RE: DR: Failure
Posted in 2001
We are running HDR on Digital unix.
Informix 7.31FC6 had a bug where HR usr to fail on secondary . It is
fixed on Informix 7.31FC7X5.
The bug was to fix the recovery problem (the secondary server is always
in fast recovery).
Thisis what we got from Informix :
The bug that we suspect is the cause of the Secondary timeout is 102170.
The description is:
Bug: 102170 DURING LOG RECOVERY IF LOGICAL RECOVERY FAILS, SERVER
SHUTDOWN WITH MSG "EXCEPTION RECURSION WHILE HANDLING: MT_EX_OS,
CONTEXT: MEM"
Description:
During log recovery, if sbspace is corrupt, engine does not come up
and following message is printed in log file:
18:29:20 Physical Recovery Complete: 57 Pages Restored.
18:29:20 Logical Recovery Started.
18:29:23 Loading Module <$INFORMIXDIR/qaudslib/string.so>
18:29:23 The C Language Module </prod/920-g/qaudslib/string.so> loaded
18:29:34 Transaction Not Found.
18:29:34 Log Record: log = 8, pos = 25126c, type = OLDRSAM:CLR(62),
trans = 7
18:29:34 Assert Failed: Rollback error 124
18:29:34 Informix Dynamic Server Version 9.20.UN516
18:29:34 Who: Session(7, root@sun5000, 0, 172968624)
Thread(20, xchg_1.0, a4c6874, 0)
File: rstrans.c Line: 2197
18:29:34 Results: Log record (OLDRSAM:HINSERT) in log 8, offset0x24f0a0 was not rolled back
18:29:34 Action: Use 'onlog' to view the transaction and repair
manually.
18:29:34 Cannot Rollforward from Checkpoint.
18:29:34 Assert Failed: No Exception Handler
18:29:34 Informix Dynamic Server Version 9.20.UN516
18:29:34 Exception Recursion while handling: MT_EX_OS, Context: mem
18:29:34 PANIC: Attempting to bring system down
-----Original Message-----
From: prufrock2000@my-deja.com [mailto:prufrock2000@my-deja.com]
Sent: Friday, January 05, 2001 9:51 AM
To: informix-list@iiug.org
Subject: Re: DR: Failure
I did do a level-0 backup of the primary and restore to the secondary
with ontape. We have been running the 7.30 release for 6 months or so,
and I'm pretty familiar with the procedures for HADR. I have _no_ idea
why this error is occuring however, I have even started entirely from
scratch, reinstalling everything and still get the same error. any other
thoughts?
In article <3A55CC91.13FDD824@alcatel.com>,
Bogdan Neagu <bogdan.neagu@alcatel.com> wrote:
> Hi prufrock2000.
>
> Try to do first a backup on the primary and restore this on the
secondary,
> to see if it works. I assume you use HDR.
>
> Bogdan Neagu
>
> prufrock2000@my-deja.com wrote:
>
> > Hello all.
> >
> > I am freshly installing Foundation2000 9.21.UC2-1 on RH6.2. These
boxes
> > were running 7.30.UC10 until about 8 hours ago _just_fine_. So after
> > installing 9.21 and importing my data, I set about configuring and
> > spinning up Data Replication. Unfortunately it is failing with the
> > following
> > from the primary:
> > 16:11:27 DR: Primary server connected
> > 16:11:27 DR: Receive error
> > 16:11:27 DR: Failure recovery error (2)
> > 16:11:29 DR: Turned off on primary server
> > 16:11:29 DR: Cannot connect to secondary server
> > 16:11:40 DR: Primary server connected
> > 16:11:40 DR: Receive error
> > 16:11:40 DR: Failure recovery error (2)
> > 16:11:42 DR: Turned off on primary server
> > 16:11:42 DR: Cannot connect to secondary server
> > 16:11:53 DR: Primary server connected> >
> > From the secondary
> > 16:11:26 DR: new type = secondary, primary server name =ifmx_mother
> > 16:11:26 DR: Trying to connect to primary server ...
> > 16:11:32 DR: Secondary server connected
> > 16:11:33 DR: Failure recovery from disk in progress ...
> > 16:11:33 DR: Failure during start of logical restore (1)
> > 16:11:33 DR: Failure recovery error (6)
> > 16:11:35 DR: Turned off on secondary server
> > 16:11:48 DR: Secondary server connected
> > 16:11:49 DR: Failure recovery from disk in progress ...
> > 16:11:49 DR: Failure during start of logical restore (1)
> > 16:11:49 DR: Failure recovery error (6)> >
> > Everything in sqlhosts, onconfig.*servername* is correct as best as
I
> > can tell. Fortunately, Informix continues to completely fail at
> > documenting it's error codes and I am at a loss as to what is
causing
> > this DR failure. Any thoughts? Anyone else running 9.21 on Linux?
Anyone
> > else think I should be shot for using this product?
> >
> > Sent via Deja.com
> > http://www.deja.com/
>
>
Sent via Deja.com
http://www.deja.com/