Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
Hi Folks,
After warm restore of one of the dbspace (say dbspace1), database does not
accept any connection with error message "can not open system catalog". As I
see from onstat -d, dbspace1 has "ND" flag and chunk has "PD". I tried to
bring the chunk online using "onspaces" return an ISAM error.
Cold restore works, however, after warm restore of the chunks that are
corrupted leaves the coresponding chunks down and no way to bring them
online. Any idea?
Thank a lot
Gursoy YERLI
↪ replying to Yerli Gursoy Contr 311 HSW/YAMO
J. Dority — — source: Informix-list mailing list archive (1991-1998)
Yerli Gursoy Contr 311 HSW/YAMO wrote:
>
> Hi Folks,
>
> After warm restore of one of the dbspace (say dbspace1), database does not
> accept any connection with error message "can not open system catalog". As I
> see from onstat -d, dbspace1 has "ND" flag and chunk has "PD". I tried to
> bring the chunk online using "onspaces" return an ISAM error.
>
> Cold restore works, however, after warm restore of the chunks that are
> corrupted leaves the coresponding chunks down and no way to bring them
> online. Any idea?
>
> Thank a lot
>
> Gursoy YERLI
I'm curious -- did you roll forward logical logs as well? I believe
this is a required step if you are to perform any type of warm restore.
J.
↪ replying to J. Dority
Art S. Kagel — — source: Informix-list mailing list archive (1991-1998)
"J. Dority" wrote:
>
> Yerli Gursoy Contr 311 HSW/YAMO wrote:
> >
> > Hi Folks,
> >
> > After warm restore of one of the dbspace (say dbspace1), database does not
> > accept any connection with error message "can not open system catalog". As I
> > see from onstat -d, dbspace1 has "ND" flag and chunk has "PD". I tried to
> > bring the chunk online using "onspaces" return an ISAM error.
> >
> > Cold restore works, however, after warm restore of the chunks that are
> > corrupted leaves the coresponding chunks down and no way to bring them
> > online. Any idea?
> >
> > Thank a lot
> >
> > Gursoy YERLI
>
> I'm curious -- did you roll forward logical logs as well? I believe
> this is a required step if you are to perform any type of warm restore.
Exactly. You should roll forward the logs and you MUST bring the instance
to full online mode (if the restore was done in quiescent mode) before
shutting it down. Not doing either of these can leave the restored chunks
and dbspaces in (D)own or (I)ncosistent mode. You can usually use
onspaces to mark the chunks and dbspace back online if they are marked 'D'
but if 'I' tech support will have to do it.
Art S. Kagel
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.