Re: Informix ESQL-Cobol on Linux (error 25507)
Posted in 2000
From: "Jim Lobley" <james.lobley@virgin.net> > >We are a software company interested in porting our application software to >a Red Hat Linux environment. Presently it runs on SCO UNIX using Informix, >ESQL-Cobol and MicroFocus Cobol. The ESQL-Cobol is a vital component of >our >software, but there are no plans for Informix to port this to Linux. Is >there any solution to this? If using Informix SE 7.10 on Linux, we execute >a Cobol program compiled under SCO and copied to Linux, it fails with an >error 25507. Can anyone help? At a guess, I'd say this was a (fixable) configuration error: You specified an unknown service name or protocol. Tell your database administrator to examine the sqlhosts file entry. Check that the NETTYPE settings in the ONCONFIG file match the NETTYPE settings in the sqlhosts file. If you are using the TCP/IP protocol, check that the correct service name appears in the /etc/services file. If you are using NFS, use ypmake to check the /etc/services file. Sometimes the daemon does not recognize service names that are added after a default boot. ______________________________________________________ Get Your Private, Free Email at http://www.hotmail.com