RE: -211 sysprocplan
Posted in 2003
I had the same problems in a 24x7 environment. I solved it by running SET OPTIMIZATION LOW; before calling the stored procedures. Since my problems were with stored procedures called from triggers, I nested the stored procedure in another stored procrdure which sets optimization low and then calls the real stored procrdure. No problems since with -211 errors on sysprocplan. Regards, Bill Dare > -----Original Message----- > From: David E. Grove [SMTP:david_grove@correct.state.ak.us] > Sent: Wednesday, May 21, 2003 8:02 PM > To: informix-list@iiug.org > Subject: -211 sysprocplan > > We run a 24x7 operation, managing the state's prison system. > > To avoid users getting -211 (sysprocplan) errors, I created a cron job > that > runs 'update statistics high', immediately followed by 'update statistics > for procedure' every night. But, users still get occasional -211 > (sysprocplan) errors. These occasional errors usually occur while the > "update statistics" jobs are actually running. The 'update statistics > high' > takes about an hour, and the 'update statistics for procedure' takes about > 7 > minutes. Since running "update statistics" is the fix, and the errors > happen during the fix, what might I do to? I'd like to eliminate -211 > errors. Does anyone have any suggestions? > > We have about 1000 tables and 1000 stored procedures in our database. > > > -- > David Grove > > - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - > "I think not," said Descartes, and disappeared. >