Unable to load locale categories
Posted in 2012
Topics: Installation, Setup & Upgrades, Stored Procedures & SPL, Connectivity: ODBC / JDBC / .NET, Server Administration, Internationalization & Character Sets
We recently had an issue with a client that has ODBC drivers on a Windows 2000 machine trying to connect to a server running Informix 9.21. The ODBC driver had been working on the client, but the client machine was shut down abruptly and has had a few issues since. One of those issues is that when it tries to connect to the database it gives the error "Unable to load locale categories." I have checked and the software is located where it should be, but I have a feeling the driver has been corrupted because the settings in SETNET32 and the driver itself look good, and I can connect to the Informix database using the same information in the ODBC driver without issue. I plan on reinstalling the ODBC driver on the server, but has anyone else come across this "Unable to load locale categories" error and remember what they did to fix it? There wasn't any error number given with this error. Keith Schleicher IT Database Administrator Cell: 224-210-8358 Blackberry: 2242108358@messaging.sprintpcs.com<mailto:2242108358@messaging.sprintpcs.com> Page: 2242108358@sprint.skytel.com<mailto:2242108358@sprint.skytel.com> For more information, use our DBA Wiki page link below: http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas e+Management> This message, including any attachments, is the property of Sears Holdings Corporation and/or one of its subsidiaries. It is confidential and may contain proprietary or legally privileged information. If you are not the intended recipient, please delete it without reading the contents. Thank you.
On Mon, Dec 3, 2012 at 6:30 PM, Schleicher, Keith < Keith.Schleicher@searshc.com> wrote: > We recently had an issue with a client that has ODBC drivers on a Windows > 2000 > machine trying to connect to a server running Informix 9.21. The ODBC > driver > had been working on the client, but the client machine was shut down > abruptly > and has had a few issues since. One of those issues is that when it tries > to > connect to the database it gives the error "Unable to load locale > categories." > I have checked and the software is located where it should be, but I have a > feeling the driver has been corrupted because the settings in SETNET32 and > the > driver itself look good, and I can connect to the Informix database using > the > same information in the ODBC driver without issue. > > I plan on reinstalling the ODBC driver on the server, but has anyone else > come > across this "Unable to load locale categories" error and remember what they > did to fix it? There wasn't any error number given with this error. > In the Unix world, 'Unable to load locale categories' usually means that $INFORMIXDIR doesn't point to somewhere with $INFORMIXDIR/gls containing valid locale information. I'm not sure how that applies to your Windows system, but I'd look at what's installed where, and whether SETNET32 is looking in the same place. -- Jonathan Leffler <jonathan.leffler@gmail.com> #include <disclaimer.h> Guardian of DBD::Informix - v2011.0612 - http://dbi.perl.org "Blessed are we who can laugh at ourselves, for we shall never cease to be amused." --047d7b3434fe72f2c304d000afe8