Restore secndary from primary fails
Posted in 2018
Topics: Backup & Restore, Storage & Space Management
Hi,
I'm trying to restore secondary from primary with ontape to STDIO piping
through ssh to secondary where I run a script with ontape -p:
ontape -s -L 0 -F -t STDIO | ssh secondary/home/informix/restore.sh;
restore.sh >> #!/bin/bash
. /home/informix/setenv.sh
ontape -t STDIO -p 2>&1but I receive error: Physical restore failed - function Invalid archive tape
failed code -1 errno 0, online.log says that archive on dbspaces was aborted
by client.
TAPEDEV
Hi Mihai.
I think you meant
ontape -s -L 0 -F -t STDIO | ssh secondary /home/informix/restore.sh
(space after "secondary", replace with your actual host name)
with restore.sh containing:
#!/bin/bash
. /home/informix/setenv.sh
ontape -t STDIO -p 2>&1
Are SSH keys in place so a password is not needed?
Test "ssh secondary" on it's own to check. See:
http://www.linuxproblem.org/art_9.html
I would try "ontape -p -t STDIO" as the order may matter.
What does the Informix message log show on secondary?
Regards,
Doug Lawry
Issue was solved. Primary had a backup filter and secondary couldn't read the backup from STDIO