RE: Problems with DR
Posted in 2000
What is your Hardware ??
We are also running HDR -Informix 7.31FC7 on DEC m/c and running into
problem, where Replication breaks n heavy load or does not start after
breaking it.
Informix told us that we are running into a recovery bug (as the
secondary is in recovery mode always). It is fixed in 7.31FC7X5 - that
is what Informix claims. We have not yet deployed that version. So no
not know. The bug number is : 102170.
Once we migrate to 7.31FCX5, I will let you know how it goes.
Niraj
-----Original Message-----
From: Helmut Leininger [mailto:h.leininger@bull.at]
Sent: Monday, December 18, 2000 8:02 AM
To: informix-list@iiug.org
Subject: Problems with DR
Hi,
we are using DR with IDS 7.31.UC5. For some reasons other than Informix
we have to restart the primary server at 4 AM every day. In most of the
cases, there is no problem, but sometimes it happens that the data
replication does not restart.
Do you have some ideas how to minimize the risk (other than "do not
restart")?
Here are the logfiles for an error:
(primary server ESCKV2, secondary server ESCKBO)
>>>>>>> online.log ESCKV2 :
Sat Dec 16 04:00:35 2000
04:00:35 Shutdown Mode
04:00:36 Quiescent Mode
04:00:37 Logical Log 11088 Complete.
04:00:37 Checkpoint Completed: duration was 0 seconds.
04:00:41 Process exited with return code 142: /bin/sh /bin/sh -c
/informix/etc/log_full.sh 2 23 "Logical Log 11088 Complete." "Logical Log 11088
Complete."
04:01:09 Informix Dynamic Server Stopped.
Sat Dec 16 04:09:07 2000
04:09:07 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
04:09:13 DR: DRAUTO is 0 (Off)
04:09:13 AIX MP latch code enabled
04:09:13 Requested shared memory segment size rounded from 796KB to800KB
04:09:13 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC
#J915528
04:09:13
04:09:13
04:09:14
04:09:16 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
04:09:17 DR: Trying to connect to secondary server ...
04:09:21 DR: Primary server connected
04:09:21
04:09:21 DR: Receive error
04:09:21 DR: Failure recovery error (2) <-Normalfall siehe Montag
18.12.
04:09:22 Physical Recovery Started.
04:09:23 Physical Recovery Complete: 0 Pages Restored.
04:09:23 Logical Recovery Started.
04:09:24 DR: Turned off on primary server
04:09:25 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
### at 07.21 ESCKVBO (secondary) Informix stopped
### Informix shutdown on ESCKV2 seems to hang
### REBOOT ESCKV2
Sat Dec 16 07:34:22 2000
07:34:22 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
07:34:28 DR: DRAUTO is 0 (Off)
07:34:28 AIX MP latch code enabled
07:34:28 Requested shared memory segment size rounded from 796KB to800KB
07:34:29 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC
#J915528
07:34:29
07:34:30
07:34:31
07:34:33 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
07:34:33 DR: Trying to connect to secondary server ...
07:36:35 DR: Cannot connect to secondary server
07:36:35 DR: Turned off on primary server
07:36:35 Physical Recovery Started.
07:36:35 Physical Recovery Complete: 0 Pages Restored.
07:36:35 Logical Recovery Started.
07:36:38 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
07:36:39 Dataskip is now OFF for all dbspaces
07:36:39 On-Line Mode
07:36:39
07:36:40 Checkpoint Completed: duration was 1 seconds.
07:37:09 Informix Dynamic Server Stopped. <- rc.online stop
Sat Dec 16 07:37:40 2000
<- rc.online start
07:37:40 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
07:37:45 DR: DRAUTO is 0 (Off)
07:37:45 AIX MP latch code enabled
07:37:45 Requested shared memory segment size rounded from 796KB to800KB
07:37:45 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC
#J915528
07:37:45
07:37:46
07:38:41
07:38:43 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
07:38:43 DR: Trying to connect to secondary server ...
07:40:45 DR: Cannot connect to secondary server
07:40:45 DR: Turned off on primary server
07:40:45 Physical Recovery Started.
07:40:45
07:40:46 Physical Recovery Complete: 0 Pages Restored.
07:40:46 Logical Recovery Started.
07:40:49 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
07:40:50 Dataskip is now OFF for all dbspaces
07:40:50 On-Line Mode
07:40:50 Checkpoint Completed: duration was 0 seconds.
07:43:47 DR: Primary server connected
07:43:48 DR: Sending log 11089 (current), size 2500 pages, 0.12 percentused
07:43:51 DR: Sending Logical Logs Completed
07:43:52 DR: Primary server operational
07:43:52 DR: LBU_PRESERVE turned on while primary
07:43:53 Checkpoint Completed: duration was 0 seconds.
>>>>>>>> online.log ESCKVBO :
Sat Dec 16 04:00:37 2000
04:00:37 Checkpoint Completed: duration was 0 seconds.
04:01:09 DR: Receive error
04:01:10 DR: Receive Btree error
04:01:10 DR: Turned off on secondary server
04:09:21 DR: Server state incompatible <-Normalfall siehe Montag
18.12.
07:21:31 Informix Dynamic Server Stopped. <- rc.online_o2e stop
Sat Dec 16 07:43:30 2000
<- rc.online_o2e start
07:43:30 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
07:43:35 DR: DRAUTO is 0 (Off)
07:43:35 AIX MP latch code enabled
07:43:35 Requested shared memory segment size rounded from 796KB to800KB
07:43:36 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC
#J915528
07:43:36
07:43:36
07:43:37
07:43:39 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
07:43:39 DR: Logs already cleared
07:43:39 DR: Trying to connect to primary server ...
07:43:43 Physical Recovery Started.
07:43:43 Physical Recovery Complete: 0 Pages Restored.
07:43:43 Warning: Logging dbspace 'dbs1' ignored in DBSPACETEMP on DRsecondary
.
07:43:43 Dataskip is now OFF for all dbspaces
07:43:43 Recovery Mode
07:43:47
07:43:47 DR: Secondary server connected
07:43:48 DR: Failure recovery from disk in progress ...
07:43:50 Logical Recovery Started.
07:43:50 Warning: Logging dbspace 'dbs1' ignored in DBSPACETEMP on DRsecondary
.
07:43:50 Start Logical Recovery - Start Log 11089, End Log ?
07:43:50 Starting Log Position - 11089 0x18
07:43:51 Checkpoint Completed: duration was 0 seconds.
07:43:51 Checkpoint Completed: duration was 0 seconds.
07:43:52 DR: Secondary server operational
07:43:53 Checkpoint Completed: duration was 0 seconds.
>>>>> to compare a case without problem:
>>>>> online.log ESCKV2
Mon Dec 18 04:00:28 2000
04:00:28 Shutdown Mode
04:00:29 Quiescent Mode
04:00:29 Logical Log 11089 Complete.
04:00:31 Checkpoint Completed: duration was 0 seconds.
04:00:34 Process exited with return code 142: /bin/sh /bin/s