Can not connect to database
Posted in 2001
Topics: Error Codes & Troubleshooting, Networking & sqlhosts Configuration, Platform-Specific Issues
We have 2 boxes. Linux box running Informix 7.30 HP box running Informix 7.23 From the Linux box I am able to connect to the HP box. However from the HP box I am not able to connect to the Linux box. The error I get is 908 and the ISAM error is 22 (invalid argument). What can be the cause? I am able to ping both the machines from each other. Both servers are running on seperate services. HP box is running on turbo (1526/tcp) and linux on turbo2 (1527/tcp). Appropriate entry is made in /etc/services and /etc/sqlhosts of the both the boxes with regards to turbo and turbo2. TIA.
Hi,
first, I don't the way you've tried to
establish the connection.
Distributed query
or
dbaccess database
or
dbaccess using the connect option from the menu.
I guess it's a missing entry in the
.rhosts file on the linux-box or you have entered
a wrong portnumber in the sqlhosts file
on the hp-box. ( There's no need to use
different port-numbers on different boxes.
It's just neccessary to use different port-numbers
on two IDS instances on the SAME box ).
Best regards,
--
Stefan Weideneder
Phone: +49 89/3565478-2 ---------------
--- Fax: +49 89/3565478-3 -------------
------ mailto:/stefan at weideneder.de ---
-------- http://www.weideneder.de -----