RE: Initialization-Error
Posted in 2000
If you want to bring the Informix Engine online for the first time you must use oninit -i to initialize the rootdbs.
-----Original Message-----
From: Thomas Stainer [SMTP:tstainer@styria.com]
Sent: Tuesday, June 13, 2000 10:44 AM
To: informix-list@iiug.org
Subject: Initialization-Error
I'm trying to initialize an Informix 7.30 UC6 instance for testing on an
HP715 workstation (128 MB RAM):
Therefore I've created a cooked device (dd if.... bs... count...
of=rootdbs), set the ownership and rights to informix:informix resp. 660
and configured all the rest (as it is realised on our HP9000/800 K360/4
except some kernel parameters adjusted to the smaller platform I wish to
install IDS).
Whenever I type in an "oninit" the systems returns the error message
"Cannot open chunk ..... errno = 2" and the online.log tells me:
17:41:00 Event alarms enabled. ALARMPROG =
'/home/informix/etc/log_full.sh'
17:41:06 DR: DRAUTO is 0 (Off)
17:41:07 Informix Dynamic Server Version 7.30.UC6 Software SerialNumber XXX#123456
17:41:07 Assert Failed: chunk failed sanity check
17:41:07 Informix Dynamic Server Version 7.30.UC6
17:41:07 Who: Session(1, user@host, 0, 0)
Thread(7, main_loop(), 0, 1)
File: rspartn.c Line: 6882
17:41:07 Results: Chunk 1 is being taken OFFLINE.
17:41:07 Action: Restore chunk from archive.
17:41:09 See Also: /usr1/informix/tmp/af.75612
17:41:09 I/O error, Primary Chunk '/dev/rootdbs' -- Offline (sanity)
17:41:10 Informix Dynamic Server Stopped.
17:41:10 mt_shm_remove: WARNING: may not have removed all/correctsegments
How can I get the rootdbs online ?!? Has anybody (I'm sure there is) the
slightest idea what to do in such a case?
thanx for help
thomas
-------------------------------------------------
Thomas Stainer - tstainer@styria.com