Linux: Error -25580, System Error Occured in Network Function
Posted in 2000
Topics: Performance & Tuning, Connectivity: ESQL/C, 4GL & Embedded SQL, Platform-Specific Issues, Versions, Editions & End-of-Life
I'm intermittently getting the -25580 error (system error occured in network function). It occurs from update or insert-intensive client ESQL/C programs connecting to the Informix server over my Ethernet LAN. It does not occur when the same program is run directly on the Informix server (shared memory). The server is a Linux system, AMD K6-2-333, 128MB, SCSI disk, Linux 2.2.13, IDS 7.30-UC7. I had similar problems on the same hardware, with Linux 2.0.36 and IDS 7.30-UC5. The clients are AIX 4 systems and Windows NT systems. I've tried various combinations of 7.1, 7.2, and 7.3 clients and ESQL/C versions. All fail. The error occurs at random points in the process, usually after 5 to 15 minutes. There is nothing interesting in online.log or in the system logs. Performance is generally very good. I don't see any problems with selects or with other functions on the Linux box. The NETTYPE settings in the Informix server are: ipcshm,1,5,CPU soctcp,5,1,NET I've tried other soctcp combinations, with similar results. There are no other user connections at the time of the error. Obviously I'm asking if anyone knows what might be going on. I'm thinking it's more likely to be Linux or the hardware than Informix. I had suspected a CPU/memory problem in the Linux system, but since the process runs to completion when run through shared memory, I'm dropping that line. My next attempt will be to replace the Ethernet card in the Linux system. Currently it as a Netgear FA410TX (DEC Tulip), which I have no reason to suspect, but you do what you can. I'll get a 3Com card and try that.
Hi Dwight,
it is Informix. Upgrading to UC10 helps somewhat. The following entry in
the onconfig also
MULTIPROCESSOR 0 # 0 for single-processor, 1 formulti-processor
NUMCPUVPS 1 # Number of user (cpu) vps
SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vpsto one
But the problem doesn't go away completely.
I suspect it's a deadlock in Informix locking.
Brgds
Peter
Dwight Rudolph Jr schrieb:
>
> I'm intermittently getting the -25580 error (system error occured in network
> function). It occurs from update or insert-intensive client ESQL/C programs
> connecting to the Informix server over my Ethernet LAN. It does not occur
> when the same program is run directly on the Informix server (shared memory).
>
> The server is a Linux system, AMD K6-2-333, 128MB, SCSI disk, Linux 2.2.13,
> IDS 7.30-UC7. I had similar problems on the same hardware, with Linux 2.0.36
> and IDS 7.30-UC5.
Thank you. I already have the settings below, and I will also try playing
with the number of network VPs. I'll see if I can find UC10 and install it
too.
In article <38844C5B.6D1C3B1A@transcom.de>, Peter.Eckhardt@transcom.de says...
>
>Hi Dwight,
>
>it is Informix. Upgrading to UC10 helps somewhat. The following entry in
>the onconfig also
>
>MULTIPROCESSOR 0 # 0 for single-processor, 1 for>multi-processor
>NUMCPUVPS 1 # Number of user (cpu) vps
>SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vps>to one
>
>But the problem doesn't go away completely.
>I suspect it's a deadlock in Informix locking.
>
>Brgds
>Peter
>
>
>Dwight Rudolph Jr schrieb:
>>
>> I'm intermittently getting the -25580 error (system error occured in
network
>> function). It occurs from update or insert-intensive client ESQL/C
programs
>> connecting to the Informix server over my Ethernet LAN. It does not occur
>> when the same program is run directly on the Informix server (shared
memory).
>>
>> The server is a Linux system, AMD K6-2-333, 128MB, SCSI disk, Linux 2.2.13,
>> IDS 7.30-UC7. I had similar problems on the same hardware, with Linux
2.0.36
>> and IDS 7.30-UC5.
I upgraded to 7.30.UC10, changed my nettype settings, and changed my Ethernet
card to a 3C905 (the last almost certainly not necessary, but it was easy).
The -25580 error has become less frequent, but as Peter Eckhardt expected, it
has not gone away. At the time of the error there were no other Informix
client connections, but of course there are all those oninit processes running
around...
I'm going to try a couple other things but I'm thinking we're stuck with this.
dwight rudolph
In article <38844C5B.6D1C3B1A@transcom.de>, Peter.Eckhardt@transcom.de says...
>
>Hi Dwight,
>
>it is Informix. Upgrading to UC10 helps somewhat. The following entry in
>the onconfig also
>
>MULTIPROCESSOR 0 # 0 for single-processor, 1 for>multi-processor
>NUMCPUVPS 1 # Number of user (cpu) vps
>SINGLE_CPU_VP 1 # If non-zero, limit number of cpu vps>to one
>
>But the problem doesn't go away completely.
>I suspect it's a deadlock in Informix locking.
>
>Brgds
>Peter
>
>
>Dwight Rudolph Jr schrieb:
>>
>> I'm intermittently getting the -25580 error (system error occured in
network
>> function). It occurs from update or insert-intensive client ESQL/C
programs
>> connecting to the Informix server over my Ethernet LAN. It does not occur
>> when the same program is run directly on the Informix server (shared
memory).
>>
>> The server is a Linux system, AMD K6-2-333, 128MB, SCSI disk, Linux 2.2.13,
>> IDS 7.30-UC7. I had similar problems on the same hardware, with Linux
2.0.36
>> and IDS 7.30-UC5.