URGENT: Temporary Work Space
Posted in 2000
Topics: SQL Development & Query Writing, Error Codes & Troubleshooting, Platform-Specific Issues, Versions, Editions & End-of-Life
I know this has been discussed before, but I have a client who is suffering error -264 when running quite a complex Ace report using multiple selects into temporary tables followed by a large select with many outer joins. My question is this :- How do I find out which area (UNIX/Informix) their environment is using for sort/temporary workspace whilst the Ace report is running. Any help would be much appreciated as their application is currently unusable. After rebooting the UNIX server (and thus the engine), the FIRST run of the program appears to be successful but all subsequent runs fail with -264. It's almost as if some temporary area is not being cleared down, but I need to be more scientific in my investigations. Regards Glyn Balmer HP-UX 10.20 IDS 7.31 ISQL 7.20 -264 Could not write to a temporary file. The database server created a temporary file in the directory that the DBTEMP environment variable (or /tmp by default on UNIX systems) specifies, but it encountered an error when it tried to write data into the file. Check the accompanying ISAM error code, and look for operating-system error messages that might give more information. Possibly a hardware failure occurred, or the disk is full. Since Version 5.01, the INFORMIX-SE database server uses the DBTEMP environment variable, but Informix Dynamic Server and INFORMIX-OnLine Dynamic Server do not. -- If it always works, why don't parachutists pull the emergency 'chute first? Sent via Deja.com http://www.deja.com/ Before you buy.
Eric The Half A Bee wrote:
>
> I know this has been discussed before, but I have a client who is
> suffering error -264 when running quite a complex Ace report using
> multiple selects into temporary tables followed by a large select with
> many outer joins. My question is this :- How do I find out which area
> (UNIX/Informix) their environment is using for sort/temporary workspace
> whilst the Ace report is running. Any help would be much appreciated as
> their application is currently unusable. After rebooting the UNIX
> server (and thus the engine), the FIRST run of the program appears to
> be successful but all subsequent runs fail with -264. It's almost as if
> some temporary area is not being cleared down, but I need to be more
> scientific in my investigations.
>
> Regards
>
> Glyn Balmer
>
> HP-UX 10.20
> IDS 7.31
> ISQL 7.20
>
> -264 Could not write to a temporary file.
>
snip
Use the environment Variable PSORT_DBTEMP:
$ export PSORT_DBTEMP=/home/where_you_have_lot_of_diskspace
$ oninit
regards
Markus
One quick mention... if you are not creating your temp tables with the "with no log" option, by default, you will create those temp tables in rootdbs. The reason is that temp space isn't logged, so if the tables are to be logged, you can't create them in temp space. This is likely NOT your problem, but you might want to check it out. It bit me a while ago in diagnosing a problem... HTH -- Dan Michaelis Database Administrator dan@kax.com Sent via Deja.com http://www.deja.com/ Before you buy.
Related threads
- Re: oninit: Dictionary Cache and SPL Routine Cache error
- Re: oninit: Dictionary Cache and SPL Routine Cache error
- Help Needed in Phoenix
- INFORMIX 9.40 LINUX