Illegal key descriptor (isam error 103)
Posted in 2004
This is a multi-part message in MIME format.
------=_NextPart_000_01A9_01C40C08.38514B60
Content-Type: text/plain;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
Hi All
I am not getting any replay from the classis-list, but most of you must =
have grown from SE to Online.
Maybe you can help.
We are running Informix SE=20
SCO Unix vers 5.0.5
Informix SE 5.08.UD1
SQL vers 4.17.UC1
RDS vers 4.17.UC1
on a Pentium Pro with a SCSI hd and 128meg ram.=20
When I try running a sql script (wild select) on a table:
select * from tab
I get error -1201 Number is too small for a DECIMAL data type. =
=20
The DECIMAL data type accommodates numbers from 10-130
through 10124 in absolute value. The precision (number of significant =
digits)=20
varies from 1 to 32; however the source of this error is not in
the length of the number but in its magnitude.
What are it trying to tell me????
If I change the select to include a where part I recieve the following =
error:
245: Could not position within a file via an index. =
=20
103: ISAM error: illegal key descriptor (too many parts or too long).
But if I change the select to (select field01 from tab) it returns =
output.
If I change the select to (select field01,(price*1) from tab) it works. =
Price is define as a float.
So this could be a problem with NULLS? and I can live with it, but hiw =
do I solve
isam error 103 when using a where part in the select ?
Plz help!!!!!!!!!!!!!!!
------=_NextPart_000_01A9_01C40C08.38514B60
Content-Type: text/html;
charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2800.1106" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Hi All</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>I am not getting any replay from the =
classis-list,=20
but most of you must have grown from SE to Online.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>Maybe you can help.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>We are running <FONT face=3D"Times New =
Roman"=20
size=3D3>Informix SE </FONT></FONT></DIV>
<DIV><FONT face=3DArial size=3D2><FONT face=3D"Times New Roman" =
size=3D3>SCO Unix vers=20
5.0.5<BR>Informix SE 5.08.UD1<BR>SQL vers 4.17.UC1<BR>RDS vers=20
4.17.UC1<BR></FONT></FONT><FONT face=3DArial size=3D2><FONT =
face=3D"Times New Roman"=20
size=3D3>on a Pentium Pro with a SCSI hd and 128meg=20
ram. </FONT></FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV>When I try running a sql script (wild select) on a table:</DIV>
<DIV>select * from tab</DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV>I get error -1201 Number is too small for a =
DECIMAL data=20
type. &n=
bsp; &nb=
sp; =20
<BR><BR>The DECIMAL data type accommodates numbers from 10-130</DIV>
<DIV>through 10124 in absolute value. The precision (number of=20
significant digits) </DIV>
<DIV>varies from 1 to 32; however the source of this error is not =
in<BR>the=20
length of the number but in its magnitude.</DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>What are it trying to tell =
me????</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>If I change the select to include a =
where part I=20
recieve the following error:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>245: Could not position within a file =
via an=20
index. &=
nbsp; &n=
bsp; <BR>103:=20
ISAM error: illegal key descriptor (too many parts or too=20
long).</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>But if I change the select to (select =field01 from=20
tab) it returns output.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>If I change the select to (select =
field01,(price*1)=20
from tab) it works. Price is define as a float.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>So this could be a problem with NULLS? =
and I can=20
live with it, but hiw do I solve</FONT></DIV>
<DIV><FONT face=3DArial size=3D2>isam error 103 when using a where part =
in the=20
select ?</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV>
<DIV><FONT face=3DArial size=3D2>Plz help!!!!!!!!!!!!!!!</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT> </DIV></BODY></HTML>
------=_NextPart_000_01A9_01C40C08.38514B60--
sending to informix-list