Informix 7.3 on Linux -25580 Error
Posted in 2000
Topics: Performance & Tuning, Installation, Setup & Upgrades, Networking & sqlhosts Configuration, Platform-Specific Issues
I am experiencing intermittent -25580 errors from client programs
accessing an Informix server on Linux. -25580 translates to 'system
error in network function', which doesn't tell me much. I have been
getting these for several months, have tried a number of things, and
haven't made it go away.
I need them to go away, as this is my development environment, and I can't
have things that run for two hours then crash randomly when I'm
billing for those hours. I have an old copy of Informix Workgroup Server
7.23 for NT, and I am now considering building the fastest NT system I
can (NT4 SP3 as this software broke after SP3). I know the fastest NT
system I can build won't match a mediocre Linux system but I have to
lose this problem.
Before I do that, does anyone definitively know what causes the -25580
errors on Linux or how to get rid of them?
Details.
The problem only occurs with client connections across the network. It
is a local network and I do not believe there is actually a network problem.
It does not occur when the program is run directly on the Linux box,
using a shared memory connection, but I need for AIX and NT programs
to work.
The Linux system is running 2.2.15. It started on 2.0.36 and has been
upgraded as new versions came out. I have had the problem at 2.0.36 and all
intervening versions. The system has 128MB memory and is doing very little
paging. It is an AMD K6-2-333 system, generic motherboard, and I have
reason to believe the hardware is okay.
The Informix version is 7.30.UC10-1, which is the latest thing I can find
at Intraware. I have tried several versions and all exhibit the problem.
The pertinent performance tuning is
LOCKS 20000 BUFFERS 30000 (there is adequate memory for this)
MULTIPROCESSOR 0
NUMCPUVPS 1
SINGLE_CPU_VP 1
NETTYPE ipcshm,1,10,CPU
NETTYPE soctcp,1,10,NET
I've tried many variations. The only one that seems to work is no icpshm
NETTYPE, and soctcp NETTYPE running in CPU, but that variation is very slow.
Clients are connecting from AIX and NT, several versions of client SDK
including 2.40, all over TCP/IP.
Thank you,
Dwight Rudolph
dwight@rudolph.com
dwight@rudolph.com (Dwight Rudolph Jr) writes: > The Informix version is 7.30.UC10-1, which is the latest thing I can find > at Intraware. I have tried several versions and all exhibit the problem. Well, unless you're like me and have clients on 7.[23]x, you might pony up some more dough and try 9.20 (aka IDS.2000). My conclusion is that IDS 7.x on Linux isn't ready for prime time. I haven't tried 9.2x, though (once bitten, twice shy). -- Forte International, P.O. Box 1412, Ridgecrest, CA 93556-1412 Ronald Cole <ronald@forte-intl.com> Phone: (760) 499-9142 President, CEO Fax: (760) 499-9152 My GPG fingerprint: C3AF 4BE9 BEA6 F1C2 B084 4A88 8851 E6C8 69E3 B00B