Re: Informix - IIS4 - ODBC - Intersolv
Posted in 1998
I've had the same problem, but it was solved by configuration: ODBC data source must be created as a SYSTEM datasource and not a USER datasource. This means the datasource is available to all users of the NT system, including IIS. INFORMIXDIR must be set in SYSTEM environment vars (control panel / system tab). INFORMIXDIR also must be in SYSTEM PATH. (as opposed to current USER's path.) Hope this helps. Mike Lester USAA Investment Management Co. john_kilgo@nettally.com wrote in message <35328889.2159354@news.nettally.com>... >On Mon, 13 Apr 1998 13:55:50 -0600, jeverson@erac.com wrote: > >>I'm running IIS4 on a NT 4.0 machine with ASP. Currently I'm using SQL Server >>as my database and all seems to work fine. The problem is we are going to be >>changing to Informix as our database and all doesn't work fine. I have used >>the Informix I-Connect product, setup everything with SETNET and installed >>Intersolv's version 3 Informix driver. At the web server I can connect to the >>Informix database just fine if I use the ODBC datasource through MS Access, >>however if I try to connect from a client using the same ODBC datasource I get >>the error: >> >>Microsoft OLE DB Provider for ODBC Drivers error '80004005' >> >>Specified driver could not be loaded due to system error 126 (INTERSOLV 3.01 >>32-BIT INFORMIX). >> >>I have checked the permissions in the Registry to the Informix and Intersolv >>areas and made sure that the users have Full Control the the areas. Infomix >>hasn't been able to help. >> >>Any help you can give me would be great. >>Thanks. > >I'm at home now, and don't have the docs, but I believe the INTERSOLV >documentation (not Informix) says something about the error 126 and >what to do about it. If you don't have INTERSOLV documentation, you >can go to their web site and download a 30 day eval of the DataDirect >drivers. There is a readme or two in the package and, if I remember >correctly, there is something about error 126 >