Re: SCO & INFORMIX:Network driver cannot bind a name with the port
Posted in 1999
Topics: Installation, Setup & Upgrades, Connectivity: ESQL/C, 4GL & Embedded SQL, Networking & sqlhosts Configuration
Alex
What are your NETTYPE config variables set to? That determines the number
of user threads that can be allocated.
HTH
Sujit
Alex Barilo <alex.barilo@phila.gov> on 05/18/99 12:12:28 PM
Please respond to Alex Barilo <alex.barilo@phila.gov>
To: informix-list@iiug.org
cc: (bcc: Sujit Pal)
Subject: SCO & INFORMIX:Network driver cannot bind a name with the port
Hi people,
hope someone will be able to help me.
OS: SCO Open Server 5.0.5 with rs505a supplement DSBM: INFORMIX Dynamic
Server 7.3 Hardware: HP NetServer LH4 with 2 NICs (HP Netserver 10/100 TX
(main) and Intel EtherExpress PRO/100B), drivers for NICs: first one was
dowloaded from SCO site (as far as I remember), the second one came with
the
card. Both installed without any glitch.
Problem:
We are running our main application wich is a series of 4ge files invoked
from main 4ge. Each 4ge connects to the database and we used Informix
shared
memory service to connect to the engine ($INFORMIXSERVER,
$INFORMIXDIR/etc/sqlhosts and /etc/services). When we got close to 70+
userthreads (onstat -u) we started having the following error in informix
log:
13:55:30 listener-thread: err = -25572: oserr = 4: errstr = : Networkdriver
cannot bind a name to the port. System error = 4.
We called Informix and they suggested to use tcp service to connect to the
engine. We did and got problem under approaching to 65+ userthreads.
We eneded up with a script which toggles INFORMIXSERVER variable between
tcp
and shared during their logon. This allowed us to have up to 218
userthreads
this morning. Which is not sufficient getting worse - we have 149 user
threads at the moment and no one can connect to the engine with the error:
4GL run-time error number -25588. The appl process cannot connect to
Dynamic
server <$INFORMIXSERVER>.
and informix log gets one more above line.
We did follow Informix directions in its release docs about kernel
parameters. We checked and it seems there are no services conflicts. tcp/ip
works fine. The box has 11 logical drives and hd major numbers go to 154
not
allowing us to use AIO and SUDS. We found one curious thing: when we were
using just one service the last line of onstat -u looked like:
72 active, 128 total, 112 maximum concurrent
and now, with 2 services, it looks like:
146 active, 256 total, 218 maximum concurrent
mind 128 and 256 what supposed to increment automatically even with one
service.
Do we have problems with number of connections per service?
Any ideas?
Thank you,
Alex.
--
Before the accident, I even could not spell UNIX
--== Sent via Deja.com http://www.deja.com/ ==--
---Share what you know. Learn what you don't.---
In article <7hsvs5$3up$1@news.xmission.com>,
Sujit.Pal@BankAmerica.com wrote:
> Alex
>
> What are your NETTYPE config variables set to? That determines the number
> of user threads that can be allocated.
Sujit,
it was:
NETTYPE ipcshm,3,400,CPU
Informix support adviced us to change it to:
2,250
still doesn't help. The amount of total threads in onstat -u increases
automatically from 128 to 256 when we hit 129 thread but it doesn't when we
are trying to go above that. I found USERTHREADS parmeter in Informix doc and
set it to 512 in onconfig - same result :( Is it ignored? SHMTOTAL set to 0,
meaning 'unlimited'. Hmmm, hopefully...
Alex.
--
Before the accident, I even could not spell UNIX
--== Sent via Deja.com http://www.deja.com/ ==--
---Share what you know. Learn what you don't.---
We had an error that sounds very familiar to yours. It's an old SCO bug
that requires a link as follows:
link /dev/inet/tcp /dev/tcp
Try this, before breaking your head with all the other fancy fixes ...
In article <7i3l62$o85$1@nnrp1.deja.com>,
Alex Barilo <alex.barilo@phila.gov> wrote:
> In article <7hsvs5$3up$1@news.xmission.com>,
> Sujit.Pal@BankAmerica.com wrote:
>
> > Alex
> >
> > What are your NETTYPE config variables set to? That determines the
number
> > of user threads that can be allocated.
>
> Sujit,
>
> it was:
>
> NETTYPE ipcshm,3,400,CPU>
> Informix support adviced us to change it to:
>
> 2,250
>
> still doesn't help. The amount of total threads in onstat -u increases
> automatically from 128 to 256 when we hit 129 thread but it doesn't
when we
> are trying to go above that. I found USERTHREADS parmeter in Informix
doc and
> set it to 512 in onconfig - same result :( Is it ignored? SHMTOTAL set
to 0,
> meaning 'unlimited'. Hmmm, hopefully...
>
> Alex.
> --
> Before the accident, I even could not spell UNIX
>
> --== Sent via Deja.com http://www.deja.com/ ==--
> ---Share what you know. Learn what you don't.---
>
--== Sent via Deja.com http://www.deja.com/ ==--
---Share what you know. Learn what you don't.---