RE: Connecting from SCO Unix to an Informix database running on W
Posted in 1999
Having you tried running a truss on it? That will tell the exact device
it's trying to open and in which mode.
I agree with Art that everything points to some network configuration
problem. Is there an accompanying isam error, anything in
/var/adm/messages. Is the OS patched as per the release notes?
A long shot would be to try and move the service number to below 1024. I've
only ever seen this make a difference on a Sun box running a secure network.
Like I said a long shot.
>
> "Art S. Kagel" <kagel@bloomberg.net> wrote:
>
> >Limis BV wrote:
> >>
> >> I'm trying to make a connection from a SCO UNIX machine
> >> to a Informix database running on Windows NT, but I get
> >> the following Informix error message on the Unix machine
> >> when I try to connect to the database:
> >>
> >> -25574 Networkdriver cannot open the network device
> >>
> >> What is going wrong ?
> >> Should there be anything installed/enabled ?
> >>
> >> I'm using the following settings on the Unix machine:
> >>
> >> $INFORMIXDIR/etc/sqlhosts:
> >>
> >> ol_asterix ontlitcp asterix turbo> >>
> >> /etc/services:
> >>
> >> turbo 1526/tcp
> >> srv_agent 1530/tcp
> >>
> >> OS specs:
> >>
> >> SCO UNIX 3.2v5.0.4
> >> Windows NT 4.0 Server
> >> Informix ODS 7.22.TC1
>
> >Can you do anything else network-y on that SCO box? Can you ping
> >asterix? Is asterix listed in /etc/hosts? SCO does not come with
> >networking enabled by default you have to install the
> networking option.
>
> That's not the problem the SCO machine already runs more than 5 years
> in a network with other unix and windows machines.
>
> I think the problem is that informix does a system call and fails.
> The question is what call it makes (to with service/device) ?
>
> If anyone can answer me this question, I can check if that
> service/device
> is present on the SCO machine.
>
> >Art S. Kagel
>
>