RE: Oninit failure
Posted in 2000
How did you reinstall the instance?
does /INFORMIXTMP exist?
If you just did a tar restore, /INFORMIXTMP needs to exist as well
as some logical links in /usr/lib
I am not sure what happens if INFORMIXTMP does not exist. (maybe this?)
if it does exist, does informix have write permissions to it?
I dont have 7.24 here, but there is a .infxdirs file in the /INFORMIXTMP
directory.
I can not figure out why it claims to be looking in /etc.
Hope this helps,
Will
>===== Original Message From "Farmer, Byrd G - CFC" <Farmer.Byrd@cfwy.com>
=====
>We has a disk drive crash on out test server. It has been corrected and
>Informix 7.24UC3 has been reinstalled. When we try to bring up the engine
>we get the following error messages during the oninit -v
>
>[048]/export/home/informix/>oninit -v
>Reading configuration file
>'/usr/informix/7.24.UC3/etc/onconfig.cf'...succeeded
>Creating /etc/.infxdirs ... FAILED
>Creating infos file "/usr/informix/7.24.UC3/etc/.infos.pcotest" ...
>"/usr/inform
>ix/7.24.UC3/etc/.conf.pcotest" ... succeeded
>Writing to infos file ... succeeded
>Checking config parameters...succeeded
>Allocating and attaching to shared memory...FAILED
>oninit: Fatal error in shared memory creation
>
>
>Can anyone help explain the "creating /etc/.infxdirs....FAILED" message?
>This database was working fine last week.
------------------------------------------------------------
This e-mail has been sent to you courtesy of OperaMail, as a free service from
Opera Software, makers of the award-winning Web Browser, Opera. Visit us at
http://www.opera.com/ or our portal at: http://www.myopera.com/ Your free e-mail
account is waiting at: http://www.operamail.com/
------------------------------------------------------------