Auto-shutdown not working
Posted in 2009
IDS 10.00.FC9 on a HP BL870c running HPUX B.11.23 (ia64) I'm trying to setup the replacement server for our current HPUX production server and ran into a weird situation that I can't figure out the cause. When I shutdown or reboot the server the checklist shows Stopping the Informix database subsystem .... N/A It should be processing the shutdown script. This is the same script it runs at startup and it properly starts IDS. is the script _ I haven't made any changes to it /etc/rc.config.d/informix has INFORMIX=1 /sbin/rc2.d lrwxrwx--- 1 root common 21 Feb 23 10:49 K500informix -> /sbin/init.d/informix /sbin/rc3.d lrwxrwx--- 1 root common 21 Feb 23 10:50 S500informix -> /sbin/init.d/Informix What am I missing? The script states you need to be sending it a 2 to get the N/A, but everything I see shows I'm sending a 1. # Allowed exit values: # 0 = success; causes "OK" to show up in checklist. # 1 = failure; causes "FAIL" to show up in checklist. # 2 = skip; causes "N/A" to show up in the checklist. # Use this value if execution of this script is overridden # by the use of a control variable, or if this script is not # appropriate to execute for some other reason. # 3 = reboot; causes the system to be rebooted after execution. # 4 = background; causes "BG" to show up in the checklist. # Use this value if this script starts a process in background mode. Suggestions????????? John