Connectiom Manager help needed
Posted in 2009
Topics: High Availability & Replication, Networking & sqlhosts Configuration, Platform-Specific Issues, Clustering, Grid & MACH11
Greetings,
I am getting an error when attempting to start the second CM in the
following configuration:
2 identical IBM P6-550 servers, AIX 6.1, IDS 11.5.FC3 (server asp5_be
is the Primary and asp6_be is the HDR in an HDR pair)
oncmsm_1.cfg (on asp5_be)
NAME oncsm_1
SLA oltp=PRI
DEBUG 1
LOGFILE path/cmsm_1.log
FOC HDR,10
oncmsm_2.cfg (on asp6_be)
NAME oncsm_1
SLA oltp=PRI
DEBUG 1
LOGFILE path/cmsm_1.log
FOC HDR,10
sqlhosts.aspbeL1 (on asp5_be)
# ASP5_BE
aspbeL1 onipcshm asp5_be aspbeL1 # aspbeL1_live onsoctcp asp5_be aspbeL1_live
hdr1P_be onsoctcp asp5_be hdr1P_be s=6
# ASP6_BE
# hdr1 onipcshm asp6 hdr1
# hdr1_live onsoctcp asp6_be hdr1_live
hdr1S_be onsoctcp asp6_be hdr1S_be s=6
# All servers in HDR configuration
g_mach group -
- e=hdr1_live
aspbeL1_live onsoctcp asp5_be aspbeL1_live
g=g_mach
hdr1_live onsoctcp asp6_be hdr1_live
g=g_mach
# Connection Manager - oncmsm_1
oltp group -
- e=oltp_cm2
oltp_cm1 onsoctcp asp5_be cmport1
g=oltp
oltp_cm2 onsoctcp asp6_be cmport2
g=oltp
sqlhosts.aspbeL1 (on asp6_be)
# ASP5_BE
# aspbeL1 onipcshm asp5_be aspbeL1
# aspbeL1_live onsoctcp asp5_be aspbeL1_live
hdr1P_be onsoctcp asp5_be hdr1P_be s=6
# ASP6_BE
hdr1 onipcshm asp6 hdr1 # hdr1_live onsoctcp asp6_be hdr1_live
hdr1S_be onsoctcp asp6_be hdr1S_be s=6
# All servers in HDR configuration
g_mach group -
- e=hdr1_live
aspbeL1_live onsoctcp asp5_be aspbeL1_live
g=g_mach
hdr1_live onsoctcp asp6_be hdr1_live
g=g_mach
# Connection Manager - oncmsm_1
oltp group -
- e=oltp_cm2
oltp_cm1 onsoctcp asp5_be cmport1
g=oltp
oltp_cm2 onsoctcp asp6_be cmport2
g=oltp
Tom wrote:
> Greetings,
>
> I am getting an error when attempting to start the second CM in the
> following configuration:
>
> 2 identical IBM P6-550 servers, AIX 6.1, IDS 11.5.FC3 (server asp5_be
> is the Primary and asp6_be is the HDR in an HDR pair)
>
> oncmsm_1.cfg (on asp5_be)
> NAME oncsm_1
> SLA oltp=PRI
> DEBUG 1
> LOGFILE path/cmsm_1.log
> FOC HDR,10
>
> oncmsm_2.cfg (on asp6_be)
> NAME oncsm_1
> SLA oltp=PRI
> DEBUG 1
> LOGFILE path/cmsm_1.log
> FOC HDR,10
>
> sqlhosts.aspbeL1 (on asp5_be)
> # ASP5_BE
> aspbeL1 onipcshm asp5_be aspbeL1> # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> # ASP6_BE
> # hdr1 onipcshm asp6 hdr1
> # hdr1_live onsoctcp asp6_be hdr1_live
> hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> # All servers in HDR configuration
> g_mach group -
> - e=hdr1_live
> aspbeL1_live onsoctcp asp5_be aspbeL1_live
> g=g_mach
> hdr1_live onsoctcp asp6_be hdr1_live
> g=g_mach>
> # Connection Manager - oncmsm_1
> oltp group -
> - e=oltp_cm2
> oltp_cm1 onsoctcp asp5_be cmport1
> g=oltp
> oltp_cm2 onsoctcp asp6_be cmport2
> g=oltp>
> sqlhosts.aspbeL1 (on asp6_be)
> # ASP5_BE
> # aspbeL1 onipcshm asp5_be aspbeL1
> # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> # ASP6_BE
> hdr1 onipcshm asp6 hdr1> # hdr1_live onsoctcp asp6_be hdr1_live
> hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> # All servers in HDR configuration
> g_mach group -
> - e=hdr1_live
> aspbeL1_live onsoctcp asp5_be aspbeL1_live
> g=g_mach
> hdr1_live onsoctcp asp6_be hdr1_live
> g=g_mach>
> # Connection Manager - oncmsm_1
> oltp group -
> - e=oltp_cm2
> oltp_cm1 onsoctcp asp5_be cmport1
> g=oltp
> oltp_cm2 onsoctcp asp6_be cmport2
> g=oltp>
> From the /etc/services file - same on both servers:
> ....
> hdr1P_be 9081/tcp
> apsbeL1_live 9082/tcp
> hdr1S-be 9083/tcp
> hdr1_live 9084/tcp
> cmport1 9085/tcp
> cmport2 9086/tcp
> cmport3 9087/tcp
> cmport4 9088/tcp
> ....
>
>
> When I run oncmsm -c oncmsm_1.cfg as user informix on asp5_be (the
> primary HDR pair) everything appears to work fine. But when I run the
> command on asp6_be I get this as the last line in the log file:
>
> 17:29:04 Error: SLA listener failed, Connection Manager shut down
>
> When I compare the two log files, the only suspicious line I see is
> this one, from the CM that fails:
>
> 17:29:03 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> 17:29:03 Warning: Cannot start listener oltp, network error -25572 <--
> NOTE THE FAILURE
>
> Yet, a few lines later:
>
> 17:29:04 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> SQLCODE = (0,0,)
> 17:29:04 Connection Manager successfully connected to hdr1_live
>
> I can use dbaccess -> connection -> connect, select hdr1_live and it
> works, from all servers.
>
> Any ideas on what is going on here?
>
> Thanks,
>
> Tom
>
So, you basically want to have 2 connection managers running:
one on asp5_be and one on asp6_be
Connecting to the Primary on asp5_be and the Secondary on asp6_be
Problem 1 is that these connection managers should have different names.
I am really struggling to work out your naming convention.
Could you provide the DBSERVERNAME / DBSERVERALIAS settings from your Primary and your Secondary?
For example, this is the sort of thing I would have expected :
SQLHOSTS
========
#
primary_shm onipcshm pri_host primary_shm
secondary_shm onipcshm sec_host secondary_shm
#
server_group group - - i=1,e=secondary_tcp
primary_tcp onsoctcp pri_host primary_tcp
secondary_tcp onsoctcp sec_host secondary_tcp# Connection Manager SLA entries
oltp_group group - - e.oltp_cm2
oltp_cm1 onsoctcp pri_host oltp_cm1
oltp_cm2 onsoctcp sec_host oltp_cm2
/etc/services :
===============
primary_tcp 9081/tcp
secondary_tcp 9082/tcp
oltp_cm1 9083/tcp
oltp_cm2 9084/tcp
oncmsm_1.cfg :
==============
NAME oncsm_1
SLA oltp_cm1=PRI
DEBUG 1
LOGFILE path/cmsm_1.log
FOC HDR,10
oncmsm_2.cfg :
NAME oncsm_2
SLA oltp_cm2=PRI
DEBUG 1
LOGFILE path/cmsm_2.log
FOC HDR,10
I would, however, suggest the following :
1. Ensure that DBSERVERNAME is set to the tcp connection name.
and / or
2. Ensure that HA_ALIAS is set to the tcp connection name
3. Await Informix 11.50.xC4, CSDK 3.50.xC4 release, quite a few issues will be addressed.
(I assume you want clients to connect to "oltp_group", being directed to "an available Connection Manager")
Anyhoo ...
Tom,
When a connection manager (CM) is initialized, it will start a listener
thread for each
SLA defined in the CM config file. That means, each SLA should have a
associated
port number in CM's sqlhosts file.
Now looking at your setup, as per oncmsm_1.cfg, CM will start the listener
thread
for SLA named 'oltp'. But in your sqlhosts.aspbeL1(on asp5_be) file, 'oltp'
is
defined as group name, which does not have a port number, so listener can't
be started.
You can not use server group name as SLA.
If you change the CM configuration as follows, both CM would be able to
start successfully.
in oncmsm_1.cfg
SLA oltp_cm1=PRI (use oltp_cm1 instead of group name - oltp)
in oncmsm_2.cfg
SLA oltp_cm2=PRI (use oltp_cm2 instead of group name - oltp)
And now you can use, 'oltp' group name as INFORMIXSERVER for clients to get
to primary.
Hope this helps.
-Nilesh.
informix-list-bounces@iiug.org wrote on 03/30/2009 10:18:23 AM:
> [image removed]
>
> Connectiom Manager help needed
>
> Tom
>
> to:
>
> informix-list
>
> 03/30/2009 10:23 AM
>
> Sent by:
>
> informix-list-bounces@iiug.org
>
> Greetings,
>
> I am getting an error when attempting to start the second CM in the
> following configuration:
>
> 2 identical IBM P6-550 servers, AIX 6.1, IDS 11.5.FC3 (server asp5_be
> is the Primary and asp6_be is the HDR in an HDR pair)
>
> oncmsm_1.cfg (on asp5_be)
> NAME oncsm_1
> SLA oltp=PRI
> DEBUG 1
> LOGFILE path/cmsm_1.log
> FOC HDR,10
>
> oncmsm_2.cfg (on asp6_be)
> NAME oncsm_1
> SLA oltp=PRI
> DEBUG 1
> LOGFILE path/cmsm_1.log
> FOC HDR,10
>
> sqlhosts.aspbeL1 (on asp5_be)
> # ASP5_BE
> aspbeL1 onipcshm asp5_be aspbeL1> # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> # ASP6_BE
> # hdr1 onipcshm asp6 hdr1
> # hdr1_live onsoctcp asp6_be hdr1_live
> hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> # All servers in HDR configuration
> g_mach group -
> - e=hdr1_live
> aspbeL1_live onsoctcp asp5_be aspbeL1_live
> g=g_mach
> hdr1_live onsoctcp asp6_be hdr1_live
> g=g_mach>
> # Connection Manager - oncmsm_1
> oltp group -
> - e=oltp_cm2
> oltp_cm1 onsoctcp asp5_be cmport1
> g=oltp
> oltp_cm2 onsoctcp asp6_be cmport2
> g=oltp>
> sqlhosts.aspbeL1 (on asp6_be)
> # ASP5_BE
> # aspbeL1 onipcshm asp5_be aspbeL1
> # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> # ASP6_BE
> hdr1 onipcshm asp6 hdr1> # hdr1_live onsoctcp asp6_be hdr1_live
> hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> # All servers in HDR configuration
> g_mach group -
> - e=hdr1_live
> aspbeL1_live onsoctcp asp5_be aspbeL1_live
> g=g_mach
> hdr1_live onsoctcp asp6_be hdr1_live
> g=g_mach>
> # Connection Manager - oncmsm_1
> oltp group -
> - e=oltp_cm2
> oltp_cm1 onsoctcp asp5_be cmport1
> g=oltp
> oltp_cm2 onsoctcp asp6_be cmport2
> g=oltp>
> >From the /etc/services file - same on both servers:
> ....
> hdr1P_be 9081/tcp
> apsbeL1_live 9082/tcp
> hdr1S-be 9083/tcp
> hdr1_live 9084/tcp
> cmport1 9085/tcp
> cmport2 9086/tcp
> cmport3 9087/tcp
> cmport4 9088/tcp
> ....
>
>
> When I run oncmsm -c oncmsm_1.cfg as user informix on asp5_be (the
> primary HDR pair) everything appears to work fine. But when I run the
> command on asp6_be I get this as the last line in the log file:
>
> 17:29:04 Error: SLA listener failed, Connection Manager shut down
>
> When I compare the two log files, the only suspicious line I see is
> this one, from the CM that fails:
>
> 17:29:03 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> 17:29:03 Warning: Cannot start listener oltp, network error -25572 <--
> NOTE THE FAILURE
>
> Yet, a few lines later:
>
> 17:29:04 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> SQLCODE = (0,0,)
> 17:29:04 Connection Manager successfully connected to hdr1_live
>
> I can use dbaccess -> connection -> connect, select hdr1_live and it
> works, from all servers.
>
> Any ideas on what is going on here?
>
> Thanks,
>
> Tom
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
On Mar 31, 12:23 pm, Nilesh Ozarkar <nile...@us.ibm.com> wrote:
> Tom,
>
> When a connection manager (CM) is initialized, it will start a listener
> thread for each
> SLA defined in the CM config file. That means, each SLA should have a
> associated
> port number in CM's sqlhosts file.
>
> Now looking at your setup, as per oncmsm_1.cfg, CM will start the listener
> thread
> for SLA named 'oltp'. But in your sqlhosts.aspbeL1(on asp5_be) file, 'oltp'
> is
> defined as group name, which does not have a port number, so listener can't
> be started.
> You can not use server group name as SLA.
>
> If you change the CM configuration as follows, both CM would be able to
> start successfully.
>
> in oncmsm_1.cfg
> SLA oltp_cm1=PRI (use oltp_cm1 instead of group name - oltp)
>
> in oncmsm_2.cfg
> SLA oltp_cm2=PRI (use oltp_cm2 instead of group name - oltp)
>
> And now you can use, 'oltp' group name as INFORMIXSERVER for clients to get
> to primary.
>
> Hope this helps.
>
> -Nilesh.
>
> informix-list-boun...@iiug.org wrote on 03/30/2009 10:18:23 AM:
>
>
>
> > [image removed]
>
> > Connectiom Manager help needed
>
> > Tom
>
> > to:
>
> > informix-list
>
> > 03/30/2009 10:23 AM
>
> > Sent by:
>
> > informix-list-boun...@iiug.org
>
> > Greetings,
>
> > I am getting an error when attempting to start the second CM in the
> > following configuration:
>
> > 2 identical IBM P6-550 servers, AIX 6.1, IDS 11.5.FC3 (server asp5_be
> > is the Primary and asp6_be is the HDR in an HDR pair)
>
> > oncmsm_1.cfg (on asp5_be)
> > NAME oncsm_1
> > SLA oltp=PRI
> > DEBUG 1
> > LOGFILE path/cmsm_1.log
> > FOC HDR,10
>
> > oncmsm_2.cfg (on asp6_be)
> > NAME oncsm_1
> > SLA oltp=PRI
> > DEBUG 1
> > LOGFILE path/cmsm_1.log
> > FOC HDR,10
>
> > sqlhosts.aspbeL1 (on asp5_be)
> > # ASP5_BE
> > aspbeL1 onipcshm asp5_be aspbeL1> > # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> > hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> > # ASP6_BE
> > # hdr1 onipcshm asp6 hdr1
> > # hdr1_live onsoctcp asp6_be hdr1_live
> > hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> > # All servers in HDR configuration
> > g_mach group -
> > - e=hdr1_live
> > aspbeL1_live onsoctcp asp5_be aspbeL1_live
> > g=g_mach
> > hdr1_live onsoctcp asp6_be hdr1_live
> > g=g_mach>
> > # Connection Manager - oncmsm_1
> > oltp group -
> > - e=oltp_cm2
> > oltp_cm1 onsoctcp asp5_be cmport1
> > g=oltp
> > oltp_cm2 onsoctcp asp6_be cmport2
> > g=oltp>
> > sqlhosts.aspbeL1 (on asp6_be)
> > # ASP5_BE
> > # aspbeL1 onipcshm asp5_be aspbeL1
> > # aspbeL1_live onsoctcp asp5_be aspbeL1_live
> > hdr1P_be onsoctcp asp5_be hdr1P_be s=6
>
> > # ASP6_BE
> > hdr1 onipcshm asp6 hdr1> > # hdr1_live onsoctcp asp6_be hdr1_live
> > hdr1S_be onsoctcp asp6_be hdr1S_be s=6
>
> > # All servers in HDR configuration
> > g_mach group -
> > - e=hdr1_live
> > aspbeL1_live onsoctcp asp5_be aspbeL1_live
> > g=g_mach
> > hdr1_live onsoctcp asp6_be hdr1_live
> > g=g_mach>
> > # Connection Manager - oncmsm_1
> > oltp group -
> > - e=oltp_cm2
> > oltp_cm1 onsoctcp asp5_be cmport1
> > g=oltp
> > oltp_cm2 onsoctcp asp6_be cmport2
> > g=oltp>
> > >From the /etc/services file - same on both servers:
> > ....
> > hdr1P_be 9081/tcp
> > apsbeL1_live 9082/tcp
> > hdr1S-be 9083/tcp
> > hdr1_live 9084/tcp
> > cmport1 9085/tcp
> > cmport2 9086/tcp
> > cmport3 9087/tcp
> > cmport4 9088/tcp
> > ....
>
> > When I run oncmsm -c oncmsm_1.cfg as user informix on asp5_be (the
> > primary HDR pair) everything appears to work fine. But when I run the
> > command on asp6_be I get this as the last line in the log file:
>
> > 17:29:04 Error: SLA listener failed, Connection Manager shut down
>
> > When I compare the two log files, the only suspicious line I see is
> > this one, from the CM that fails:
>
> > 17:29:03 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> > 17:29:03 Warning: Cannot start listener oltp, network error -25572 <--
> > NOTE THE FAILURE
>
> > Yet, a few lines later:
>
> > 17:29:04 CONNECT to sysmaster@hdr1_live|onsoctcp|asp6_be|hdr1_live
> > SQLCODE = (0,0,)
> > 17:29:04 Connection Manager successfully connected to hdr1_live
>
> > I can use dbaccess -> connection -> connect, select hdr1_live and it
> > works, from all servers.
>
> > Any ideas on what is going on here?
>
> > Thanks,
>
> > Tom
>
> > _______________________________________________
> > Informix-list mailing list
> > Informix-l...@iiug.org
> >http://www.iiug.org/mailman/listinfo/informix-list- Hide quoted text -
>
> - Show quoted text -
Nilesh has corrected the problem. Using the name "oltp" as the SLA and
group name is not the way to go. I changed the names as shown in his
post and all now works as hoped. Even when adding the suggestions as
written by "eherber" in the Informix Zone article http://www.informix-zone.com/print/606.
I set up my sqlhosts file as shown above, then set
INFORMIXSERVER=g_mach when starting the Connection Managers.INFORMIXSERVER is set to "oltp" for all other users.
Thanks again for the help,
Tom
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts