ESQL/C: Error -33020: Line is too long.
Posted in 2000
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL
Hi, I am getting " Error -33020: Line is too long. " when preprocessing ec file. finderr says: Refer to the embedded-language manual and to the host-language manual for rules on continuing long lines. I cannot find reference to that in my V5 PGMR manual. Are there any optinal command line switches I could use? thanks, sunil + esql -V INFORMIX-ESQL Version 5.08.UD1 SunOS 5.5.1
How long is the line? I've seen similar (not precicely, but similar) errors occur if I forget to close a comment, so you might want to check that. In article <8m6pih$o7i$1@news.xmission.com>, "Bhaskarla, Sunil" <Sunil.Bhaskarla@Eclipsys.com> wrote: > > Hi, > > I am getting " Error -33020: Line is too long. " when preprocessing ec > file. > > finderr says: Refer to the embedded-language manual and to the host-language > manual for rules on continuing long lines. > > I cannot find reference to that in my V5 PGMR manual. > > Are there any optinal command line switches I could use? > > thanks, > sunil > > + esql -V > INFORMIX-ESQL Version 5.08.UD1 > SunOS 5.5.1 > > -- # unrm / ksh: unrm: not found # man cpio Sent via Deja.com http://www.deja.com/ Before you buy.
IMS the line limit for ESQL/C 5.xx was 32K. Why not just break the line up or build the command as a string and prepare it? Don't be stubborn, be lazy. Good programmers are lazy and should be. This is a perfect example. It is easier to break the long line up than to search the manuals, the web, and this newsgroup for a compiler switch that will permit you to leave it long! Be lazy. Art S. Kagel "Bhaskarla, Sunil" wrote: > > Hi, > > I am getting " Error -33020: Line is too long. " when preprocessing ec > file. > > finderr says: Refer to the embedded-language manual and to the host-language > manual for rules on continuing long lines. > > I cannot find reference to that in my V5 PGMR manual. > > Are there any optinal command line switches I could use? > > thanks, > sunil > > + esql -V > INFORMIX-ESQL Version 5.08.UD1 > SunOS 5.5.1
"Art S. Kagel" wrote: > IMS the line limit for ESQL/C 5.xx was 32K. Why not just break the > line up or build the command as a string and prepare it? Don't be > stubborn, be lazy. Good programmers are lazy and should be. This is > a perfect example. It is easier to break the long line up than to > search the manuals, the web, and this newsgroup for a compiler > switch that will permit you to leave it long! Be lazy. Basically, I agree with you, Art, unless there are circumstances beyond his control that cause the ESQL/C to be so long. For example, he might be using a code generator that creates the ESQL/C source file. > "Bhaskarla, Sunil" wrote: > > I am getting " Error -33020: Line is too long. " when preprocessing ec > > file. > > > > finderr says: Refer to the embedded-language manual and to the host-language > > manual for rules on continuing long lines. > > > > I cannot find reference to that in my V5 PGMR manual. > > Are there any optinal command line switches I could use? > > > > thanks, > > sunil > > > > + esql -V > > INFORMIX-ESQL Version 5.08.UD1 > > SunOS 5.5.1 That version of ESQL/C is not Y2K-compliant. Please upgrade to 5.10. Now. -- Yours, Jonathan Leffler (Jonathan.Leffler@Informix.com) #include <disclaimer.h> Guardian of DBD::Informix v1.00.PC1 -- http://www.perl.com/CPAN "I don't suffer from insanity; I enjoy every minute of it!"