Connecting from SCO Unix to an Informix database running on Windows NT server
Posted in 1999
Topics: Installation, Setup & Upgrades, Networking & sqlhosts Configuration
Limis BV wrote:
>
> I'm trying to make a connection from a SCO UNIX machine
> to a Informix database running on Windows NT, but I get
> the following Informix error message on the Unix machine
> when I try to connect to the database:
>
> -25574 Networkdriver cannot open the network device
>
> What is going wrong ?
> Should there be anything installed/enabled ?
>
> I'm using the following settings on the Unix machine:
>
> $INFORMIXDIR/etc/sqlhosts:
>
> ol_asterix ontlitcp asterix turbo>
> /etc/services:
>
> turbo 1526/tcp
> srv_agent 1530/tcp
>
> OS specs:
>
> SCO UNIX 3.2v5.0.4
> Windows NT 4.0 Server
> Informix ODS 7.22.TC1
Can you do anything else network-y on that SCO box? Can you ping
asterix? Is asterix listed in /etc/hosts? SCO does not come with
networking enabled by default you have to install the networking option.
Art S. Kagel
I'm trying to make a connection from a SCO UNIX machine
to a Informix database running on Windows NT, but I get
the following Informix error message on the Unix machine
when I try to connect to the database:
-25574 Networkdriver cannot open the network device
What is going wrong ?
Should there be anything installed/enabled ?
I'm using the following settings on the Unix machine:
$INFORMIXDIR/etc/sqlhosts:
ol_asterix ontlitcp asterix turbo
/etc/services:
turbo 1526/tcp
srv_agent 1530/tcp
OS specs:
SCO UNIX 3.2v5.0.4
Windows NT 4.0 Server
Informix ODS 7.22.TC1
Please help.
Hans Leeuw
Limis BV
info@limis.nl
"Art S. Kagel" <kagel@bloomberg.net> wrote:
>Limis BV wrote:
>>
>> I'm trying to make a connection from a SCO UNIX machine
>> to a Informix database running on Windows NT, but I get
>> the following Informix error message on the Unix machine
>> when I try to connect to the database:
>>
>> -25574 Networkdriver cannot open the network device
>>
>> What is going wrong ?
>> Should there be anything installed/enabled ?
>>
>> I'm using the following settings on the Unix machine:
>>
>> $INFORMIXDIR/etc/sqlhosts:
>>
>> ol_asterix ontlitcp asterix turbo>>
>> /etc/services:
>>
>> turbo 1526/tcp
>> srv_agent 1530/tcp
>>
>> OS specs:
>>
>> SCO UNIX 3.2v5.0.4
>> Windows NT 4.0 Server
>> Informix ODS 7.22.TC1
>Can you do anything else network-y on that SCO box? Can you ping
>asterix? Is asterix listed in /etc/hosts? SCO does not come with
>networking enabled by default you have to install the networking option.
That's not the problem the SCO machine already runs more than 5 years
in a network with other unix and windows machines.
I think the problem is that informix does a system call and fails.
The question is what call it makes (to with service/device) ?
If anyone can answer me this question, I can check if that service/device
is present on the SCO machine.
>Art S. Kagel