603 cannot close blob
Posted in 2000
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Versions, Editions & End-of-Life
Getting desperate.
I am trying to import a database with blobs. The import keeps blowing up with the error "603 - Cannot close blob. 172 - ISAM error: Unexpected internal error" I can't find anything about these errors, probably looking in the wrong spot.
IDS 7.20.UC2 on Sun intel 2.6
onstat -m
INFORMIX-OnLine Version 7.20.UC2 -- On-Line -- Up 00:32:49 -- 129824 Kbytes
Message Log File: /usr/informix/online.log
10:44:48 Quiescent Mode
10:45:27 On-Line Mode
10:45:27 Not enough physical procs for affinity
10:45:27 Building 'sysmaster' database ...
10:45:52 'sysmaster' database built successfully.
10:46:20 Checkpoint Completed: duration was 4 seconds.
10:46:47 Logical Log 1 Complete.
10:51:36 Checkpoint Completed: duration was 9 seconds.
10:52:33 Checkpoint Completed: duration was 4 seconds.
10:56:15 Checkpoint Completed: duration was 5 seconds.
11:01:35 Checkpoint Completed: duration was 17 seconds.
11:03:40 Checkpoint Completed: duration was 4 seconds.
11:08:48 Checkpoint Completed: duration was 5 seconds.
11:09:28 Assert Failed: Page Check Error in allocbpg(1):bad BLOB bitmap page
11:09:28 Who: Session(19, informix@ralph, 1829, 1459981472)
Thread(44, sqlexec, 57038e7c, 1)
11:09:28 Results: Possible inconsistencies in 'newnaomi:"informix".ref_notes'
11:09:28 Action: Run 'oncheck -cD 1048829'
11:09:28 See Also: /usr/tmp/af.2c1c48
11:13:52 Checkpoint Completed: duration was 4 seconds.
Let me know what other information that will help.
Thanks in advance!!!
Anne
Upgrade to 7.31.UC4 at least.
Avoid UC6 it is e bad bug in it - create a large index and if the
creation rollsback, Online crashes and then fails to start again
complaining about corrupt logs.
UC5 will be tested by me soon, although I have heard it has optimizer
problems.
I wonder, is UC7 out yet (I the UK UC7 was delayed due to a QA
problem and UC8 is expected to follow very soon after UC7).
David.
Anne Shelp wrote in message <8nh8ej$htp$1@news.xmission.com>...
>
>Getting desperate.
>
>I am trying to import a database with blobs. The import keeps blowing up
with the error "603 - Cannot close blob. 172 - ISAM error: Unexpected
internal error" I can't find anything about these errors, probably looking
in the wrong spot.
>
>IDS 7.20.UC2 on Sun intel 2.6
>
>onstat -m>
>INFORMIX-OnLine Version 7.20.UC2 -- On-Line -- Up 00:32:49 -- 129824
Kbytes
>
>Message Log File: /usr/informix/online.log
>10:44:48 Quiescent Mode
>10:45:27 On-Line Mode
>10:45:27 Not enough physical procs for affinity
>10:45:27 Building 'sysmaster' database ...
>10:45:52 'sysmaster' database built successfully.
>10:46:20 Checkpoint Completed: duration was 4 seconds.
>10:46:47 Logical Log 1 Complete.
>10:51:36 Checkpoint Completed: duration was 9 seconds.
>10:52:33 Checkpoint Completed: duration was 4 seconds.
>10:56:15 Checkpoint Completed: duration was 5 seconds.
>11:01:35 Checkpoint Completed: duration was 17 seconds.
>11:03:40 Checkpoint Completed: duration was 4 seconds.
>11:08:48 Checkpoint Completed: duration was 5 seconds.
>11:09:28 Assert Failed: Page Check Error in allocbpg(1):bad BLOB bitmappage
>11:09:28 Who: Session(19, informix@ralph, 1829, 1459981472)
> Thread(44, sqlexec, 57038e7c, 1)
>11:09:28 Results: Possible inconsistencies in'newnaomi:"informix".ref_notes'
>11:09:28 Action: Run 'oncheck -cD 1048829'
>11:09:28 See Also: /usr/tmp/af.2c1c48
>11:13:52 Checkpoint Completed: duration was 4 seconds.>
>Let me know what other information that will help.
>
>Thanks in advance!!!
>Anne
>