Unable to load locale categories
Posted in 2000
Topics: Connectivity: ODBC / JDBC / .NET, Internationalization & Character Sets
Hi, I'm try to use Microsoft ADO(ver 2) from client pc to access the Informix SE in Linux, but the following error return to me: ActiveX Data Object (ADO) Microsoft OLE DB Provider for ODBC Drivers error '80004005' [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale categories. I can connect to the database when i using the ILogin(Informix-CLI ver 2.5) and I've try to set the DB_LOCALE to en_us.819 for the server and client. But it still return the same error to me. Have someone face this before? Thank you. regards Wei Choon
Hello ! > Hi, I'm try to use Microsoft ADO(ver 2) from client pc to access the > Informix SE in Linux, but the following error return to me: > [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale categories. > I can connect to the database when i using the ILogin(Informix-CLI ver 2.5) > and I've try to set the DB_LOCALE to en_us.819 for the server and client. > But it still return the same error to me. Have someone face this before? > This error is generated by ODBC-driver, when it not properly configured. Try use different locale for both server and client. For example defaul locales en_us.8859-1 - for Unix en_us.1252 - for NT You can also check INFORMIXDIR variable. WBR, Serguei I. Ivantsov
Hi, many of these "Unable to load locale categories"-errors occurs of the wrong setting of your INFORMIXDIR path. check the INFORMIXDIR setting for the client and the server. you need no values for DB_Locale and CLIENT_LOCALE if you use standard en_US.819 does I-CLI 2.5 needs setnet ??? i don`t know. i only use the native way to get my data. if there is a setnet installed check the INFORMIXDIR - Var. ingo Wei Choon schrieb: > Hi, I'm try to use Microsoft ADO(ver 2) from client pc to access the > Informix SE in Linux, but the following error return to me: > > ActiveX Data Object (ADO) > Microsoft OLE DB Provider for ODBC Drivers error '80004005' > > [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale categories. > > I can connect to the database when i using the ILogin(Informix-CLI ver 2.5) > and I've try to set the DB_LOCALE to en_us.819 for the server and client. > But it still return the same error to me. Have someone face this before? > > Thank you. > > regards > Wei Choon
Hi, thank you for those reply to me (either by email or here) . I've fixed this problem by running the regcopy.exe in my informix/bin directory. I can retrieve the data from the database. However, when i try to run the following code: Set Conn = Server.CreateObject("ADODB.Connection") Conn.Open "testdb", "informix", "abc321" Set Cmd = Server.CreateObject("ADODB.Command") Cmd.ActiveConnection = Conn Cmd.CommandType = 1 Cmd.CommandText = "Insert into employee (emp_no, name) values ('" & Request.Form("emp_no") & "' , '" & Request.Form("emp_name") & "')" Conn.BeginTrans conn.IsolationLevel = adXactIsolated Cmd.Execute IF Conn.Errors = 0 THEN Conn.CommitTrans ELSE Conn.RollbackTrans END IF The following error return to me: Microsoft OLE DB Provider for ODBC Drivers error '8004d008' Neither the isolation level or a strengthening of it can be supported. /aspsamp/aspdev/insert.asp, line 10 Is Informix SE support transaction processing? Thanks again. regards Wei Choon Serguei I. Ivantsov <manowar@niist.ntu-kpi.kiev.ua> wrote in message news:861d3t$2j9o$1@igloo.uran.net.ua... > Hello ! > > > Hi, I'm try to use Microsoft ADO(ver 2) from client pc to access the > > Informix SE in Linux, but the following error return to me: > > [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale > categories. > > I can connect to the database when i using the ILogin(Informix-CLI ver > 2.5) > > and I've try to set the DB_LOCALE to en_us.819 for the server and client. > > But it still return the same error to me. Have someone face this before? > > > > This error is generated by ODBC-driver, when it not properly configured. Try > use different locale for both server and client. For example defaul locales > en_us.8859-1 - for Unix > en_us.1252 - for NT > You can also check INFORMIXDIR variable. > > WBR, > Serguei I. Ivantsov > > > > > >
> Hi, thank you for those reply to me (either by email or here) . I've fixed > this problem by running the regcopy.exe in my informix/bin directory. I can > retrieve the data from the database. However, when i try to run the > following code: > <SKIPPEED> > > The following error return to me: > Microsoft OLE DB Provider for ODBC Drivers error '8004d008' > Neither the isolation level or a strengthening of it can be supported. > /aspsamp/aspdev/insert.asp, line 10 > > Is Informix SE support transaction processing? Yes. But me be you are connecting to NON BUFFERED (LOGGED) Informix database. In this cases Intersolv-2.5 client generates error (Driver not capable). You may either set logging options in your database to buffered or try using Informix Client v2.80, which works correctly both with buffered and non-buffered databases. -- Sincerely, Serguei I. Ivantsov Software Developer, Research Institute Of System Technologies e-mail : ManOwaR@WinDrivers.NET
Wei, You should make sure that INFORMIXSERVER and INFORMIXDIR are set in your environment when connecting. Regards, Stephen Schadt Support Consultant Openlink Software http://www.openlinksw.com In article <860p9a$kn8$1@news4.jaring.my>, "Wei Choon" <weichoon@powersys.com.my> wrote: > Hi, I'm try to use Microsoft ADO(ver 2) from client pc to access the > Informix SE in Linux, but the following error return to me: > > ActiveX Data Object (ADO) > Microsoft OLE DB Provider for ODBC Drivers error '80004005' > > [INTERSOLV][ODBC Informix driver][Informix]Unable to load locale categories. > > I can connect to the database when i using the ILogin(Informix-CLI ver 2.5) > and I've try to set the DB_LOCALE to en_us.819 for the server and client. > But it still return the same error to me. Have someone face this before? > > Thank you. > > regards > Wei Choon > > Sent via Deja.com http://www.deja.com/ Before you buy.