Ontape Error - read: Not Enough Space
Posted in 2000
Topics: Backup & Restore, Storage & Space Management
I hate ontape and all other informix stuff.
What kind of a system can give such an error message.
I have just looked at previous postings, not able to find anything that
will cause ontape to print this error message.
read: Not Enough Space.
The above error message appears when it needs 2nd DLT Tape.
I checked out everything( disk space, tempdbs space, ....), I have
tried many tapes including DLT3 and DLT4.
Art, do you have any document describes all ontape error messages and
their possible reasons as well.
Gurus. I need you assistance.
Please be quick.
Regards,
Yener
Sent via Deja.com http://www.deja.com/
Before you buy.
You have your TAPESIZE set too high. If you are relying on
compression to double the capacity of your tapes, forget it. The
published compression ratio of 2:1 (50%) is predicated on backing up
primarily text to the drive. If your database is mainly binary columns
(ie INTEGER, SMALLINT, FLOAT, SMALLFLOAT, DECIMAL, DATE, DATETIME,
INTERVAL, BYTE, ...) then you cannot expect better than 3:2 (30%)
compression on DLT drives. Since Informix does not detect for EOT it
returns an error when it tries to write beyond the end of tape.
Art S. Kagel
yener@my-deja.com wrote:
>
> I hate ontape and all other informix stuff.
>
> What kind of a system can give such an error message.
>
> I have just looked at previous postings, not able to find anything that
> will cause ontape to print this error message.
>
> read: Not Enough Space.
>
> The above error message appears when it needs 2nd DLT Tape.
>
> I checked out everything( disk space, tempdbs space, ....), I have
> tried many tapes including DLT3 and DLT4.
>
> Art, do you have any document describes all ontape error messages and
> their possible reasons as well.
>
> Gurus. I need you assistance.
>
> Please be quick.
>
> Regards,
>
> Yener
>
> Sent via Deja.com http://www.deja.com/
> Before you buy.
I saw this error a few weeks ago when I was bitten by bug #101062 (ARCHIVE
PERFORMANCE DEGRADATION WHEN MANY CALLS TO ARC_VERY_OLD_PAGE). I don't
know for sure if the error message was related to the bug, but it would be
worth investigating. Do your backups seem to be taking an unusually long
time?
Ty O'Kelly
tokelly@maxor.invalid.com
yener@my-deja.com wrote:
> I hate ontape and all other informix stuff.
>
> What kind of a system can give such an error message.
>
> I have just looked at previous postings, not able to find anything that
> will cause ontape to print this error message.
>
> read: Not Enough Space.
>
> The above error message appears when it needs 2nd DLT Tape.
>
> I checked out everything( disk space, tempdbs space, ....), I have
> tried many tapes including DLT3 and DLT4.
>
> Art, do you have any document describes all ontape error messages and
> their possible reasons as well.
>
> Gurus. I need you assistance.
>
> Please be quick.
>
> Regards,
>
> Yener
Well Art,
You may be right on TAPESIZE. However, I am using this TAPESIZE
parameter for over 1 month. An sometimes, it backs up the system.
Sometimes it gives this nonsense error message. I have tried DLTIV and
DLT III drives. My current TAPESIZE configuration parameter is 90000000.
I would like to say that this error message is given not in the middle
of second tape, it gives this error at the beginning of second TAPE.
I am now suspicious about BUFFER size of the informix. I set it from
400000 to 1250000. We have 8 GB of memory and I want to use as much as
possible.
Regards,
In article <398F1E67.8A868701@bloomberg.net>,
kagel@bloomberg.net wrote:
> You have your TAPESIZE set too high. If you are relying on
> compression to double the capacity of your tapes, forget it. The
> published compression ratio of 2:1 (50%) is predicated on backing up
> primarily text to the drive. If your database is mainly binary
columns
> (ie INTEGER, SMALLINT, FLOAT, SMALLFLOAT, DECIMAL, DATE, DATETIME,
> INTERVAL, BYTE, ...) then you cannot expect better than 3:2 (30%)
> compression on DLT drives. Since Informix does not detect for EOT it
> returns an error when it tries to write beyond the end of tape.
>
> Art S. Kagel
>
> yener@my-deja.com wrote:
> >
> > I hate ontape and all other informix stuff.
> >
> > What kind of a system can give such an error message.
> >
> > I have just looked at previous postings, not able to find anything
that
> > will cause ontape to print this error message.
> >
> > read: Not Enough Space.
> >
> > The above error message appears when it needs 2nd DLT Tape.
> >
> > I checked out everything( disk space, tempdbs space, ....), I have
> > tried many tapes including DLT3 and DLT4.
> >
> > Art, do you have any document describes all ontape error messages
and
> > their possible reasons as well.
> >
> > Gurus. I need you assistance.
> >
> > Please be quick.
> >
> > Regards,
> >
> > Yener
> >
> > Sent via Deja.com http://www.deja.com/
> > Before you buy.
>
Sent via Deja.com http://www.deja.com/
Before you buy.
Also sprach yener@my-deja.com :
:Well Art,
:
:You may be right on TAPESIZE. However, I am using this TAPESIZE
:parameter for over 1 month. An sometimes, it backs up the system.
:Sometimes it gives this nonsense error message. I have tried DLTIV and
:DLT III drives. My current TAPESIZE configuration parameter is 90000000.
:
:I would like to say that this error message is given not in the middle
:of second tape, it gives this error at the beginning of second TAPE.
:
:I am now suspicious about BUFFER size of the informix. I set it from
:400000 to 1250000. We have 8 GB of memory and I want to use as much as
:possible.
:
:
You will often get this error when you are trying to write to a brand-new (i.e.
never been written to before) tape. It's an error returned by unix when opening
a virgin tape. I get them all the time labeling new tapes in Legato. Try
dd'ing or tar'ing some junk onto the tapes before using them for ontape, or use
mt and write a few eof's onto it.
Dave