Re: ids 9.20 crash on Linux. please help.
Posted in 2000
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Hi Konstantin,
MT_EX_OS is usually an error reported by the OS. I would
suggest checking your RAM. Maybe it's defective or running too
fast.
Or some resources are not available (shared memory ?) and the OS
reports an error.
You might check dmesg and /var/log/messages for suspicious entries.
Does only the server crash or the whole system ?
If it's only IDS then you might try to upgeade to a more current
kernel (2.2.5 is certified, 2.2.16 should do just fine, also).
Do you have a current glibc ? You need glibc 2.1.1.
Brgds
Peter
Konstantin Bakunov schrieb:
>
> hi All..
> Can anybody help me ?
> I have a server crash just every day with the following (or same)
> messages:
> ...............
> 19:38:01 Checkpoint Completed: duration was 0 seconds.
> 19:38:01 Checkpoint loguniq 802, logpos 0x219018
>
> 19:38:50 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
> 19:38:50 Informix Dynamic Server 2000 Version 9.20.UC1
> 19:38:50 Who: Session(72963, root@app.les.loc, 30410, 276629628)
> Thread(197446, sqlexec, 107a8dd8, 1)
> File: mtex.c Line: 330
> 19:38:50 Action: Please notify Informix Technical Support.
> 19:38:50 stack trace for pid 443 written to /var/tmp/af.72e4a09
> 19:38:50 See Also: /var/tmp/af.72e4a09, shmem.72e4a09.0
> 19:39:01 (-9791): ERROR: Routine execution trap -- procname=<updsst>
> procid=183
> reason: mem
> 19:39:01 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
> 19:39:01 Informix Dynamic Server 2000 Version 9.20.UC1
> 19:39:01 Who: Session(72963, root@app.les.loc, 30410, 276629628)
> Thread(197446, sqlexec, 107a8dd8, 1)
> File: mtex.c Line: 330
> 19:39:01 Action: Please notify Informix Technical Support.
> 19:39:01 stack trace for pid 443 written to /var/tmp/af.72e4a09
> 19:39:01 See Also: /var/tmp/af.72e4a09, shmem.72e4a09.1
> 19:39:16 (-9791): ERROR: Routine execution trap -- procname=<updsst>
> procid=183
> reason: mem
> 19:39:17 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
> 19:39:17 Informix Dynamic Server 2000 Version 9.20.UC1
> 19:39:17 Who: Session(72963, root@app.les.loc, 30410, 276629628)
> Thread(197446, sqlexec, 107a8dd8, 1)
> File: mtex.c Line: 330
> 19:39:17 Action: Please notify Informix Technical Support.
> 19:39:17 stack trace for pid 443 written to /var/tmp/af.72e4a09
> 19:39:17 See Also: /var/tmp/af.72e4a09, shmem.72e4a09.2
> 19:39:31 (-9791): ERROR: Routine execution trap -- procname=<updsst>
> procid=183
> reason: mem
> 19:39:31 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
> 19:39:31 Informix Dynamic Server 2000 Version 9.20.UC1
> 19:39:31 Who: Session(72963, root@app.les.loc, 30410, 276629628)
> Thread(197446, sqlexec, 107a8dd8, 1)
> File: mtex.c Line: 330
> 19:39:31 Action: Please notify Informix Technical Support.
> 19:39:31 stack trace for pid 443 written to /var/tmp/af.72e4a09
> 19:39:31 See Also: /var/tmp/af.72e4a09, shmem.72e4a09.3
> 19:39:44 (-9791): ERROR: Routine execution trap -- procname=<updsst>
> procid=183
> reason: mem
> 19:39:44 Assert Failed: Exception Caught. Type: MT_EX_OS, Context: mem
> 19:39:44 Informix Dynamic Server 2000 Version 9.20.UC1
> 19:39:44 Who: Session(72963, root@app.les.loc, 30410, 276629628)
> Thread(197446, sqlexec, 107a8dd8, 1)
> File: mtex.c Line: 330
> 19:39:44 Action: Please notify Informix Technical Support.
> 19:39:44 stack trace for pid 443 written to /var/tmp/af.72e4a09
> 19:39:44 See Also: /var/tmp/af.72e4a09, shmem.72e4a09.4
> 19:39:58 (-9791): ERROR: Routine execution trap -- procname=<updsst>
> procid=183
> reason: mem
> ...............
> and so on..> Is it because i have a problem with my hardware/OS or that is a
> something else ?...
> or is it reason to notify Informix Technical Support ..:)
>
> I have the IDS 2000 on RedHat Linux 2.2.
>
> Thanks in advance.
> =Konstantin-
Hi Peter, Thanks for your answer.. You're probably right about checking RAM. It's really maybe defective.. (It has not a "Parity Check"). I have to check my hardware. I have kernel 2.2.14 (just download 2.2.16 as you suggested :) and glibc 2.1.3. I think that's enough to be fine :). Isn't it?... There's no anything suspecious in /var/log/messages. No it's only the informix server crash, not the whole system. I heard that the RedHat 6.2 has something like a "hole"... it's about the problem with stack or something else.. Do you know what is it ? ------------------- Regards =Konstantin- Peter Eckhardt wrote: > Hi Konstantin, > > MT_EX_OS is usually an error reported by the OS. I would > suggest checking your RAM. Maybe it's defective or running too > fast. > Or some resources are not available (shared memory ?) and the OS > reports an error. > > You might check dmesg and /var/log/messages for suspicious entries. > > Does only the server crash or the whole system ? > > If it's only IDS then you might try to upgeade to a more current > kernel (2.2.5 is certified, 2.2.16 should do just fine, also). > > Do you have a current glibc ? You need glibc 2.1.1. > > Brgds > Peter
Hi Konstantin, in previous post there were some more people claiming about IDS 2000 not running reliable. What they all had in common was a glibc version other than the certified 2.1.1. If your box runs otherwise reliable i wouldn't suspect ram. One quite good test to check your RAM is to do some kernel compiles. If gcc dies with mysterious error messages you have hardware problems. Peter Konstantin Bakunov schrieb: > > Hi Peter, > > Thanks for your answer.. > You're probably right about checking RAM. It's really maybe defective.. > (It has not a "Parity Check"). I have to check my hardware. > > I have kernel 2.2.14 (just download 2.2.16 as you suggested :) > and glibc 2.1.3. > I think that's enough to be fine :). Isn't it?... > There's no anything suspecious in /var/log/messages. > > No it's only the informix server crash, not the whole system. > > I heard that the RedHat 6.2 has something like a "hole"... it's about > the problem > with stack or something else.. > Do you know what is it ? > > ------------------- > Regards > =Konstantin- > > Peter Eckhardt wrote: > > > Hi Konstantin, > > > > MT_EX_OS is usually an error reported by the OS. I would > > suggest checking your RAM. Maybe it's defective or running too > > fast. > > Or some resources are not available (shared memory ?) and the OS > > reports an error. > > > > You might check dmesg and /var/log/messages for suspicious entries. > > > > Does only the server crash or the whole system ? > > > > If it's only IDS then you might try to upgeade to a more current > > kernel (2.2.5 is certified, 2.2.16 should do just fine, also). > > > > Do you have a current glibc ? You need glibc 2.1.1. > > > > Brgds > > Peter