RE: export fails with error : *** prepare unldobj
Posted in 2000
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration, Security, Permissions & Auditing, Migration, Import/Export & Data Conversion, Versions, Editions & End-of-Life
You might try getting Art Kagel's myexport/myimport utilities from
www.iiug.org. They are part of the utils2_ak package, and they also require
Jonathan Leffler's SQLCMD utility from that same site. I haven't used these
particular utilities, yet, but I *have* used Art's myschema and dbcopy to do
a critical database reorg, and we rely on his dostats for several of our
update statistics jobs.
HTH,
Paul Mosser
Wells Fargo & Co.
-----Original Message-----
From: Tam McLaughlin [mailto:tamm@scotlegal.com]
Sent: Thursday, September 07, 2000 10:03 AM
To: informix-list@iiug.org
Subject: export fails with error : *** prepare unldobj
I am in a bit of a panic as I have to export our databases for tomorrow
morning
as our servers disks get replaced but I am getting an error on the exports.
I tried exporting 2 different databases and they both fall over with the
same
error at the same table. A sample from the dbexport.out file is below.
We are on sco unixware 7.0.1 with IDS 7.30.UC2.
I have tried :
dbexport -d databasename -ss -c
and without the -c and get same result
create table "dba".syscolformats
(
owner char(32),
tabname char(32),
.........
...........
) extent size 16 next size 16 lock mode row;
revoke all on "dba".syscolformats from "public";
*** prepare unldobj
201 - A syntax error has occurred.
Informix support have suggested the following options and cannot give me
any other
options/answer until tomorrow when it is too late.
1. dbexport without -c option.
2. unload the table which caused the problem and drop it before you run
dbexport.
1 does not nwork
I think it would be better to run a script (which i am doing now) to give me
the
schema , and then to unload each table , 1 at a time and to an unload file
and try and
generate an import file from the schema files.
Any better ideas ?
One other imporant thing, we are getting Assert failures as below:
Cannot use TBLSpace page for TBLSpace 1048676
16:31:09 Action: Run 'oncheck -pt 1048676
however oncheck reports that the tablespace no does not exist. Informix
support believe it's
a temp table and that doing the export/import may fix the problem.
The myexport utility is a separate package, myexport, though it DOES
require utils2_ak and sqlcmd to work. The schema and data files it outputs
are fully compatible with myimport AND dbimport.
Watch for an update to myexport/myimport implementing a new flag to unload/
load in parallel, coming soon.
Art S. Kagel
mosserp@WellsFargo.COM wrote:
>
> You might try getting Art Kagel's myexport/myimport utilities from
> www.iiug.org. They are part of the utils2_ak package, and they also require
> Jonathan Leffler's SQLCMD utility from that same site. I haven't used these
> particular utilities, yet, but I *have* used Art's myschema and dbcopy to do
> a critical database reorg, and we rely on his dostats for several of our
> update statistics jobs.>
> HTH,
> Paul Mosser
> Wells Fargo & Co.
>
> -----Original Message-----
> From: Tam McLaughlin [mailto:tamm@scotlegal.com]
> Sent: Thursday, September 07, 2000 10:03 AM
> To: informix-list@iiug.org
> Subject: export fails with error : *** prepare unldobj
>
> I am in a bit of a panic as I have to export our databases for tomorrow
> morning
> as our servers disks get replaced but I am getting an error on the exports.
> I tried exporting 2 different databases and they both fall over with the
> same
> error at the same table. A sample from the dbexport.out file is below.
> We are on sco unixware 7.0.1 with IDS 7.30.UC2.
> I have tried :
> dbexport -d databasename -ss -c>
> and without the -c and get same result
>
> create table "dba".syscolformats
> (
> owner char(32),
> tabname char(32),
> .........
> ...........
> ) extent size 16 next size 16 lock mode row;
> revoke all on "dba".syscolformats from "public";>
> *** prepare unldobj
> 201 - A syntax error has occurred.
>
> Informix support have suggested the following options and cannot give me
> any other
> options/answer until tomorrow when it is too late.
>
> 1. dbexport without -c option.
> 2. unload the table which caused the problem and drop it before you run
> dbexport.
>
> 1 does not nwork
>
> I think it would be better to run a script (which i am doing now) to give me
> the
> schema , and then to unload each table , 1 at a time and to an unload file
> and try and
> generate an import file from the schema files.
> Any better ideas ?
>
> One other imporant thing, we are getting Assert failures as below:
>
> Cannot use TBLSpace page for TBLSpace 1048676
> 16:31:09 Action: Run 'oncheck -pt 1048676>
> however oncheck reports that the tablespace no does not exist. Informix
> support believe it's
> a temp table and that doing the export/import may fix the problem.