Help! - transaction log file
Posted in 2000
Topics: Error Codes & Troubleshooting, Transactions, Locking & Isolation
Hi, all;
I need your help again! I deleted the transaction log file in /tmp
mistakenly. Right now I can not select the database. It shows the
message as following. Please help me to let me know what I should do.
It is SE and IDS on the same machine. SE shows me the error message and
IDS just hangs
224: Cannot open transaction log file.
120: ISAM error: cannot open log file.
Thanks million
Randy
Sent via Deja.com
http://www.deja.com/
Randy,
Just do the following:
cd /tmp
touch logfile (where logfile is the name of the log file)
(use "cat /dev/null > logfile" if you do not have touch for some reason)
If you still get errors, try changing the owner & permissions of the log
file:
chmod 666 /tmp/logfile
chown informix /tmp/logfile
chgrp informix /tmp/logfile
If it still doesn't work, that is not the name of the log file. Try this to
find it out:
cd /dir/database.dbs (where /dir/database.dbs is the directory where the
database files are)
grep syslog systables.dat
The last command will display some data and in it will be the log file name
(there may be other stuff, so you will have to try to recognize it).
You need to create that file shown. Use the touch command or "cat /dev/null
> /dir/logfile" to do that.
<r_hao@hotmail.com> wrote in message news:91ikav$q18$1@nnrp1.deja.com...
> Hi, all;
>
> I need your help again! I deleted the transaction log file in /tmp
> mistakenly. Right now I can not select the database. It shows the
> message as following. Please help me to let me know what I should do.
>
> It is SE and IDS on the same machine. SE shows me the error message and
> IDS just hangs
>
> 224: Cannot open transaction log file.
> 120: ISAM error: cannot open log file.>
> Thanks million
>
> Randy
>
>
> Sent via Deja.com
> http://www.deja.com/
JJ;
Thanks for the tip of "grep syslog systables.dat". It turns out that
log file is call 'dblog', not syslog as I thought.
Now the SE is work, what about IDS, they both run on the same machine.
When I start the IDS, I can not run dbaccess. It hangs without any
error messages
Thank you again for your kind help.
Randy
In article <3a3e16c0.0@news.kivex.com>,
"JJ" <jj@nospam.com> wrote:
> Randy,
>
> Just do the following:
>
> cd /tmp
> touch logfile (where logfile is the name of the log file)
>
> (use "cat /dev/null > logfile" if you do not have touch for some
reason)
>
> If you still get errors, try changing the owner & permissions of the
log
> file:
>
> chmod 666 /tmp/logfile
> chown informix /tmp/logfile
> chgrp informix /tmp/logfile
>
> If it still doesn't work, that is not the name of the log file. Try
this to
> find it out:
>
> cd /dir/database.dbs (where /dir/database.dbs is the directory
where the
> database files are)
> grep syslog systables.dat
>
> The last command will display some data and in it will be the log
file name
> (there may be other stuff, so you will have to try to recognize it).
>
> You need to create that file shown. Use the touch command
or "cat /dev/null
> > /dir/logfile" to do that.
>
> <r_hao@hotmail.com> wrote in message news:91ikav$q18
$1@nnrp1.deja.com...
> > Hi, all;
> >
> > I need your help again! I deleted the transaction log file in /tmp
> > mistakenly. Right now I can not select the database. It shows the
> > message as following. Please help me to let me know what I should
do.
> >
> > It is SE and IDS on the same machine. SE shows me the error message
and
> > IDS just hangs
> >
> > 224: Cannot open transaction log file.
> > 120: ISAM error: cannot open log file.> >
> > Thanks million
> >
> > Randy
> >
> >
> > Sent via Deja.com
> > http://www.deja.com/
>
>
Sent via Deja.com
http://www.deja.com/
I don't know enough about IDS to answer that, but one thing that comes to
mind is to be sure that they are both not trying to use the same TCP/IP
port. This is specified in $INFORMIXDIR/etc/sqlhosts with SE (you need to
look up the value in the last field in /etc/services to find out the
number).
<r_hao@hotmail.com> wrote in message news:91mjv1$ulg$1@nnrp1.deja.com...
> JJ;
>
> Thanks for the tip of "grep syslog systables.dat". It turns out that
> log file is call 'dblog', not syslog as I thought.
>
> Now the SE is work, what about IDS, they both run on the same machine.
> When I start the IDS, I can not run dbaccess. It hangs without any
> error messages
>
> Thank you again for your kind help.
>
> Randy
>
> In article <3a3e16c0.0@news.kivex.com>,
> "JJ" <jj@nospam.com> wrote:
> > Randy,
> >
> > Just do the following:
> >
> > cd /tmp
> > touch logfile (where logfile is the name of the log file)
> >
> > (use "cat /dev/null > logfile" if you do not have touch for some
> reason)
> >
> > If you still get errors, try changing the owner & permissions of the
> log
> > file:
> >
> > chmod 666 /tmp/logfile
> > chown informix /tmp/logfile
> > chgrp informix /tmp/logfile
> >
> > If it still doesn't work, that is not the name of the log file. Try
> this to
> > find it out:
> >
> > cd /dir/database.dbs (where /dir/database.dbs is the directory
> where the
> > database files are)
> > grep syslog systables.dat
> >
> > The last command will display some data and in it will be the log
> file name
> > (there may be other stuff, so you will have to try to recognize it).
> >
> > You need to create that file shown. Use the touch command
> or "cat /dev/null
> > > /dir/logfile" to do that.
> >
> > <r_hao@hotmail.com> wrote in message news:91ikav$q18
> $1@nnrp1.deja.com...
> > > Hi, all;
> > >
> > > I need your help again! I deleted the transaction log file in /tmp
> > > mistakenly. Right now I can not select the database. It shows the
> > > message as following. Please help me to let me know what I should
> do.
> > >
> > > It is SE and IDS on the same machine. SE shows me the error message
> and
> > > IDS just hangs
> > >
> > > 224: Cannot open transaction log file.
> > > 120: ISAM error: cannot open log file.> > >
> > > Thanks million
> > >
> > > Randy
> > >
> > >
> > > Sent via Deja.com
> > > http://www.deja.com/
> >
> >
>
>
> Sent via Deja.com
> http://www.deja.com/