RE: OnBar/ADSM/IDS 7.3
Posted in 1999
What error message are you getting when backing up logs to ADSM?
After upgrading from IDS 7.30.UC3X3 to ODS 7.30.UC6-1, we starting getting
the following messages in our online.log:
07:55:45 Process exited with return code 255: /bin/sh /bin/sh -c
/informix/7.30.UC6-1/bi/infxalrm 2 23 "Logical Log 2058 Complete." "Logical Log 2058 Complete."
07:55:46 Logical Log 2058 - Backup Started
07:56:07 Checkpoint Completed: duration was 7 seconds.
07:56:10 Logical Log 2058 - Backup Completed
07:56:10 Process exited with return code 255: /bin/sh /bin/sh -c
/informix/7.30.UC6-1/bi/infxalrm 2 18 "Log Backup completed: 2058." "Logical Log 2058 - Backup
Comple
The backup runs OK according to the onbar log (/tmp/bar_act.log).
We have an open case with Informix Technical Support on this issue.
Their initial response was to switch our alarm program to "no_log.sh".
We didn't do this, because we want the ALARMPROGRAM to back-up our logical
logs.
However, I experimented by inserting an "exit 0" as the first executable
statement in the ALARMPROGRAM. The first set of messages still occurred.
Therefore, the ALARMPROGRAM is not the cause of these "return code 255"
messages.
Our LTAPEDEV is set to a directory where various log files reside.
I had been told it needs to be set to valid location other than /dev/null
before
onbar will work.
Rick Bernstein
rbernste@alarismed.com
-----Original Message-----
From: michael wallace [mailto:wallace@infotechusa.com]
Sent: Thursday, January 21, 1999 19:55
To: informix-list@iiug.org
Subject: OnBar/ADSM/IDS 7.3
I have just about finished configuring OnBar and ADSM. The Level 0 and
Level 1 Backups run but report an error backing up the logical logs. The
onbar -l call from the log_full.sh creates this error message. What hasto be set in the onconfig file for tapedev to call the library defined
by adsm.
Thanks in advance
Mike Wallace
wallace@infotechusa.com