Re: Cannot write sorted rows.
Posted in 2000
Topics: Storage & Space Management, Error Codes & Troubleshooting, Platform-Specific Issues
I'm also getting this problem. I have increased the temporary DBSpace to 400MB. I'm running on an NT machine but we have seen this on solaris. This does not happen for all queries only on a particularly complicated one when I' trying to do an order by. There is plenty of disk space also on this machine. Does anybody know if this is a problem with contigious free space? Does anybody know how I can check that the DBMS is using the temporary space which I created. Thanks Michael. gina_132@my-deja.com wrote: > Hi , can any body help me to go throw the error: > > SQL Error (-567) : Cannot write sorted rows.[ISAM error -5 : I/O error ] > > Best regards, > Galina > > Sent via Deja.com http://www.deja.com/ > Before you buy.
Unless you are also getting ISAM error -5 you have a different problem. Looks like you just do no have enough tempspace. Do you have the DBSPACETEMP environment variable set to point to that large temp dbspace? If not ROOTDBS will be used for sort-work files! Note also that if PSORT_DBTEMP is set (it should list FILESYSTEMS or disks rather than dbspaces) the listed filesystems will be used instead of the temp dbspace for the sort-work files which is often faster and since you have lots of disk PSORT_DBTEMP is a way of taking advantage of that without locking up tons of filespace in temp dbspace chunks. Art S. Kagel Michael Kearns wrote: > > I'm also getting this problem. I have increased the temporary DBSpace to > 400MB. I'm running on an NT machine but we have seen this on solaris. This > does not happen for all queries only on a particularly complicated one when > I' trying to do an order by. There is plenty of disk space also on this > machine. Does anybody know if this is a problem with contigious free space? > > Does anybody know how I can check that the DBMS is using the temporary space > which I created. > > Thanks > > Michael. > > gina_132@my-deja.com wrote: > > > Hi , can any body help me to go throw the error: > > > > SQL Error (-567) : Cannot write sorted rows.[ISAM error -5 : I/O error ] > > > > Best regards, > > Galina > > > > Sent via Deja.com http://www.deja.com/ > > Before you buy.