RE: UPDATE STATISTICS and Error -647
Posted in 2000
Topics: Server Administration, Platform-Specific Issues
> <cpmiller@lucent.com> writes
> >
> >I have a script that performs the following statement:
> >
> >UPDATE STATISTICS MEDIUM FOR TABLE p3e DISTRIBUTIONS ONLY;> >
> >From onstat -g sql I get a -647 in the SQL ERR column.
> >Could someone explain, please?
> >
> >The platform is:
> >Online 7.24.UC5
> >Sun 5000, Solarius 2.6
> >
>
> Does the command complete without error in dbaccess, I seem
> to remember
> a small buglet whereby the onstat -g sql indicated an error
> where there
> wasn't one. It was under 7.12 and Dynix/pts, I saw it first
> and I sure
> it was there under Solaris as well.
A similar buglet exists for AIX and 7.30
Running update statistics reports error 211 through
onstat -g sql but is syntactically correct. This is more of anannoyance than a problem since the statistics do actually get
updated.
Jo
___________________________________________________________________________
This email is confidential and intended solely for the use of the
individual to whom it is addressed. Any views or opinions presented are
solely those of the author and do not necessarily represent those of
Sema Group.
If you are not the intended recipient, be advised that you have received this
email in error and that any use, dissemination, forwarding, printing, or
copying of this email is strictly prohibited.
If you have received this email in error please notify the Sema Group
Helpdesk by telephone on +44 (0) 121 627 5600.
___________________________________________________________________________
In article <8l42nm$1f7$1@news.xmission.com>, COOPER, Joseph
<Joseph.COOPER@sema.co.uk> writes
>
>> <cpmiller@lucent.com> writes
>> >
>> >I have a script that performs the following statement:
>> >
>> >UPDATE STATISTICS MEDIUM FOR TABLE p3e DISTRIBUTIONS ONLY;>> >
>> >From onstat -g sql I get a -647 in the SQL ERR column.
>> >Could someone explain, please?
>> >
>> >The platform is:
>> >Online 7.24.UC5
>> >Sun 5000, Solarius 2.6
>> >
>>
>> Does the command complete without error in dbaccess, I seem
I have seen a bug in isql where the single statement
(on a logged database)
ALTER FRAGMENT ON TABLE x INIT IN datadbs1;
fails under isql with error -875:
"Incompatible Access Mode and Isolation Level.
If you set the access mode to READ-WRITE, you cannot set the
isolation level to READ-UNCOMMITTED." (!????)
but this works in dbaccess!!!
Seems as if isql and dbaccess send the SQL to the engine in different
ways (??) or use different versions of libraries (??).
dbaccess was meant to replace isql but does not include the
Query -> Forms option (or ace reports). I notice that isql
Query-> Forms generates forms which will not work with
fragmenteded tables that do not have a rowid. They fail with a
message like (cannot find rowid / cannot access row via rowid).
Seems isql does not properly handle 100% of the new features in the
^^^^
version 7.x engines. Close but not quite complete!!
We now use a script instead which invokes dbaccess first and if
it cannot find dbaccess then uses isql.
>> to remember
>> a small buglet whereby the onstat -g sql indicated an error
>> where there
>> wasn't one. It was under 7.12 and Dynix/pts, I saw it first
>> and I sure
>> it was there under Solaris as well.
>
>A similar buglet exists for AIX and 7.30
>Running update statistics reports error 211 through
>onstat -g sql but is syntactically correct. This is more of an>annoyance than a problem since the statistics do actually get
>updated.
>
>Jo
>
>
>___________________________________________________________________________
>This email is confidential and intended solely for the use of the
>individual to whom it is addressed. Any views or opinions presented are
>solely those of the author and do not necessarily represent those of
>Sema Group.
>If you are not the intended recipient, be advised that you have received this
>email in error and that any use, dissemination, forwarding, printing, or
>copying of this email is strictly prohibited.
>
>If you have received this email in error please notify the Sema Group
>Helpdesk by telephone on +44 (0) 121 627 5600.
>___________________________________________________________________________
--
David Williams
Related threads
- Posting from the Informix-list
- Migrating from IDS 9.40.UC6 to 11.50.UC3
- Ip for a network session
- questions onstat -g