unable to connect INFORMIX through ODBC
Posted in 2008
Topics: Connectivity: ODBC / JDBC / .NET, Security, Permissions & Auditing, Networking & sqlhosts Configuration
Dear Sir/Madam,
We are trying to connect to Informix database through odbc connectivity. But
we are unable to locate the error.
Environment
Informix Dynamic Server : 7.30 FC4
Informix Connect : 3.0 (which I downloaded from ibm website)
Operating System : Compaq Tru64 Unix 5.1B
Parameters
INFORMIXSERVER = wmc
Hostname = wmic.warba.com
Servicename = wtic
Protocolname = onsoctcp
Databasename = production
My sqlhosts file looks as follows:-
wmc onipcshm wmic.warba.com wicshm
wmc1 onipcshm wmic.warba.com wicshm
wmc onsoctcp wmic.warba.com wtic
I edited services file (/etc) in unix and add an entry like this:-
wtic 1528/tcp
I edited services file (c:\\\\windows/system32\\\\drivers\\\\etc) in windows and add an
entry like this:-
wtic 1528/tcp
I edited IBM Informix Setnet32 (Informix Connect) entries as follows:-
Environment tab
INFORMIXSERVER=wmc
Server Information tab
IBM Informix Server : wmc
HostName : wmic.warba.com
Protocolname : onsoctcp
Service Name : wtic
Host Information tab
Current Host : wmic.warba.com
I entered User Name & Password as the same which we are using for our
production database
Then I tried to open through iLogin Demo for IBM INFORMIX-Connect for Win32
Server : wmc
Hostname : wmic.warba.com
Servicename : wtic
Protocolname : onsoctcp
Username/Password : same as which we are using to connect to our unix system
Stores Database: production
It returns me error.
Please try to help me on this issue. A quick response is highly appreciated.
Thanks in Advance
Best regards,
Regi Mammen
Warba Takaful Insurance Co.
Kuwait
You didn't mention ODBC DSN being used (usually in your home dir with file
.odbc.ini). Post your odbc.ini entries. Also, in your SQLHOST file you
seem to have same server name one with shared memory and another with
socket, I am not sure if this could also be a problem. Also, make sure you
have initialized server using tcp and not shared memory as your client
seem to be on Windows machine and server on Compaq. What's the error
message you get?
-Shesh
"REGI MAMMEN" <mammen_regi@hotmail.com>
Sent by: ids-bounces@iiug.org
10/05/2008 14:16
Please respond to
ids@iiug.org
To
ids@iiug.org
cc
Subject
unable to connect INFORMIX through ODBC [12068]
Dear Sir/Madam,
We are trying to connect to Informix database through odbc connectivity.
But
we are unable to locate the error.
Environment
Informix Dynamic Server : 7.30 FC4
Informix Connect : 3.0 (which I downloaded from ibm website)
Operating System : Compaq Tru64 Unix 5.1B
Parameters
INFORMIXSERVER = wmc
Hostname = wmic.warba.com
Servicename = wtic
Protocolname = onsoctcp
Databasename = production
My sqlhosts file looks as follows:-
wmc onipcshm wmic.warba.com wicshm
wmc1 onipcshm wmic.warba.com wicshm
wmc onsoctcp wmic.warba.com wtic
I edited services file (/etc) in unix and add an entry like this:-
wtic 1528/tcp
I edited services file (c:\\\\windows/system32\\\\drivers\\\\etc) in windows and
add an
entry like this:-
wtic 1528/tcp
I edited IBM Informix Setnet32 (Informix Connect) entries as follows:-
Environment tab
INFORMIXSERVER=wmc
Server Information tab
IBM Informix Server : wmc
HostName : wmic.warba.com
Protocolname : onsoctcp
Service Name : wtic
Host Information tab
Current Host : wmic.warba.com
I entered User Name & Password as the same which we are using for our
production database
Then I tried to open through iLogin Demo for IBM INFORMIX-Connect for
Win32
Server : wmc
Hostname : wmic.warba.com
Servicename : wtic
Protocolname : onsoctcp
Username/Password : same as which we are using to connect to our unix
system
Stores Database: production
It returns me error.
Please try to help me on this issue. A quick response is highly
appreciated.
Thanks in Advance
Best regards,
Regi Mammen
Warba Takaful Insurance Co.
Kuwait
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Since its not very clear, I am assuming re-start of Informix went fine.
And the error you are getting is while trying to connect to Informix
server. I hope your client is Windows only. If so, you have to create DSN
by going to Start->Control Panel->Administrative Tool->Data Source (ODBC).
You can go through Informix ODBC Manual for more information.
-Shesh
Regi Mammen <mammen_regi@hotmail.com>
11/05/2008 14:49
To
Sheshnarayan Agrawal/India/IBM@IBMIN
cc
Subject
RE: unable to connect INFORMIX through ODBC [12069]
Hi Sesh,
Thank you for your mail.
After edited the SQLHOSTS file we restarted the informix database.
The error which i'm getting is error no: -25580 ie, System error occurred
in network function. A system call has failed.
Here is my odbc.ini entries:
[ODBC 32 bit Data Sources]
MS Access Database=Microsoft Access Driver (*.mdb) (32 bit)
Excel Files=Microsoft Excel Driver (*.xls) (32 bit)
dBASE Files=Microsoft dBase Driver (*.dbf) (32 bit)
dev=IBM INFORMIX ODBC DRIVER (32 bit)
[MS Access Database]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[Excel Files]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[dBASE Files]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[dev]
Driver32=C:\\\\Program Files\\\\IBM\\\\Informix\\\\Client-SDK\\\\\\\\bin\\\\iclit09b.dll
Hope u can help me. Waiting for your reply. Thanks
Best Regards,
Regi Mammen
> To: mammen_regi@hotmail.com
> From: shagrawal@in.ibm.com
> Subject: Re: unable to connect INFORMIX through ODBC [12069]
> Date: Sat, 10 May 2008 05:15:19 -0400
>
> You didn't mention ODBC DSN being used (usually in your home dir with
file
> ..odbc.ini). Post your odbc.ini entries. Also, in your SQLHOST file you
> seem to have same server name one with shared memory and another with
> socket, I am not sure if this could also be a problem. Also, make sure
you
> have initialized server using tcp and not shared memory as your client
> seem to be on Windows machine and server on Compaq. What's the error
> message you get?
>
> -Shesh
>
> "REGI MAMMEN" <mammen_regi@hotmail.com>
> Sent by: ids-bounces@iiug.org
> 10/05/2008 14:16
> Please respond to
> ids@iiug.org
>
> To
> ids@iiug.org
> cc
>
> Subject
> unable to connect INFORMIX through ODBC [12068]
>
> Dear Sir/Madam,
>
> We are trying to connect to Informix database through odbc connectivity.
> But
> we are unable to locate the error.
>
> Environment
>
> Informix Dynamic Server : 7.30 FC4
> Informix Connect : 3.0 (which I downloaded from ibm website)
> Operating System : Compaq Tru64 Unix 5.1B
>
> Parameters
>
> INFORMIXSERVER = wmc
> Hostname = wmic.warba.com
> Servicename = wtic
> Protocolname = onsoctcp
> Databasename = production
>
> My sqlhosts file looks as follows:-
> wmc onipcshm wmic.warba.com wicshm
> wmc1 onipcshm wmic.warba.com wicshm
> wmc onsoctcp wmic.warba.com wtic>
> I edited services file (/etc) in unix and add an entry like this:-
> wtic 1528/tcp
>
> I edited services file (c:\\\\windows/system32\\\\drivers\\\\etc) in windows and
> add an
> entry like this:-
> wtic 1528/tcp
>
> I edited IBM Informix Setnet32 (Informix Connect) entries as follows:-
>
> Environment tab
> INFORMIXSERVER=wmc>
> Server Information tab
> IBM Informix Server : wmc
> HostName : wmic.warba.com
> Protocolname : onsoctcp
> Service Name : wtic
>
> Host Information tab
> Current Host : wmic.warba.com
>
> I entered User Name & Password as the same which we are using for our
> production database
>
> Then I tried to open through iLogin Demo for IBM INFORMIX-Connect for
> Win32
> Server : wmc
> Hostname : wmic.warba.com
> Servicename : wtic
> Protocolname : onsoctcp
> Username/Password : same as which we are using to connect to our unix
> system
> Stores Database: production
>
> It returns me error.
>
> Please try to help me on this issue. A quick response is highly
> appreciated.
>
> Thanks in Advance
>
> Best regards,
>
> Regi Mammen
>
> Warba Takaful Insurance Co.
>
> Kuwait
>
>
>
*******************************************************************************
>
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
Get Free (PRODUCT) RED⢠Emoticons, Winks and Display Pics. Check it out!
Perhaps Tru64 Unix requires TLI/TCP instead of SOC/TCP? Should be in the
'machine' release notes somewhere under $INFORMIXDIR/release/*
Bob Roussey
Unix / Informix Administration
Spirit Airlines
Robert.Roussey@SpiritAir.com
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
Sheshnarayan Agrawal
Sent: Sunday, May 11, 2008 5:49 AM
To: ids@iiug.org
Subject: RE: unable to connect INFORMIX through ODBC [12075]
Since its not very clear, I am assuming re-start of Informix went fine.
And the error you are getting is while trying to connect to Informix
server. I hope your client is Windows only. If so, you have to create DSN
by going to Start->Control Panel->Administrative Tool->Data Source (ODBC).
You can go through Informix ODBC Manual for more information.
-Shesh
Regi Mammen <mammen_regi@hotmail.com>
11/05/2008 14:49
To
Sheshnarayan Agrawal/India/IBM@IBMIN
cc
Subject
RE: unable to connect INFORMIX through ODBC [12069]
Hi Sesh,
Thank you for your mail.
After edited the SQLHOSTS file we restarted the informix database.
The error which i'm getting is error no: -25580 ie, System error occurred
in network function. A system call has failed.
Here is my odbc.ini entries:
[ODBC 32 bit Data Sources]
MS Access Database=Microsoft Access Driver (*.mdb) (32 bit)
Excel Files=Microsoft Excel Driver (*.xls) (32 bit)
dBASE Files=Microsoft dBase Driver (*.dbf) (32 bit)
dev=IBM INFORMIX ODBC DRIVER (32 bit)
[MS Access Database]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[Excel Files]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[dBASE Files]
Driver32=C:\\\\WINDOWS\\\\System32\\\\odbcjt32.dll
[dev]
Driver32=C:\\\\Program Files\\\\IBM\\\\Informix\\\\Client-SDK\\\\\\\\bin\\\\iclit09b.dll
Hope u can help me. Waiting for your reply. Thanks
Best Regards,
Regi Mammen
> To: mammen_regi@hotmail.com
> From: shagrawal@in.ibm.com
> Subject: Re: unable to connect INFORMIX through ODBC [12069]
> Date: Sat, 10 May 2008 05:15:19 -0400
>
> You didn't mention ODBC DSN being used (usually in your home dir with
file
> ..odbc.ini). Post your odbc.ini entries. Also, in your SQLHOST file you
> seem to have same server name one with shared memory and another with
> socket, I am not sure if this could also be a problem. Also, make sure
you
> have initialized server using tcp and not shared memory as your client
> seem to be on Windows machine and server on Compaq. What's the error
> message you get?
>
> -Shesh
>
> "REGI MAMMEN" <mammen_regi@hotmail.com>
> Sent by: ids-bounces@iiug.org
> 10/05/2008 14:16
> Please respond to
> ids@iiug.org
>
> To
> ids@iiug.org
> cc
>
> Subject
> unable to connect INFORMIX through ODBC [12068]
>
> Dear Sir/Madam,
>
> We are trying to connect to Informix database through odbc connectivity.
> But
> we are unable to locate the error.
>
> Environment
>
> Informix Dynamic Server : 7.30 FC4
> Informix Connect : 3.0 (which I downloaded from ibm website)
> Operating System : Compaq Tru64 Unix 5.1B
>
> Parameters
>
> INFORMIXSERVER = wmc
> Hostname = wmic.warba.com
> Servicename = wtic
> Protocolname = onsoctcp
> Databasename = production
>
> My sqlhosts file looks as follows:-
> wmc onipcshm wmic.warba.com wicshm
> wmc1 onipcshm wmic.warba.com wicshm
> wmc onsoctcp wmic.warba.com wtic>
> I edited services file (/etc) in unix and add an entry like this:-
> wtic 1528/tcp
>
> I edited services file (c:\\\\windows/system32\\\\drivers\\\\etc) in windows and
> add an
> entry like this:-
> wtic 1528/tcp
>
> I edited IBM Informix Setnet32 (Informix Connect) entries as follows:-
>
> Environment tab
> INFORMIXSERVER=wmc>
> Server Information tab
> IBM Informix Server : wmc
> HostName : wmic.warba.com
> Protocolname : onsoctcp
> Service Name : wtic
>
> Host Information tab
> Current Host : wmic.warba.com
>
> I entered User Name & Password as the same which we are using for our
> production database
>
> Then I tried to open through iLogin Demo for IBM INFORMIX-Connect for
> Win32
> Server : wmc
> Hostname : wmic.warba.com
> Servicename : wtic
> Protocolname : onsoctcp
> Username/Password : same as which we are using to connect to our unix
> system
> Stores Database: production
>
> It returns me error.
>
> Please try to help me on this issue. A quick response is highly
> appreciated.
>
> Thanks in Advance
>
> Best regards,
>
> Regi Mammen
>
> Warba Takaful Insurance Co.
>
> Kuwait
>
>
>
*******************************************************************************
>
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
Get Free (PRODUCT) REDâ"¢ Emoticons, Winks and Display Pics. Check it out!
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.