DBspace powrs_01 is disabled.
Posted in 2011
Topics: Backup & Restore, Storage & Space Management, Stored Procedures & SPL, Error Codes & Troubleshooting, Server Administration, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
We use AIX 5.3.0.0 with IDS 10.00.UC5:
Any solutions before I restore the instance from ontape backup?
06:45:20 Maximum server connections 56
15:12:12 IBM Informix Dynamic Server Started.
15:12:13 VP pid=31236 priority fixed at 60, former = 71
Sat Jan 8 15:12:14 2011
15:12:14 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has insecure
permissions
15:12:14 Event alarms enabled. ALARMPROG =
'/ifmx/ifmx04401/fs_server/etc/log_full.sh'
15:12:14 Booting Language <c> from module <>
15:12:14 Loading Module <CNULL>
15:12:14 Booting Language <builtin> from module <>
15:12:14 Loading Module <BUILTINNULL>
15:12:19 DR: DRAUTO is 0 (Off)
15:12:19 AIX MP latch code enabled
15:12:20 IBM Informix Dynamic Server Version 10.00.UC5 Software
Serial Number AAA#B000000
15:12:21 IBM Informix Dynamic Server Initialized -- Shared Memory
Initialized.
15:12:21 Physical Recovery Started at Page (2:12279).
15:12:21 Physical Recovery Complete: 0 Pages Examined, 0 Pages
Restored.
15:12:21 Logical Recovery Started.
15:12:21 10 recovery worker threads will be started.
15:12:23 Rollforward of log record failed. iserrno = 126
15:12:23 Log Record: log = 17319, pos = 0x29e044, type =
OLDRSAM:HINSERT(40), trans = 34
15:12:42 Assert Warning: Chunk 14 is being taken OFFLINE.
15:12:42 IBM Informix Dynamic Server Version 10.00.UC5
15:12:42 Who: Session(12, informix@sls0440, 0, 5022c118)
Thread(27, xchg_1.3, 502031b4, 1)
File: rsmirror.c Line: 1922
15:12:42 Results: DBspace powrs_01 is disabled.
15:12:42 Action: Restore DBspace powrs_01
15:12:42 stack trace for pid 31236 written to /tmp/af.403d334
15:12:42 See Also: /tmp/af.403d334
15:12:43 Chunk 14 is being taken OFFLINE.
15:12:43 Rollforward of log record failed. iserrno = 126
15:12:43 Log Record: log = 17319, pos = 0x29e044, type =
OLDRSAM:HINSERT(40), trans = 34
15:12:45 Rollforward of log record failed. iserrno = 101
15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
OLDRSAM:HINSERT(40), trans = 23
15:12:45 Rollforward of log record failed. iserrno = 101
15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
OLDRSAM:HINSERT(40), trans = 23
15:12:47 Rollforward of log record failed. iserrno = 101
15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
OLDRSAM:HINSERT(40), trans = 34
15:12:47 Rollforward of log record failed. iserrno = 101
15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
OLDRSAM:HINSERT(40), trans = 34
15:12:49 Rollforward of log record failed. iserrno = 101
15:12:49 Log Record: log = 17319, pos = 0x2a1044, type =
OLDRSAM:HINSERT(40), trans = 23
15:12:49 Rollforward of log record failed. iserrno = 101
15:19:48 Log Record: log = 17319, pos = 0x9d60d8, type =
OLDRSAM:HUPAFT(43), trans = 67
15:19:50 Logical Recovery has reached the transaction cleanup phase.
15:19:50 Logical Recovery Complete.
2434 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
15:19:52 Dataskip is now OFF for all dbspaces
15:19:52 Checkpoint Completed: duration was 0 seconds.
15:19:52 Checkpoint loguniq 17319, logpos 0x9e4018, timestamp:
0x47a12fc5
15:19:52 Maximum server connections 0
15:19:52 On-Line Mode
15:20:07 Booting Language <spl> from module <>
15:20:07 Loading Module <SPLNULL>
15:20:20 Checkpoint Completed: duration was 0 seconds.
15:20:20 Checkpoint loguniq 17319, logpos 0x9e5018, timestamp:
0x47a13001
$onstat -d
IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up
01:43:15 -- 621984 Kbytes
Dbspaces
address number flags fchunk nchunks pgsize flags owner
name
501317e8 1 0x40001 1 1 4096 N B
informix rootdbs
50a3fde0 2 0x40001 2 1 4096 N B
informix plogdbs
50a40018 3 0x40001 3 2 4096 N B
informix llogdbs
50a40178 4 0x42001 4 1 4096 N TB
informix tempdbs01
50a402d8 5 0x40001 5 2 4096 N B
informix emm0s_01
50a40438 6 0x40001 7 2 4096 N B
informix ollps_01
50a40598 7 0x40001 9 3 4096 N B
informix outbs_01
50a406f8 8 0x40005 14 20 4096 ND B
informix powrs_01
50a40858 9 0x40001 21 1 4096 N B
informix yms_01
9 active, 2047 maximum
Chunks
address chunk/dbs offset size free bpages flags
pathname
50131948 1 1 1 7750 5606 PO-B
/ifmx/ifmx04401/lv_server_01
502389e0 2 2 1 16383 80 PO-B
/ifmx/ifmx04401/lv_server_02
50238b68 3 3 1 122879 426 PO-B
/ifmx/ifmx04401/lv_server_03
50238cf0 4 4 1 24575 24522 PO-B
/ifmx/ifmx04401/lv_server_04
50238e78 5 5 1 32767 15810 PO-B
/ifmx/ifmx04401/lv_emm0_01
50131b18 6 5 1 32767 28161 PO-B
/ifmx/ifmx04401/lv_emm0_02
50131ca0 7 6 1 24575 1779 PO-B
/ifmx/ifmx04401/lv_ollp_01
50131e28 8 6 1 16383 16022 PO-B
/ifmx/ifmx04401/lv_ollp_02
50227630 9 7 1 122879 324 PO-B
/ifmx/ifmx04401/lv_outb_01
502277b8 10 7 1 122879 83518 PO-B
/ifmx/ifmx04401/lv_outb_02
50227940 11 7 1 131071 131068 PO-B
/ifmx/ifmx04401/lv_outb_03
50227ac8 12 3 1 131071 8668 PO-B
/ifmx/ifmx04401/lv_server_03_01
50227c50 13 8 0 131000 0 PD-B
/ifmx/ifmx04401/lv_powr_18
50227dd8 14 8 1 32767 0 PD-B
/ifmx/ifmx04401/lv_powr_01
50a3e018 15 8 1 65535 0 PD-B
/ifmx/ifmx04401/lv_powr_02
50a3e1a0 16 8 1 131071 0 PD-B
/ifmx/ifmx04401/lv_powr_03
50a3e328 17 8 1 106495 0 PD-B
/ifmx/ifmx04401/lv_powr_04
50a3e4b0 18 8 1 8191 0 PD-B
/ifmx/ifmx04401/lv_powr_05
50a3e638 19 8 1 131071 0 PD-B
/ifmx/ifmx04401/lv_powr_06
50a3e7c0 20 8 1 131071 0 PD-B
/ifmx/ifmx04401/lv_powr_07
50a3e948 21 9 1 122879 71200 PO-B
/ifmx/ifmx04401/lv_yms_01
50a3ead0 22 8 1 131071 0 PD-B
/ifmx/ifmx04401/lv_powr_08
50a3ec58 23 8 1 73499 0 PD-B
/ifmx/ifmx04401/lv_powr_09
50a3ede0 24 8 1 73727 0 PD-B
/ifmx/ifmx04401/lv_powr_10
50a3f018 25 8 1 73727 0 PD-B
/ifmx/ifmx04401/lv_powr_11
50a3f1a0 26 8 1 73727 0 PD-B
/ifmx/ifmx04401/lv_powr_12
50a3f328 27 8 1 262143 0 PD-B
/ifmx/ifmx04401/lv_powr_13
50a3f4b0 28 8 1 262143 0 PD-B
/ifmx/ifmx04401/lv_powr_14
50a3f638 29 8 0 256000 0 PD-B
/ifmx/ifmx04401/lv_powr_15
50a3f7c0 30 8 0 256000 0 PD-B
/ifmx/ifmx04401/lv_powr_16
50a3f948 31 8 1 262143 0 PD-B
/ifmx/ifmx04401/lv_powr_17
50a3fad0 32 8 1 524286 0 PD-B
/ifmx/ifmx04401/lv_powr_19
50a3fc58 33 8 1 524286 0 PD-B
/ifmx/ifmx04401/lv_powr_20
33 active, 32766 maximum
NOTE: The values in the "size" and "free" columns for DBspace chunks are
displayed in terms of "pgsize" of the DBspace to which they
belong.
Expanded chunk capacity mode: always
Thanks,
*******************************************************************
Ernie Knox
IT Database Administrator Specialist
Sears Holdings - BU: I & T Group
3333 Beverly Rd., B4-266A@@
If the dbspace was disabled in a way that wouldn't't cause corruption or
inconsistencies you can call IBM and the can mark it online. Otherwise
restore and roll forward logical logs.
Art
On Jan 8, 2011 6:00 PM, "Knox, Ernest" <Ernest.Knox@searshc.com> wrote:
> We use AIX 5.3.0.0 with IDS 10.00.UC5:
>
> Any solutions before I restore the instance from ontape backup?
>
> 06:45:20 Maximum server connections 56
>
> 15:12:12 IBM Informix Dynamic Server Started.
>
> 15:12:13 VP pid=31236 priority fixed at 60, former = 71
>
> Sat Jan 8 15:12:14 2011
>
> 15:12:14 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has insecure
> permissions
>
> 15:12:14 Event alarms enabled. ALARMPROG =
> '/ifmx/ifmx04401/fs_server/etc/log_full.sh'
>
> 15:12:14 Booting Language <c> from module <>
>
> 15:12:14 Loading Module <CNULL>
>
> 15:12:14 Booting Language <builtin> from module <>
>
> 15:12:14 Loading Module <BUILTINNULL>
>
> 15:12:19 DR: DRAUTO is 0 (Off)
>
> 15:12:19 AIX MP latch code enabled
>
> 15:12:20 IBM Informix Dynamic Server Version 10.00.UC5 Software
> Serial Number AAA#B000000
>
> 15:12:21 IBM Informix Dynamic Server Initialized -- Shared Memory
> Initialized.
>
> 15:12:21 Physical Recovery Started at Page (2:12279).
>
> 15:12:21 Physical Recovery Complete: 0 Pages Examined, 0 Pages
> Restored.
>
> 15:12:21 Logical Recovery Started.
>
> 15:12:21 10 recovery worker threads will be started.
>
> 15:12:23 Rollforward of log record failed. iserrno = 126
>
> 15:12:23 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:42 Assert Warning: Chunk 14 is being taken OFFLINE.
>
> 15:12:42 IBM Informix Dynamic Server Version 10.00.UC5
>
> 15:12:42 Who: Session(12, informix@sls0440, 0, 5022c118)
>
> Thread(27, xchg_1.3, 502031b4, 1)
>
> File: rsmirror.c Line: 1922
>
> 15:12:42 Results: DBspace powrs_01 is disabled.
>
> 15:12:42 Action: Restore DBspace powrs_01
>
> 15:12:42 stack trace for pid 31236 written to /tmp/af.403d334
>
> 15:12:42 See Also: /tmp/af.403d334
>
> 15:12:43 Chunk 14 is being taken OFFLINE.
>
> 15:12:43 Rollforward of log record failed. iserrno = 126
>
> 15:12:43 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:12:49 Log Record: log = 17319, pos = 0x2a1044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:19:48 Log Record: log = 17319, pos = 0x9d60d8, type =
> OLDRSAM:HUPAFT(43), trans = 67
>
> 15:19:50 Logical Recovery has reached the transaction cleanup phase.
>
> 15:19:50 Logical Recovery Complete.
>
> 2434 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 15:19:52 Dataskip is now OFF for all dbspaces
>
> 15:19:52 Checkpoint Completed: duration was 0 seconds.
>
> 15:19:52 Checkpoint loguniq 17319, logpos 0x9e4018, timestamp:
> 0x47a12fc5
>
> 15:19:52 Maximum server connections 0
>
> 15:19:52 On-Line Mode
>
> 15:20:07 Booting Language <spl> from module <>
>
> 15:20:07 Loading Module <SPLNULL>
>
> 15:20:20 Checkpoint Completed: duration was 0 seconds.
>
> 15:20:20 Checkpoint loguniq 17319, logpos 0x9e5018, timestamp:
> 0x47a13001
>
> $onstat -d
>
> IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up
> 01:43:15 -- 621984 Kbytes>
> Dbspaces
>
> address number flags fchunk nchunks pgsize flags owner
> name
>
> 501317e8 1 0x40001 1 1 4096 N B
> informix rootdbs
>
> 50a3fde0 2 0x40001 2 1 4096 N B
> informix plogdbs
>
> 50a40018 3 0x40001 3 2 4096 N B
> informix llogdbs
>
> 50a40178 4 0x42001 4 1 4096 N TB
> informix tempdbs01
>
> 50a402d8 5 0x40001 5 2 4096 N B
> informix emm0s_01
>
> 50a40438 6 0x40001 7 2 4096 N B
> informix ollps_01
>
> 50a40598 7 0x40001 9 3 4096 N B
> informix outbs_01
>
> 50a406f8 8 0x40005 14 20 4096 ND B
> informix powrs_01
>
> 50a40858 9 0x40001 21 1 4096 N B
> informix yms_01
>
> 9 active, 2047 maximum
>
> Chunks
>
> address chunk/dbs offset size free bpages flags
> pathname
>
> 50131948 1 1 1 7750 5606 PO-B
> /ifmx/ifmx04401/lv_server_01
>
> 502389e0 2 2 1 16383 80 PO-B
> /ifmx/ifmx04401/lv_server_02
>
> 50238b68 3 3 1 122879 426 PO-B
> /ifmx/ifmx04401/lv_server_03
>
> 50238cf0 4 4 1 24575 24522 PO-B
> /ifmx/ifmx04401/lv_server_04
>
> 50238e78 5 5 1 32767 15810 PO-B
> /ifmx/ifmx04401/lv_emm0_01
>
> 50131b18 6 5 1 32767 28161 PO-B
> /ifmx/ifmx04401/lv_emm0_02
>
> 50131ca0 7 6 1 24575 1779 PO-B
> /ifmx/ifmx04401/lv_ollp_01
>
> 50131e28 8 6 1 16383 16022 PO-B
> /ifmx/ifmx04401/lv_ollp_02
>
> 50227630 9 7 1 122879 324 PO-B
> /ifmx/ifmx04401/lv_outb_01
>
> 502277b8 10 7 1 122879 83518 PO-B
> /ifmx/ifmx04401/lv_outb_02
>
> 50227940 11 7 1 131071 131068 PO-B
> /ifmx/ifmx04401/lv_outb_03
>
> 50227ac8 12 3 1 131071 8668 PO-B
> /ifmx/ifmx04401/lv_server_03_01
>
> 50227c50 13 8 0 131000 0 PD-B
> /ifmx/ifmx04401/lv_powr_18
>
> 50227dd8 14 8 1 32767 0 PD-B
> /ifmx/ifmx04401/lv_powr_01
>
> 50a3e018 15 8 1 65535 0 PD-B
> /ifmx/ifmx04401/lv_powr_02
>
> 50a3e1a0 16 8 1 131071 0 PD-B
> /ifmx/ifmx04401/lv_powr_03
>
> 50a3e328 17 8 1 106495 0 PD-B
> /ifmx/ifmx04401/lv_powr_04
>
> 50a3e4b0 18 8 1 8191 0 PD-B
> /ifmx/ifmx04401/lv_powr_05
>
> 50a3e638 19 8 1 131071 0 PD-B
> /ifmx/ifmx04401/lv_powr_06
>
> 50a3e7c0 20 8 1 131071 0 PD-B
> /ifmx/ifmx04401/lv_powr_07
>
> 50a3e948 21 9 1 122879 71200 PO-B
> /ifmx/ifmx04401/lv_yms_01
>
> 50a3ead0 22 8 1 131071 0 PD-B
> /ifmx/ifmx04401/lv_powr_08
>
> 50a3ec58 23 8 1 73499 0 PD-B
> /ifmx/ifmx04401/lv_powr_09
>
> 50a3ede0 24 8 1 73727 0 PD-B
> /ifmx/ifmx04401/lv_powr_10
>
> 50a3f018 25 8 1 73727 0 PD-B
> /ifmx/ifmx04401/lv_powr_11
>
> 50a3f1a0 26 8 1 73727 0 PD-B
> /ifmx/ifmx04401/lv_powr_12
>
> 50a3f328 27 8 1 262143 0 PD-B
> /ifmx/ifmx04401/lv_powr_13
>
> 50a3f4b0 28 8 1 262143 0 PD-B
> /ifmx/ifmx04401/lv_powr_14
>
> 50a3f638 29 8 0 256000 0 PD-B
> /ifmx/ifmx04401/lv_powr_15
>
> 50a3f7c0 30 8 0 256000 0 PD-B
> /ifmx/ifmx04401/lv_powr_16
>
> 50a3f948 31
I have been in touch with IBM and they can bring the chunks on-line from
our contract.
I am going to perform an ontape restore, first.
Thanks,
*******************************************************************
Ernie Knox
IT Database Administrator Specialist
Sears Holdings - BU: I & T Group
3333 Beverly Rd., B4-266A
Hoffman Estates, IL. 60179
Office: (847) 286-5735
Email: Ernest.Knox@searshc.com
Blackberry: 2244650553@messaging.sprintpcs.com
Page via Skytel: 2244650553@sprint.skytel.com
Informix or MySQL Primary: 9110210@skytel.com
Informix or MySQL Secondary: 7276872@skytel.com
" Yes we can make a Change! "
" It's always a great day to watch Sports - GO LIONS, TIGERS, and BEARS!
"
" Lets not forget - GO Pistons and Red Wings! "
GSU
*******************************************************************
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
Art Kagel
Sent: Saturday, January 08, 2011 7:48 PM
To: ids@iiug.org
Subject: Re: DBspace powrs_01 is disabled. [22378]
If the dbspace was disabled in a way that wouldn't't cause corruption or
inconsistencies you can call IBM and the can mark it online. Otherwise
restore and roll forward logical logs.
Art
On Jan 8, 2011 6:00 PM, "Knox, Ernest" <Ernest.Knox@searshc.com> wrote:
> We use AIX 5.3.0.0 with IDS 10.00.UC5:
>
> Any solutions before I restore the instance from ontape backup?
>
> 06:45:20 Maximum server connections 56
>
> 15:12:12 IBM Informix Dynamic Server Started.
>
> 15:12:13 VP pid=31236 priority fixed at 60, former = 71
>
> Sat Jan 8 15:12:14 2011
>
> 15:12:14 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has
insecure
> permissions
>
> 15:12:14 Event alarms enabled. ALARMPROG =
> '/ifmx/ifmx04401/fs_server/etc/log_full.sh'
>
> 15:12:14 Booting Language <c> from module <>
>
> 15:12:14 Loading Module <CNULL>
>
> 15:12:14 Booting Language <builtin> from module <>
>
> 15:12:14 Loading Module <BUILTINNULL>
>
> 15:12:19 DR: DRAUTO is 0 (Off)
>
> 15:12:19 AIX MP latch code enabled
>
> 15:12:20 IBM Informix Dynamic Server Version 10.00.UC5 Software
> Serial Number AAA#B000000
>
> 15:12:21 IBM Informix Dynamic Server Initialized -- Shared Memory
> Initialized.
>
> 15:12:21 Physical Recovery Started at Page (2:12279).
>
> 15:12:21 Physical Recovery Complete: 0 Pages Examined, 0 Pages
> Restored.
>
> 15:12:21 Logical Recovery Started.
>
> 15:12:21 10 recovery worker threads will be started.
>
> 15:12:23 Rollforward of log record failed. iserrno = 126
>
> 15:12:23 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:42 Assert Warning: Chunk 14 is being taken OFFLINE.
>
> 15:12:42 IBM Informix Dynamic Server Version 10.00.UC5
>
> 15:12:42 Who: Session(12, informix@sls0440, 0, 5022c118)
>
> Thread(27, xchg_1.3, 502031b4, 1)
>
> File: rsmirror.c Line: 1922
>
> 15:12:42 Results: DBspace powrs_01 is disabled.
>
> 15:12:42 Action: Restore DBspace powrs_01
>
> 15:12:42 stack trace for pid 31236 written to /tmp/af.403d334
>
> 15:12:42 See Also: /tmp/af.403d334
>
> 15:12:43 Chunk 14 is being taken OFFLINE.
>
> 15:12:43 Rollforward of log record failed. iserrno = 126
>
> 15:12:43 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:12:49 Log Record: log = 17319, pos = 0x2a1044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:19:48 Log Record: log = 17319, pos = 0x9d60d8, type =
> OLDRSAM:HUPAFT(43), trans = 67
>
> 15:19:50 Logical Recovery has reached the transaction cleanup phase.
>
> 15:19:50 Logical Recovery Complete.
>
> 2434 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 15:19:52 Dataskip is now OFF for all dbspaces
>
> 15:19:52 Checkpoint Completed: duration was 0 seconds.
>
> 15:19:52 Checkpoint loguniq 17319, logpos 0x9e4018, timestamp:
> 0x47a12fc5
>
> 15:19:52 Maximum server connections 0
>
> 15:19:52 On-Line Mode
>
> 15:20:07 Booting Language <spl> from module <>
>
> 15:20:07 Loading Module <SPLNULL>
>
> 15:20:20 Checkpoint Completed: duration was 0 seconds.
>
> 15:20:20 Checkpoint loguniq 17319, logpos 0x9e5018, timestamp:
> 0x47a13001
>
> $onstat -d
>
> IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up
> 01:43:15 -- 621984 Kbytes>
> Dbspaces
>
> address number flags fchunk nchunks pgsize flags owner
> name
>
> 501317e8 1 0x40001 1 1 4096 N B
> informix rootdbs
>
> 50a3fde0 2 0x40001 2 1 4096 N B
> informix plogdbs
>
> 50a40018 3 0x40001 3 2 4096 N B
> informix llogdbs
>
> 50a40178 4 0x42001 4 1 4096 N TB
> informix tempdbs01
>
> 50a402d8 5 0x40001 5 2 4096 N B
> informix emm0s_01
>
> 50a40438 6 0x40001 7 2 4096 N B
> informix ollps_01
>
> 50a40598 7 0x40001 9 3 4096 N B
> informix outbs_01
>
> 50a406f8 8 0x40005 14 20 4096 ND B
> informix powrs_01
>
> 50a40858 9 0x40001 21 1 4096 N B
> informix yms_01
>
> 9 active, 2047 maximum
>
> Chunks
>
> address chunk/dbs offset size free bpages flags
> pathname
>
> 50131948 1 1 1 7750 5606 PO-B
> /ifmx/ifmx04401/lv_server_01
>
> 502389e0 2 2 1 16383 80 PO-B
> /ifmx/ifmx04401/lv_server_02
>
> 50238b68 3 3 1 122879 426 PO-B
> /ifmx/ifmx04401/lv_server_03
>
> 50238cf0 4 4 1 24575 24522 PO-B
> /ifmx/ifmx04401/lv_server_04
>
> 50238e78 5 5 1 32767 15810 PO-B
> /ifmx/ifmx04401/lv_emm0_01
>
> 50131b18 6 5 1 32767 28161 PO-B
> /ifmx/ifmx04401/lv_emm0_02
>
> 50131ca0 7 6 1 24575 1779 PO-B
> /ifmx/ifmx04401/lv_ollp_01
>
> 50131e28 8 6 1 16383 16022 PO-B
> /ifmx/ifmx04401/lv_ollp_02
>
> 50227630 9 7 1 122879 324 PO-B
> /ifmx/ifmx04401/lv_outb_01
>
> 502277b8 10 7 1 122879 83518 PO-B
> /ifmx/ifmx04401/lv_outb_02
>
> 50227940 11 7 1 131071 131068 PO-B
> /ifmx/ifmx04401/lv_outb_03
>
> 50227ac8 12 3 1 131071 8668 PO-B
> /ifmx/ifmx04401/lv_server_03_01
>
> 50227c50 13 8 0 131000 0 PD-B
> /ifmx/ifmx04401/lv_powr_18
>
> 50227dd8 14 8 1 32767 0 PD-B
> /ifmx/ifmx04401/lv_powr_01
>
> 50a3e018 15 8 1 65
The restore was sufficient. Thanks for everyone's suggestions.
Thanks,
*******************************************************************
Ernie Knox
IT Database Administrator Specialist
Sears Holdings - BU: I & T Group
3333 Beverly Rd., B4-266A
Hoffman Estates, IL. 60179
Office: (847) 286-5735
Email: Ernest.Knox@searshc.com
Blackberry: 2244650553@messaging.sprintpcs.com
Page via Skytel: 2244650553@sprint.skytel.com
Informix or MySQL Primary: 9110210@skytel.com
Informix or MySQL Secondary: 7276872@skytel.com
" Yes we can make a Change! "
" It's always a great day to watch Sports - GO LIONS, TIGERS, and BEARS!
"
" Lets not forget - GO Pistons and Red Wings! "
GSU
*******************************************************************
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
Knox, Ernest
Sent: Saturday, January 08, 2011 7:51 PM
To: ids@iiug.org
Subject: RE: DBspace powrs_01 is disabled. [22379]
I have been in touch with IBM and they can bring the chunks on-line from
our contract.
I am going to perform an ontape restore, first.
Thanks,
*******************************************************************
Ernie Knox
IT Database Administrator Specialist
Sears Holdings - BU: I & T Group
3333 Beverly Rd., B4-266A
Hoffman Estates, IL. 60179
Office: (847) 286-5735
Email: Ernest.Knox@searshc.com
Blackberry: 2244650553@messaging.sprintpcs.com
Page via Skytel: 2244650553@sprint.skytel.com
Informix or MySQL Primary: 9110210@skytel.com
Informix or MySQL Secondary: 7276872@skytel.com
" Yes we can make a Change! "
" It's always a great day to watch Sports - GO LIONS, TIGERS, and BEARS!
"
" Lets not forget - GO Pistons and Red Wings! "
GSU
*******************************************************************
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
Art Kagel
Sent: Saturday, January 08, 2011 7:48 PM
To: ids@iiug.org
Subject: Re: DBspace powrs_01 is disabled. [22378]
If the dbspace was disabled in a way that wouldn't't cause corruption or
inconsistencies you can call IBM and the can mark it online. Otherwise
restore and roll forward logical logs.
Art
On Jan 8, 2011 6:00 PM, "Knox, Ernest" <Ernest.Knox@searshc.com> wrote:
> We use AIX 5.3.0.0 with IDS 10.00.UC5:
>
> Any solutions before I restore the instance from ontape backup?
>
> 06:45:20 Maximum server connections 56
>
> 15:12:12 IBM Informix Dynamic Server Started.
>
> 15:12:13 VP pid=31236 priority fixed at 60, former = 71
>
> Sat Jan 8 15:12:14 2011
>
> 15:12:14 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has
insecure
> permissions
>
> 15:12:14 Event alarms enabled. ALARMPROG =
> '/ifmx/ifmx04401/fs_server/etc/log_full.sh'
>
> 15:12:14 Booting Language <c> from module <>
>
> 15:12:14 Loading Module <CNULL>
>
> 15:12:14 Booting Language <builtin> from module <>
>
> 15:12:14 Loading Module <BUILTINNULL>
>
> 15:12:19 DR: DRAUTO is 0 (Off)
>
> 15:12:19 AIX MP latch code enabled
>
> 15:12:20 IBM Informix Dynamic Server Version 10.00.UC5 Software
> Serial Number AAA#B000000
>
> 15:12:21 IBM Informix Dynamic Server Initialized -- Shared Memory
> Initialized.
>
> 15:12:21 Physical Recovery Started at Page (2:12279).
>
> 15:12:21 Physical Recovery Complete: 0 Pages Examined, 0 Pages
> Restored.
>
> 15:12:21 Logical Recovery Started.
>
> 15:12:21 10 recovery worker threads will be started.
>
> 15:12:23 Rollforward of log record failed. iserrno = 126
>
> 15:12:23 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:42 Assert Warning: Chunk 14 is being taken OFFLINE.
>
> 15:12:42 IBM Informix Dynamic Server Version 10.00.UC5
>
> 15:12:42 Who: Session(12, informix@sls0440, 0, 5022c118)
>
> Thread(27, xchg_1.3, 502031b4, 1)
>
> File: rsmirror.c Line: 1922
>
> 15:12:42 Results: DBspace powrs_01 is disabled.
>
> 15:12:42 Action: Restore DBspace powrs_01
>
> 15:12:42 stack trace for pid 31236 written to /tmp/af.403d334
>
> 15:12:42 See Also: /tmp/af.403d334
>
> 15:12:43 Chunk 14 is being taken OFFLINE.
>
> 15:12:43 Rollforward of log record failed. iserrno = 126
>
> 15:12:43 Log Record: log = 17319, pos = 0x29e044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:45 Rollforward of log record failed. iserrno = 101
>
> 15:12:45 Log Record: log = 17319, pos = 0x29f044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:47 Rollforward of log record failed. iserrno = 101
>
> 15:12:47 Log Record: log = 17319, pos = 0x2a0044, type =
> OLDRSAM:HINSERT(40), trans = 34
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:12:49 Log Record: log = 17319, pos = 0x2a1044, type =
> OLDRSAM:HINSERT(40), trans = 23
>
> 15:12:49 Rollforward of log record failed. iserrno = 101
>
> 15:19:48 Log Record: log = 17319, pos = 0x9d60d8, type =
> OLDRSAM:HUPAFT(43), trans = 67
>
> 15:19:50 Logical Recovery has reached the transaction cleanup phase.
>
> 15:19:50 Logical Recovery Complete.
>
> 2434 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks
>
> 15:19:52 Dataskip is now OFF for all dbspaces
>
> 15:19:52 Checkpoint Completed: duration was 0 seconds.
>
> 15:19:52 Checkpoint loguniq 17319, logpos 0x9e4018, timestamp:
> 0x47a12fc5
>
> 15:19:52 Maximum server connections 0
>
> 15:19:52 On-Line Mode
>
> 15:20:07 Booting Language <spl> from module <>
>
> 15:20:07 Loading Module <SPLNULL>
>
> 15:20:20 Checkpoint Completed: duration was 0 seconds.
>
> 15:20:20 Checkpoint loguniq 17319, logpos 0x9e5018, timestamp:
> 0x47a13001
>
> $onstat -d
>
> IBM Informix Dynamic Server Version 10.00.UC5 -- On-Line -- Up
> 01:43:15 -- 621984 Kbytes>
> Dbspaces
>
> address number flags fchunk nchunks pgsize flags owner
> name
>
> 501317e8 1 0x40001 1 1 4096 N B
> informix rootdbs
>
> 50a3fde0 2 0x40001 2 1 4096 N B
> informix plogdbs
>
> 50a40018 3 0x40001 3 2 4096 N B
> informix llogdbs
>
> 50a40178 4 0x42001 4 1 4096 N TB
> informix tempdbs01
>
> 50a402d8 5 0x40001 5 2 4096 N B
> informix emm0s_01
>
> 50a40438 6 0x40001 7 2 4096 N B
> informix ollps_01
>
> 50a40598 7 0x40001 9 3 4096 N B
> informix outbs_01
>
> 50a406f8 8 0x40005 14 20 4096 ND B
> informix powrs_01
>
> 50a40858 9 0x40001 21 1 4096 N B
> informix yms_01
>
> 9 active, 2047 maximum
>
> Chunks
>
> address chunk/dbs offset size free bpages flags
> pathname@@NL@
Related threads
- IDS 10 table-level restore
- Informix Development Webinar December 11, 2007
- ontape -p/r with changed ROOTPATH
- Migrate from HP PA-RISC to HP ITANIUM by ontape