Running Informix 7.30 on HPUX 11.0
Posted in 2004
Topics: Installation, Setup & Upgrades, Server Administration
Hello Looing for info/feedback on this combination. I'm troubleshooting a problem where I suspect the informix 7.30 is running in 32-bit mode while the hpux 11 is 64-bit. The software I support is having problems in this environment - mainly errors like "usr/lib/dld.sl unresolved symbol...". I'm pretty new to this - does Informix also install a client on the unix box - like in Windows? If so, where can I find this? I want to ensure this customer is running on the latest version fo the client. Can I check the env variables to see if Informix is running in 32-bit. and also the OS? Thanks!
Chuck C wrote: > Looing for info/feedback on this combination. > > I'm troubleshooting a problem where I suspect the informix 7.30 is > running in 32-bit mode while the hpux 11 is 64-bit. The software I > support is having problems in this environment - mainly errors like > "usr/lib/dld.sl unresolved symbol...". > > I'm pretty new to this - does Informix also install a client on the > unix box - like in Windows? If so, where can I find this? I want to > ensure this customer is running on the latest version fo the client. > > Can I check the env variables to see if Informix is running in 32-bit. > and also the OS? Best thing to do is to look at the version number. If it is 7.30.UCx, it is a 32-bit version. If it is 7.30.FCx, it is a 64-bit version. If it is 7.30.HCx, it is a HP hybrid - which, I think, runs the server in 64-bit and yet allows 32-bit clients to connect, or vice versa. But, you should not be running 7.30.anything; it should be around 7.31.UD7. There are a lot of changes and fixes since 7.30. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/