Problems with Data Replication (WGS)
Posted in 2000
Topics: High Availability & Replication, Networking & sqlhosts Configuration, Platform-Specific Issues
Hi,
We are using Data Replication of Workgroup Server on AIX systems.
For some other reasons the primary server is rebooted every day at 3:00
in the morning. After the reboot sometimes (about once a week) we have
replication problems and the primary server (ESCKV2) seems to be blocked
(does not accept sessions).
Up to now, we have not found a good way to 1) avoid this situation and
2) reactivate DR.
Any ideas?
used protocol between the servers is onsoctcp, Informix versions are
equal, no apparent sqlhosts problems.
DR Settings:
DRAUTO 0
DRTIMEOUT 30
DRINTERVAL 10
Logs:
server ESCKV2
Thu Sep 21 03:08:24 2000
03:08:24 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
03:08:30 DR: DRAUTO is 0 (Off)
03:08:30 AIX MP latch code enabled
03:08:30 Requested shared memory segment size rounded from 796KB to800KB
03:08:30 Informix Dynamic Server Version 7.31.UC5 Software SerialNumber AAC#J915528
03:08:31
03:08:31
03:08:32
03:08:34 Informix Dynamic Server Initialized -- Shared MemoryInitialized.
03:08:34 DR: Trying to connect to secondary server ...
03:08:38 DR: Primary server connected
03:08:38 DR: Receive error
03:08:38 DR: Failure recovery error (2)
03:08:39 Physical Recovery Started.
03:08:39
03:08:40 Physical Recovery Complete: 0 Pages Restored.
03:08:40 Logical Recovery Started.
03:08:40 DR: Turned off on primary server
server ESCKVBO
Thu Sep 21 03:00:32 2000
03:00:32 DR: Receive error
03:00:32 DR: Receive Btree error
03:00:32 DR: Turned off on secondary server
03:08:38 DR: Server state incompatible
07:32:22 DR: Server state incompatible
TIA
Helmut Leininger
Bull AG / Vienna
Open Systems Support
Email: h.leininger@bull.at
helmut.leininger@bull.net
This opinion is mine and not necessarily that of my employer.
No guarantees whatsoever.
a) do not reboot
b) to restart
use ontape to take a level 0 archive on the primary and then
restore the secondary.
You could try shutting down the secondary first then the
primary. Not sure which is the best way to restart them
though!
Helmut Leininger wrote in message <39D9C5FC.3B2D548C@bull.at>...
>Hi,
>
>We are using Data Replication of Workgroup Server on AIX systems.
>
>For some other reasons the primary server is rebooted every day at 3:00
>in the morning. After the reboot sometimes (about once a week) we have
>replication problems and the primary server (ESCKV2) seems to be blocked
>(does not accept sessions).
>
>Up to now, we have not found a good way to 1) avoid this situation and
>2) reactivate DR.
>
>Any ideas?
>
>used protocol between the servers is onsoctcp, Informix versions are
>equal, no apparent sqlhosts problems.
>
>DR Settings:
>
>DRAUTO 0
>DRTIMEOUT 30
>DRINTERVAL 10>
>
>Logs:
>server ESCKV2
>
>Thu Sep 21 03:08:24 2000
>
>03:08:24 Event alarms enabled. ALARMPROG = '/informix/etc/log_full.sh'
>
>03:08:30 DR: DRAUTO is 0 (Off)
>03:08:30 AIX MP latch code enabled
>03:08:30 Requested shared memory segment size rounded from 796KB to>800KB
>03:08:30 Informix Dynamic Server Version 7.31.UC5 Software Serial>Number AAC#J915528
>03:08:31
>03:08:31
>03:08:32
>03:08:34 Informix Dynamic Server Initialized -- Shared Memory>Initialized.
>03:08:34 DR: Trying to connect to secondary server ...
>03:08:38 DR: Primary server connected
>03:08:38 DR: Receive error
>03:08:38 DR: Failure recovery error (2)
>03:08:39 Physical Recovery Started.
>03:08:39
>03:08:40 Physical Recovery Complete: 0 Pages Restored.
>03:08:40 Logical Recovery Started.
>03:08:40 DR: Turned off on primary server>
>
>server ESCKVBO
>
>Thu Sep 21 03:00:32 2000
>
>03:00:32 DR: Receive error
>03:00:32 DR: Receive Btree error
>03:00:32 DR: Turned off on secondary server
>03:08:38 DR: Server state incompatible
>07:32:22 DR: Server state incompatible>
>
>
>TIA
>
>Helmut Leininger
>
>Bull AG / Vienna
>Open Systems Support
>
>Email: h.leininger@bull.at
> helmut.leininger@bull.net
>
>This opinion is mine and not necessarily that of my employer.
>No guarantees whatsoever.
>
>