trouble getting HPUX test/dev system DB loaded aft
Posted in 2016
Topics: Backup & Restore, Installation, Setup & Upgrades, Migration, Import/Export & Data Conversion
HPUX 11.31 (11iv3) on BL870c servers
Informix 12.10.FC6
I know this is slightly off topic.
Recently we migrated from using a EVA4400 as our Informix storage to a 3par
8200 SAN connected to our HPUX servers that run our ERP. The migration went
smoothly. Each HPUX server are identical in configuration and each have one
raw lun attached by fiber to the 3par SAN for the Informix database.
A few days ago I was going to update our test/dev server with a copy of the
production server to test an ERP upgrade. Like I have for the last 10+ years I
made a recovery tape using HPUX's Ignite's make_tape_recovery process. After
loading the OS using the recovery tape I normally would run a ontape -r to
restore the database. this time the ontape -r is giving an error
Physical restore failed - Error opening file /opt/informix/dev/root.1.
errno=19
The 3par lun is a raw lun so the make recovery tape will only bring over the
structure/config of that volume group and not the data.
My question is anyone out there using a HPUX server with a 3par raw lun for
Informix and successfully do a make_tape_recovery to another server? Was there
any special configuration needed? Something on the HPUX side? Something on the
3par side? Something with the make_tape_recovery command?
I have a call into HP and has been kicked up to level 2 but they can't seem to
find the cause or the correction. Only that the volume group information from
the production server did not get moved to the test/dev server. Even when we
manually exported and imported that configuration on the test server Informix
still can't get to the raw lun to restore the data base.
Any help/suggestions would be appreciated
John David Adamski, Sr. Network Specialist
Graceland University, 1 University Place, Lamoni, IA 50140
adamski@graceland.edu
641.784.5267
Error -19 is probably no such device but double check in errno.h
You 100% certain the device is there and dd'able ?
Cheers
Paul
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of John
Adamski (Work Account)
Sent: Friday, September 23, 2016 12:28 PM
To: ids@iiug.org
Subject: trouble getting HPUX test/dev system DB loaded.... [37871]
HPUX 11.31 (11iv3) on BL870c servers
Informix 12.10.FC6
I know this is slightly off topic.
Recently we migrated from using a EVA4400 as our Informix storage to a 3par
8200 SAN connected to our HPUX servers that run our ERP. The migration went
smoothly. Each HPUX server are identical in configuration and each have one
raw lun attached by fiber to the 3par SAN for the Informix database.
A few days ago I was going to update our test/dev server with a copy of the
production server to test an ERP upgrade. Like I have for the last 10+ years
I
made a recovery tape using HPUX's Ignite's make_tape_recovery process. After
loading the OS using the recovery tape I normally would run a ontape -r to
restore the database. this time the ontape -r is giving an error
Physical restore failed - Error opening file /opt/informix/dev/root.1.
errno=19
The 3par lun is a raw lun so the make recovery tape will only bring over the
structure/config of that volume group and not the data.
My question is anyone out there using a HPUX server with a 3par raw lun for
Informix and successfully do a make_tape_recovery to another server? Was
there
any special configuration needed? Something on the HPUX side? Something on
the
3par side? Something with the make_tape_recovery command?
I have a call into HP and has been kicked up to level 2 but they can't seem
to
find the cause or the correction. Only that the volume group information
from
the production server did not get moved to the test/dev server. Even when we
manually exported and imported that configuration on the test server
Informix
still can't get to the raw lun to restore the data base.
Any help/suggestions would be appreciated
John David Adamski, Sr. Network Specialist
Graceland University, 1 University Place, Lamoni, IA 50140
adamski@graceland.edu
641.784.5267
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
Yes the device was/is there. HP never could figure out why the
make_tape_recovery did not copy over the config of the 3par volume group. In
the end did a manual config of the volume group.
My guess is 3par is doing something slightly differently in presenting the raw
lun to HPUX that the EVA did.
After wasting 10 days and no assurance this will not happen again I'm not too
pleased with HPE right now.
John
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Paul
Watson
Sent: Monday, October 03, 2016 6:08 PM
To: ids@iiug.org
Subject: RE: trouble getting HPUX test/dev system DB lo.... [37896]
Error -19 is probably no such device but double check in errno.h
You 100% certain the device is there and dd'able ?
Cheers
Paul
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of John
Adamski (Work Account)
Sent: Friday, September 23, 2016 12:28 PM
To: ids@iiug.org
Subject: trouble getting HPUX test/dev system DB loaded.... [37871]
HPUX 11.31 (11iv3) on BL870c servers
Informix 12.10.FC6
I know this is slightly off topic.
Recently we migrated from using a EVA4400 as our Informix storage to a 3par
8200 SAN connected to our HPUX servers that run our ERP. The migration went
smoothly. Each HPUX server are identical in configuration and each have one
raw lun attached by fiber to the 3par SAN for the Informix database.
A few days ago I was going to update our test/dev server with a copy of the
production server to test an ERP upgrade. Like I have for the last 10+ years I
made a recovery tape using HPUX's Ignite's make_tape_recovery process. After
loading the OS using the recovery tape I normally would run a ontape -r to
restore the database. this time the ontape -r is giving an error
Physical restore failed - Error opening file /opt/informix/dev/root.1.
errno=19
The 3par lun is a raw lun so the make recovery tape will only bring over the
structure/config of that volume group and not the data.
My question is anyone out there using a HPUX server with a 3par raw lun for
Informix and successfully do a make_tape_recovery to another server? Was there
any special configuration needed? Something on the HPUX side? Something on the
3par side? Something with the make_tape_recovery command?
I have a call into HP and has been kicked up to level 2 but they can't seem to
find the cause or the correction. Only that the volume group information from
the production server did not get moved to the test/dev server. Even when we
manually exported and imported that configuration on the test server Informix
still can't get to the raw lun to restore the data base.
Any help/suggestions would be appreciated
John David Adamski, Sr. Network Specialist Graceland University, 1 University
Place, Lamoni, IA 50140 adamski@graceland.edu
641.784.5267
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.