help!-buffer modified inconsistent chunk
Posted in 2000
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting
Cant bring online up, every time we infup it looks as if its gone online but
straight away I find that its still down and the 'buffer modified
inconsistent chunk' message appears in the errorlog.
It does say in the log that I have an invalid dbspace, 'tempdbs', though its
had this for months without problems!
Copy of error below.
19:29:50 Event alarms enabled. ALARMPROG = '/usr/informix/etc/log_full.sh'
19:29:51 DR: DRAUTO is 0 (Off)
19:29:53 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
19:29:53 Warning: Invalid dbspace 'tempdbs' listed in DBSPACETEMP.
19:29:53 Physical Recovery Started.
19:29:54 Physical Recovery Complete: 128 Pages Restored.
19:29:54 Logical Recovery Started.
19:29:58 Assert Failed: Buffer modified in inconsistent chunk.
19:29:58 Who: Session(10, root@saber, 0, 273002800)
Thread(21, fast_rec, 10438cb0, 1)
19:29:58 Results: Chunk 4 is being taken OFFLINE.
19:29:58 Action: Restore chunk from archive.
19:29:58 See Also: /tmp/af.1580a5, shmem.1580a5.0
19:30:11 Assert Failed: WARNING! Chunk 4 is being taken OFFLINE.
19:30:11 Who: Session(10, root@saber, 0, 273002800)
Thread(21, fast_rec, 10438cb0, 1)
19:30:11 Results: DBspace dbspace_1 is disabled.
19:30:11 Action: Restore DBspace dbspace_1
19:30:11 See Also: /tmp/af.1580a5
19:30:12 Assert Failed: pthdrpage:ptalloc:bad partn page
19:30:12 Who: Session(10, root@saber, 0, 273002800)"actemp" 30 lines, 1414 characters
Well, the message is pretty clear, isn't it? Chunk 4, from dbspace
dbspace_1 is the one at fault. Looks like a restore from archive.
Otherwise, perhaps Tech Support can rescue you.
simon <simon@iisg.co.uk> wrote in message
news:966624654.21657.0.nnrp-08.d4f0950b@news.demon.co.uk...
> Cant bring online up, every time we infup it looks as if its gone online
but
> straight away I find that its still down and the 'buffer modified
> inconsistent chunk' message appears in the errorlog.
>
>
> It does say in the log that I have an invalid dbspace, 'tempdbs', though
its
> had this for months without problems!
>
> Copy of error below.
>
>
>
> 19:29:50 Event alarms enabled. ALARMPROG =
'/usr/informix/etc/log_full.sh'
> 19:29:51 DR: DRAUTO is 0 (Off)
> 19:29:53 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 19:29:53 Warning: Invalid dbspace 'tempdbs' listed in DBSPACETEMP.
> 19:29:53 Physical Recovery Started.
> 19:29:54 Physical Recovery Complete: 128 Pages Restored.
> 19:29:54 Logical Recovery Started.
> 19:29:58 Assert Failed: Buffer modified in inconsistent chunk.
> 19:29:58 Who: Session(10, root@saber, 0, 273002800)
> Thread(21, fast_rec, 10438cb0, 1)
> 19:29:58 Results: Chunk 4 is being taken OFFLINE.
> 19:29:58 Action: Restore chunk from archive.
> 19:29:58 See Also: /tmp/af.1580a5, shmem.1580a5.0
> 19:30:11 Assert Failed: WARNING! Chunk 4 is being taken OFFLINE.
> 19:30:11 Who: Session(10, root@saber, 0, 273002800)
> Thread(21, fast_rec, 10438cb0, 1)
> 19:30:11 Results: DBspace dbspace_1 is disabled.
> 19:30:11 Action: Restore DBspace dbspace_1
> 19:30:11 See Also: /tmp/af.1580a5
> 19:30:12 Assert Failed: pthdrpage:ptalloc:bad partn page
> 19:30:12 Who: Session(10, root@saber, 0, 273002800)> "actemp" 30 lines, 1414 characters
>
>
Sometimes the dump files (in DUMPDIR; /tmp/af.1580a5 in your case)
created from an assert failure can provide suggestions to resolve a problem.
My experiences with these failures is limited to damaged indexes which are
usually easy to recover.
The DBSPACETEMP parm in your onconfig file should match the
DBSPACETEMP environment variable for the user that starts the database.
simon wrote:
> Cant bring online up, every time we infup it looks as if its gone online but
> straight away I find that its still down and the 'buffer modified
> inconsistent chunk' message appears in the errorlog.
>
> It does say in the log that I have an invalid dbspace, 'tempdbs', though its
> had this for months without problems!
>
> Copy of error below.
>
> 19:29:50 Event alarms enabled. ALARMPROG = '/usr/informix/etc/log_full.sh'
> 19:29:51 DR: DRAUTO is 0 (Off)
> 19:29:53 INFORMIX-OnLine Initialized -- Shared Memory Initialized.
> 19:29:53 Warning: Invalid dbspace 'tempdbs' listed in DBSPACETEMP.
> 19:29:53 Physical Recovery Started.
> 19:29:54 Physical Recovery Complete: 128 Pages Restored.
> 19:29:54 Logical Recovery Started.
> 19:29:58 Assert Failed: Buffer modified in inconsistent chunk.
> 19:29:58 Who: Session(10, root@saber, 0, 273002800)
> Thread(21, fast_rec, 10438cb0, 1)
> 19:29:58 Results: Chunk 4 is being taken OFFLINE.
> 19:29:58 Action: Restore chunk from archive.
> 19:29:58 See Also: /tmp/af.1580a5, shmem.1580a5.0
> 19:30:11 Assert Failed: WARNING! Chunk 4 is being taken OFFLINE.
> 19:30:11 Who: Session(10, root@saber, 0, 273002800)
> Thread(21, fast_rec, 10438cb0, 1)
> 19:30:11 Results: DBspace dbspace_1 is disabled.
> 19:30:11 Action: Restore DBspace dbspace_1
> 19:30:11 See Also: /tmp/af.1580a5
> 19:30:12 Assert Failed: pthdrpage:ptalloc:bad partn page
> 19:30:12 Who: Session(10, root@saber, 0, 273002800)> "actemp" 30 lines, 1414 characters