OnLine Initialization failure.
Posted in 2000
Topics: Logging & Checkpoints
Hi guys, I got the following Alarm message : Tue Jun 13 13:44:39 PDT 2000 Severity : 3 OnLine Initialization failure. WARNING! Physical Log size 40960 is too small. Physical Log overflows may occur during peak activity. Recommended minimum Physical Log size is 20 times maximum concurrent user threads. Does a Physical log overflow ever occurs? If the physical log becomes 75% full, it will initiate a checkpoint and it will be totally free. Isn't it true? I am getting this message after changing the LRUS from 64 to 65 and CLEANERS from 20 to 65. Has it anything to do with these parameter changes? Thanks in advance Vinod Bhansali ________________________________________________________________________ Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
In article <8i68ia$569$1@news.xmission.com>, Vinod Bhansali <iiug@hotmail.com> writes > >Hi guys, > >I got the following Alarm message : >Tue Jun 13 13:44:39 PDT 2000 >Severity : 3 >OnLine Initialization failure. >WARNING! Physical Log size 40960 is too small. Physical Log overflows may >occur during peak activity. Recommended minimum Physical Log size is 20 >times maximum concurrent user threads. > >Does a Physical log overflow ever occurs? If the physical log becomes 75% >full, it will initiate a checkpoint and it will be totally free. Isn't it >true? > I initiates a checkpoint, but the checkpoint will not start until ALL userthreads exit any critical sections of code which they are in. Last I heard critical sections can generates up to 2 pages of logging I/O. >I am getting this message after changing the LRUS from 64 to 65 and CLEANERS >from 20 to 65. Has it anything to do with these parameter changes? > > > > >Thanks in advance >Vinod Bhansali >________________________________________________________________________ >Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com > -- David Williams
Physical log overflows CAN occur.
The scenario is this:
1) at 75% physical log full, engine raises a checkpoint REQUEST. THIS IS
NOT A CHECKPOINT. It is simply a block that prevents new apps from starting
critical code sections and allows existing apps to continue until they
complete any open critical operations. Updating can continue. When all
active transactions have completed critical operations, the checkpoint is
taken. So, a big transaction can continue to run after the checkpoint
request is raised and cause a physical log overflow.
Once a physical log overflow occurs, the only danger is if system crashes
before a checkpoint can complete. In that case, the system cannot
fast-recover and a restore from archive is required.
Disk is cheap --- make it bigger.
HTH,
Doug
"Vinod Bhansali" <iiug@hotmail.com> wrote in message
news:8i68ia$569$1@news.xmission.com...
>
> Hi guys,
>
> I got the following Alarm message :
> Tue Jun 13 13:44:39 PDT 2000
> Severity : 3
> OnLine Initialization failure.
> WARNING! Physical Log size 40960 is too small. Physical Log overflows may
> occur during peak activity. Recommended minimum Physical Log size is 20
> times maximum concurrent user threads.
>
> Does a Physical log overflow ever occurs? If the physical log becomes 75%
> full, it will initiate a checkpoint and it will be totally free. Isn't it
> true?
>
> I am getting this message after changing the LRUS from 64 to 65 and
CLEANERS> from 20 to 65. Has it anything to do with these parameter changes?
>
>
>
>
> Thanks in advance
> Vinod Bhansali
> ________________________________________________________________________
> Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com
>
Doug's description of an overflow is right on. Changing the LRUS and CLEANERS should not have triggered this message but if you also changed the NETTYPE parameters since the last startup that could cause the message as NETTYPE determines the number of concurrent user thread structures that are allocated by the engine at startup time (in OL5 it was the USERS parameter and in 6.00 -> 7.1x it was USERTHREADS both now unused). Art S. Kagel Vinod Bhansali wrote: > > Hi guys, > > I got the following Alarm message : > Tue Jun 13 13:44:39 PDT 2000 > Severity : 3 > OnLine Initialization failure. > WARNING! Physical Log size 40960 is too small. Physical Log overflows may > occur during peak activity. Recommended minimum Physical Log size is 20 > times maximum concurrent user threads. > > Does a Physical log overflow ever occurs? If the physical log becomes 75% > full, it will initiate a checkpoint and it will be totally free. Isn't it > true? > > I am getting this message after changing the LRUS from 64 to 65 and CLEANERS > from 20 to 65. Has it anything to do with these parameter changes? > > Thanks in advance > Vinod Bhansali > ________________________________________________________________________ > Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com