Initialisation Error [dbspace/shared memory]
Posted in 2000
Topics: Storage & Space Management, Server Administration
I am trying to get an instance of my database with the oninit command. The
command fails with the following error message:
oninit: cannot open chunk /dev/online_root.
I get the same message when I try to initialise parameters with the
onmonitor utility. When I run onmonitor, I have
Root Name [rootdbs ]
Primary Path [/dev/online_root]
If I run dbaccess, and try to access the database server (demo_on), it says
" Shared Memory not initialised".
YOur help will be appreciated.
Jerry Chimutanda wrote:
> I am trying to get an instance of my database with the oninit command. The
> command fails with the following error message:
>
> oninit: cannot open chunk /dev/online_root.
/dev/online_root is the DUMMY name for the root chunk that Informix places into
the sample ONCONFIG file, onconfig.std. You are supposed to edit the file and
replace that with the path of the actual file or device you are going to be
using for
the first root chunk. The file/device MUST exist and have permissions 660,
owner
informix and group informix. If you are using a COOKED filesystem file the
file can
be empty (ie created with touch or cat /dev/null >...) and the engine will
write the
complete contents it wants to the file expanding it to the specified ROOTSIZE.
I posted a message about configuring a Linux IDS server about a week or two ago
search for ROOTPATH in the IIUG archives of CDI, that post had rather complete
instructions which I do not feel like repeating so soon.
Art S. Kagel
>
> I get the same message when I try to initialise parameters with the
> onmonitor utility. When I run onmonitor, I have
> Root Name [rootdbs ]
> Primary Path [/dev/online_root]
>
> If I run dbaccess, and try to access the database server (demo_on), it says
> " Shared Memory not initialised".
>
> YOur help will be appreciated.
Jerry Chimutanda wrote:
> I am trying to get an instance of my database with the oninit command. The
> command fails with the following error message:
>
> oninit: cannot open chunk /dev/online_root.
/dev/online_root is the DUMMY name for the root chunk that Informix places into
the sample ONCONFIG file, onconfig.std. You are supposed to edit the file and
replace that with the path of the actual file or device you are going to be
using for
the first root chunk. The file/device MUST exist and have permissions 660,
owner
informix and group informix. If you are using a COOKED filesystem file the
file can
be empty (ie created with touch or cat /dev/null >...) and the engine will
write the
complete contents it wants to the file expanding it to the specified ROOTSIZE.
I posted a message about configuring a Linux IDS server about a week or two ago
search for ROOTPATH in the IIUG archives of CDI, that post had rather complete
instructions which I do not feel like repeating so soon.
Art S. Kagel
>
> I get the same message when I try to initialise parameters with the
> onmonitor utility. When I run onmonitor, I have
> Root Name [rootdbs ]
> Primary Path [/dev/online_root]
>
> If I run dbaccess, and try to access the database server (demo_on), it says
> " Shared Memory not initialised".
>
> YOur help will be appreciated.