Re: Problem in Informix on Linux.
Posted in 2000
Topics: Installation, Setup & Upgrades, Server Administration, Platform-Specific Issues
From: "CM Inform'tica" <cminform@zaz.com.br>
>
>I install the Informix IDS on Linux and it is ok.
>
>But, a have the following problems:
>
>My environment variables:
>
>INFORMIXDIR=/opt/informix
>INFORMIXSERVER=demo_on>
>The oninit command execute this error.
>
>[informix@cminfo informix]$ oninit -i
>This action will initialize Informix Dynamic Server;
>any existing Informix Dynamic Server databases will NOT be accessible -
>Do you wish to continue (y/n)? y
>
>20:16:45 shmget: [38]: key 52564801: operating system error
>20:16:45 mt_shm_init: can't create resident segment>
>oninit: Fatal error in shared memory creation
Well, this means that the database server didn't come up. Are your kernel
parameters OK?
>When I try to connect in demo_on DATABASE with dbaccess the following error
>occurs.
>
>25588: The appl process cannot connect to Dynamic server demo_on.>No such file or directory
That's just because the database isn't up.
______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com
My parameters of Kernel were not modified after the installation of Linux.
Does some exist parameter that does necessary to be modified ?
Can you inform some parameters important of the kernel used by Informix ?
Thank's
----------------------------------------------------------------------------
--------------------------------------
Obnoxio The Clown escreveu na mensagem <8aag8c$jai$1@news.xmission.com>...
>
>From: "CM Inform'tica" <cminform@zaz.com.br>
>>
>>I install the Informix IDS on Linux and it is ok.
>>
>>But, a have the following problems:
>>
>>My environment variables:
>>
>>INFORMIXDIR=/opt/informix
>>INFORMIXSERVER=demo_on>>
>>The oninit command execute this error.
>>
>>[informix@cminfo informix]$ oninit -i
>>This action will initialize Informix Dynamic Server;
>>any existing Informix Dynamic Server databases will NOT be accessible -
>>Do you wish to continue (y/n)? y
>>
>>20:16:45 shmget: [38]: key 52564801: operating system error
>>20:16:45 mt_shm_init: can't create resident segment>>
>>oninit: Fatal error in shared memory creation
>
>Well, this means that the database server didn't come up. Are your kernel
>parameters OK?
>
>>When I try to connect in demo_on DATABASE with dbaccess the following
error
>>occurs.
>>
>>25588: The appl process cannot connect to Dynamic server demo_on.>>No such file or directory
>
>That's just because the database isn't up.
>______________________________________________________
>Get Your Private, Free Email at http://www.hotmail.com
>