Re: Informix wg server 7.20.uc2 on SCO 5.02 halts with 25580
Posted in 1997
Here is a post I made with the same problem this year...
I got this from my post from w/Dejanews...(search for "informix 25580" in
the old database)
Subject: Re: Problems installing Informix DS on ScoOpen 5
From: "Steven L Cooper" <scooper@thecompounders.com>
Date: 1997/09/25
Message-ID: <01bcc9c0$9b4315a0$7abf6dce@scooper>
Newsgroups: comp.databases.informix,comp.unix.sco.misc
[More Headers]
I had the same problem when installing Informix. This one took a long
weekend and many calls to Informix "tech" support!
We are running SCO OpenServer 5.0.4, so I do not know if all these
parameters are in the same place, but here is part of the EMail I sent to
Informix support...hoping that they would help future customers...
Problem
----------
oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
asfcode='-25580'.
Cannot start engine. This happens during install. Get the same error when
trying to start the engine at any time. The problem seems to be a tune
thing?
From the Informix installation notes and your EMail of past problems, I was
able to get the engine to "run" after manual changing of serveral files!
Solution
----------
NOTICE: It seems that you must edit the mtune, stune and config.h manually
to get SCO to use these values! I even had to add one of the parameters to
the stune file?
stune file (partial)
SEMMNI 2048
SEMMNS 2048
SEMMAP 2048
SEMMNU 100
SEMMSL 60
SHMMAX 671088640
mtune file (partial)
SEMMAP 10 10 8192
SEMMNI 10 10 8192
SEMMNS 60 60 2048
SEMMNU 30 10 100
SEMMSL 25 25 60
XSEMMAX 60 20 90
NOTICE: You must change the maximum values in mtune or stune will NOT
override!
config.h file (partial)
#define SEMMAP 2048
#define SEMMNI 2048
#define SEMMNS 2048
#define SEMMNU 100
#define SEMMSL 60
#define XSEMMAX 60
Hope this helps!
Steve
--
Steven L Cooper
Manager, Systems Engineering
---------------------------------------
The views expressed here are mine and
you can't have them...unless you agree!
v.nguyen@offratel.nc wrote in article <881738432.702283777@dejanews.com>...
> I'm installing informix online workgroup server 7.20.uc2 on SCO 5.02. As
> recommanded by Informix, I've modified kernel parameters and relinked the
> kernel. Installation have completed but when I launch oninit, the systems
> replies : oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA'
> flags; asfcode = '- 25580'.
>
> The online.log sees : 18:13:22 Event alarms enabled. ALARMPROG =
> '/amis/informix/etc/log_full.sh' 18:13:25 DR: DRAUTO is 0 (Off) 18:13:25
> (3) failure, system out of semaphores
>
> What's wrong ? Informix doc talks about SEMMNS, SEMMSL, MAXMEM, SHMALL,
> SHMSEG. I haven't found these parameters in scoadmin ! Are these
> parameters still available under SCO openserver 5.02 ?
>
> Thank you for any help.
> Vincent
> Noum'a
>
> -------------------==== Posted via Deja News ====-----------------------
> http://www.dejanews.com/ Search, Read, Post to Usenet
>