Re: sqlcode < 100
Posted in 1993
You are working on a System V based machine, and are running out of locks. Error -46 is "No record locks available" on System V, but the same text is associated with erro -79 on BSD systems, and error -46 is "Protocol family not supported". Have a good look at your Online configuration if using Online, or the Unix kernel configuration if using SE. And, yes, changing an index from unique to duplicate could alter the locking strategy required, though it is more likely a coincidental result of the increased use which led to you needing to drop the uniqueness of the index. You use finderr to discover what an error message means, but the message texts for the system errors are BSD based, not System V based. Yours, Jonathan Leffler (johnl@obelix.informix.com) #include <disclaimer.h> >From: uunet!mtcdev.MEDIATECH.COM!lei (Charles Lei) >Subject: sqlcode < 100 >Date: Tue, 2 Mar 93 17:57:33 CST >X-Informix-List-Id: <list.1958> >We're running SCO Unix 3.2.4 on 486 PCs with the 4.1 SE and 4.1 I-Net, >plus 4.0 RDS front ends. >All of a sudden we're getting a series of repetitive sqlerrs. This started >happening immediately after we altered an unique index to start accepting >duplicate values. Did this really have anything to do with these problems? >Its looks like we need bump up some of our kernal parameters, but can >someone tell us which ones? >Here is an excerpt from our errlog: > Date: 03/02/1993 Time: 16:01:22 > Program error at "fg_mesg.4gl", line number 138. > SQL statement error number -211. > Cannot read system catalog (systables). > SYSTEM error number -46. >Someone once told me that errors < 100 are system errors, but I cannot >remember how I could go about find out what they really are. Can anyone >help? >Since we're running I-Net, I would assume that these errors are >caused by the parameters on the database server. We should therefore >bump up the kernal parameters there, is this the correct assumption?