New install: Fatal ASF_INIT_DATA error on initialization
Posted in 1999
Topics: Installation, Setup & Upgrades
Hi Folks,
I've got an SGI running IRIX, and I've just installed Informix IDS/UD -
914.UC3-1 on SGI IRIX 6.4, and when I try to finish it off with 'oninit
-i', it replies with:
oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
asfcode = '25507'.
...Of course, 25507 isn't in the error messages manual...
The manuals identify ASF as being associated with connectivity, and
identifies it as the Association Service Facility. I am willing to
believe there's a problem with the connectivity configuration I suppose,
but I can't find anything wrong in particular. (I have reviewed
/etc/hosts, /etc/services, etc.)
I also note that a single semaphore gets created and, though "I" (user
informix) created it, I couldn't delete it (with ipcrm) unless I became
root...
Insights or comments appreciated. (Email reply is also appreciated.)
Regards,
RT
Richard Troy
Chief Scientist, Berkeley Earth Science Tools corporation
rtroy@ScienceTools.com, 510-567-9957
and
Co-Investigator, OceanESIP, Earth System Information Partner Federation
Team Leader, BigSur, The NASA EOS-DIS Alternative Architecture project.
rtroy@cs.berkeley.edu, 510-643-1016 (the other number is better)
On Tue, 19 Jan 1999 17:14:39 -0800, Richard Troy
<rtroy@cs.berkeley.edu> wrote:
>Hi Folks,
>
>I've got an SGI running IRIX, and I've just installed Informix IDS/UD -
>914.UC3-1 on SGI IRIX 6.4, and when I try to finish it off with 'oninit
>-i', it replies with:
>
>oninit: Fatal error in initializing ASF with 'ASF_INIT_DATA' flags;
>asfcode = '25507'.
This is most commonly caused by using the wrong protocol in either
your sqlhosts file and/or your NETTYPE entries in onconfig. If your
informix port uses tli and you specify soc in either of those
locations (or vice-versa) you will get this error. Check your release
notes ($INFORMIXDIR/release/en_us/0333) to see which network interface
was used for your port.
Dave Kosenko
Summit Data Group