Failed to add ODBC driver 3.31 under NT
Posted in 2000
Topics: Connectivity: ODBC / JDBC / .NET
I have downloaded the Informix Client SDK 2.4 and want to set up the ODBC driver 3.31 to talk to a remote database server. The SDK put the 3.31 driver onto my system and I can run the ILogin Demo to connect to the server. However, when I try to add the new driver as datasource with the ODBCAdmin, it gives me an error saying "The procedure entry point InfxRegSqlHostEx2 could not be located in the dynamic link library iregt07b.dll" When I try to add the driver through Microsoft ODBC admin, it gives me the following error. "The setup routines for INFORMIX 3.31 32BIT ODBC driver could not be loaded." What would the problem be? I was able to add the ODBC driver 2.8 but I get an error when I try to connect to the server through OLEDB provider for ODBC driver. "Test connection failed because of an error occur initializing provider. Catastropic failure." I get no error when I try to connect using the Informix ILogin Demo but I have no way to connect to the server through ODBC and OLEDB. What did I do wrong here? -dp Sent via Deja.com http://www.deja.com/ Before you buy.
I get my problem solved. It happens that the ODBC driver expects the Informix directory to be on the system path. The problem solved once I add c:\\Informix\\bin on the system path and reboot. Hope it will help someone in the future. In article <86pq03$c8r$1@nnrp1.deja.com>, dondpoon@my-deja.com wrote: > I have downloaded the Informix Client SDK 2.4 and want to set up the > ODBC driver 3.31 to talk to a remote database server. The SDK put the > 3.31 driver onto my system and I can run the ILogin Demo to connect to > the server. However, when I try to add the new driver as datasource > with the ODBCAdmin, it gives me an error saying > "The procedure entry point InfxRegSqlHostEx2 could not be located in > the dynamic link library iregt07b.dll" > > When I try to add the driver through Microsoft ODBC admin, it gives me > the following error. "The setup routines for INFORMIX 3.31 32BIT ODBC > driver could not be loaded." What would the problem be? > > I was able to add the ODBC driver 2.8 but I get an error when I try to > connect to the server through OLEDB provider for ODBC driver. > "Test connection failed because of an error occur initializing > provider. Catastropic failure." > > I get no error when I try to connect using the Informix ILogin Demo but > I have no way to connect to the server through ODBC and OLEDB. What > did I do wrong here? > > -dp > > Sent via Deja.com http://www.deja.com/ > Before you buy. > Sent via Deja.com http://www.deja.com/ Before you buy.