Re : Erreur lors de la création de table
Posted in 2000
Translated from English by DrWatson — View original
De : John Harman <harmanj@agric.nsw.gov.au> > >Le mercredi 12 janvier 2000, Obnoxio The Clown a écrit : > > > De : John Harman <harmanj@agric.nsw.gov.au> > > > > > > Lorsque j'exécute un ordre SQL pour créer une table, j'obtiens une > > >erreur « constraint already exists », avec un identifiant du type > > >'n359_1147'. Quelqu'un pourrait-il me donner une >piste > > >sur la cause de ce problème ? > > > > Hum. Euh. Vous avez déjà une contrainte nommée n359_1147 sur une autre >table. > > Essayez de nommer explicitement (avec un nom différent) toutes les contraintes de >votre > > nouvelle table. (Celle qui échoue est un NOT NULL, j'imagine) > > > Oui, cette contrainte existe sur une autre table, mais quel rapport >avec celle que j'essaie de créer ? Même sans utiliser de contrainte, >j'obtiens la même erreur, mais l'identifiant de la contrainte est différent à chaque fois. > Le script que j'utilise attribue bien un nom explicite aux >contraintes. Bon, ça va vraiment faire mal, mais que se passe-t-il si vous nommez explicitement toutes les contraintes de la base de données ? ______________________________________________________ Obtenez votre messagerie privée et gratuite sur http://www.hotmail.com