Re: Create table error
Posted in 2000
From: John Harman <harmanj@agric.nsw.gov.au> > >On Wed, 12 Jan 2000, Obnoxio The Clown wrote: > > > From: John Harman <harmanj@agric.nsw.gov.au> > > > > > > When running an sql to create a table, I'm getting a 'constraint > > >already exists' error, with an id like 'n359_1147'. Can anyone give me >a > > >clue what causes this ?? > > > > Um. Errr. You already have a constraint called n359_1147 on another >table. > > Try naming explicitly (to something different) all the contraints on >your > > new table. (The one that's failing is a NOT NULL, I guess) > > > Yes this constraint exists on another table, but what has it to do >with the one that I'm trying to create ?? Even without using a constraint, >it gives me the same error, but the constraint id is different every time. > The script that I'm using does give the constraints an explicit >name. Ok, this is really going to hurt, but what happens if you explicitly name all constraints in the database? ______________________________________________________ Get Your Private, Free Email at http://www.hotmail.com