Re: Listener Thread Error
Posted in 1999
Topics: Networking & sqlhosts Configuration
Sounds like a SCO network driver problem to me. Contact SCO. Art S. Kagel pkedar@hotmail.com wrote: > > Hi all, > > We have Informix 7.3.UC2 running on SCO Unix > V5.05 Rel. 3.2 ( 8 processor machine). > > We have setup NETTYPE as tlitcp,3,100,NET and NUMCPUVPS as 3 though we have > around only 100 connections at a time. > > Around 90% connections transfer blob data on those tcp ports and other around > 10% are decision support connections. > > Our listener thread dies frequently(on average in a week) giving following > error: > > online log 09:19:26 listener-thread: err = -25572: oserr = 4: errstr = : > Network driver ca nnot bind a name to the port. System error = 4. > > and on client side -27001 Read error occurred during connection attempt, > connection reset by peer > > After this error no tcp/ip client connections are allowed though all other > shared memory connections and engine is running fine. > > I would really appreciate any help from all those database experts out > there... > > If anyone needs more info about the problem please post a message. > > Thanks in advance. > > Praveen Kedar > > Sent via Deja.com http://www.deja.com/ > Share what you know. Learn what you don't.
Hi Art,
Thanx for your answer.
I guess tcp listener thread is getting too busy to handle more requests as
finderr of error 27001 shows:
When you encounter this error on the CLIENT side, it indicates that a
network I/O error occurred when the client tried to connect to a
database server. Probably the connection attempt timed out because the
DATABASE SERVER or the network was VERY BUSY, too many clients were
attempting to connect to the database server simultaneously, or the
database server was taken off-line during the connection attempt.
I rule out the possibilities 1.Network is too busy(we restart the engine and
everything is fine) 2. Too many clients( we have setup 300 connections and we
have only 100 connections at a time)
I am suspecting maybe listener thread gets too busy and loopy on some dead
process!!
Is it caused by maybe some users are killing their application while database
is doing some critical SQL processing or power off Client(PC) without closing
application?
FYI i will check LONGSPINS using onstat -g glo next time listener thread goes
down.
Does anybody knows about other possibilities of listener thread going LOOPY?
Is their way to restart listener thread?
Thanks in advance.
Praveen Kedar
In article <37A85A29.D5FAC7B4@bloomberg.net>,
kagel@bloomberg.net wrote:
> Sounds like a SCO network driver problem to me. Contact SCO.
>
> Art S. Kagel
>
> pkedar@hotmail.com wrote:
> >
> > Hi all,
> >
> > We have Informix 7.3.UC2 running on SCO Unix
> > V5.05 Rel. 3.2 ( 8 processor machine).
> >
> > We have setup NETTYPE as tlitcp,3,100,NET and NUMCPUVPS as 3 though we have
> > around only 100 connections at a time.
> >
> > Around 90% connections transfer blob data on those tcp ports and other around
> > 10% are decision support connections.
> >
> > Our listener thread dies frequently(on average in a week) giving following
> > error:
> >
> > online log 09:19:26 listener-thread: err = -25572: oserr = 4: errstr = :
> > Network driver ca nnot bind a name to the port. System error = 4.
> >
> > and on client side -27001 Read error occurred during connection attempt,
> > connection reset by peer
> >
> > After this error no tcp/ip client connections are allowed though all other
> > shared memory connections and engine is running fine.
> >
> > I would really appreciate any help from all those database experts out
> > there...
> >
> > If anyone needs more info about the problem please post a message.
> >
> > Thanks in advance.
> >
> > Praveen Kedar
> >
> > Sent via Deja.com http://www.deja.com/
> > Share what you know. Learn what you don't.
>
Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts