Translating with DrWatson… this can take a few seconds the first time.
This is a genuine, complex translation. DrWatson protects commands, error codes, and log output while naturally translating the surrounding text. It’s translated once and saved.
Gary Quiring — — source: Informix-list mailing list archive (1991-1998)
Date: 01/27/2000 Time: 13:45:35
Program error at "ord_inse.4gl", line number 620.
SQL statement error number -211.
Cannot read system catalog (sysprocauth).
SYSTEM error number -144.
ISAM error: key value locked
The above error caused all of our EDI to fail. We are still in the
learning curve with Informix. Is there anyway to tell what user
caused this error?
Thanks
Gary Quiring
↪ replying to Gary Quiring
Art S. Kagel — — source: Informix-list mailing list archive (1991-1998)
Gary Quiring wrote:
> Date: 01/27/2000 Time: 13:45:35
> Program error at "ord_inse.4gl", line number 620.
> SQL statement error number -211.
> Cannot read system catalog (sysprocauth).
> SYSTEM error number -144.
> ISAM error: key value locked>
> The above error caused all of our EDI to fail. We are still in the
> learning curve with Informix. Is there anyway to tell what user
> caused this error?
Probably caused by someone updating stats on or adding a new stored
predure causing the index node
to be locked. SET LOCK MODE TO WAIT <nsecs> in you application so you
wait for such
short-lived locks to be released instead of getting an error.
Art S. Kagel
↪ replying to Art S. Kagel
Gary Quiring — — source: Informix-list mailing list archive (1991-1998)
On Thu, 27 Jan 2000 16:03:08 -0500, "Art S. Kagel" <kagel@bloomberg.net>
wrote:
>> Date: 01/27/2000 Time: 13:45:35
>> Program error at "ord_inse.4gl", line number 620.
>> SQL statement error number -211.
>> Cannot read system catalog (sysprocauth).
>> SYSTEM error number -144.
>> ISAM error: key value locked>>
>> The above error caused all of our EDI to fail. We are still in the
>> learning curve with Informix. Is there anyway to tell what user
>> caused this error?
>
>Probably caused by someone updating stats on or adding a new stored
>predure causing the index node
>to be locked. SET LOCK MODE TO WAIT <nsecs> in you application so you
>wait for such
>short-lived locks to be released instead of getting an error.
>
>Art S. Kagel
Thanks Art, as usual your answer is on the money. We were updating stats
at 1:00, it ended at 1:49, so it looks like we won't be doing that during
production hours any more.
Thanks
Gary Quiring
We use strictly necessary cookies to make this site work. With your
consent we’d also use optional cookies for analytics and marketing. You can accept all,
reject all, or choose. Read our Cookie Policy.