Assert Warning: chunk failed sanity check
Posted in 2009
Topics: High Availability & Replication, Storage & Space Management, Error Codes & Troubleshooting, Security, Permissions & Auditing, Platform-Specific Issues, Cloud, Docker & Containers, Versions, Editions & End-of-Life
Hello,
We are running IDS 11.10 on Red hat Linux Enterprise edition.
and while running the oninit command we are some errors and the database is
not initialized
i am attaching the out put of online.log and the stack output
I am not sure what is the issue. can someone help?
Thanks
Hari
online.log
___________
03:48:05 IBM Informix Dynamic Server Started.
Fri Jan 16 03:48:06 2009
03:48:06 Event alarms enabled. ALARMPROG = '/u/informix/etc/alarmprogram.sh'
03:48:07 Booting Language <c> from module <>
03:48:07 Loading Module <CNULL>
03:48:07 Booting Language <builtin> from module <>
03:48:07 Loading Module <BUILTINNULL>
03:48:12 Dynamically allocated new virtual shared memory segment (size 8192KB)
03:48:12 Memory sizes:resident:11904 KB, virtual:16384 KB, no SHMTOTAL limit
03:48:12 DR: DRAUTO is 0 (Off)
03:48:12 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
03:48:12 Event notification facility epoll enabled.
03:48:12 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial Number
AAA#B000000
03:48:12 listener-thread: err = -25572: oserr = 99: errstr = : Network driver
cannot bind a name to the port.
System error = 99.
03:48:12 sql_listener: ASF_LISTEN failed
03:48:12 Attempting to bring listener thread down.
03:48:12 Server stopped.
03:48:12 IBM Informix Dynamic Server Stopped.
03:48:12 mt_shm_remove: WARNING: may not have removed all/correct segments
03:59:21 IBM Informix Dynamic Server Started.
Fri Jan 16 03:59:23 2009
03:59:23 Event alarms enabled. ALARMPROG = '/u/informix/etc/alarmprogram.sh'
03:59:23 Booting Language <c> from module <>
03:59:23 Loading Module <CNULL>
03:59:23 Booting Language <builtin> from module <>
03:59:23 Loading Module <BUILTINNULL>
03:59:28 Dynamically allocated new virtual shared memory segment (size 8192KB)
03:59:28 Memory sizes:resident:11904 KB, virtual:16384 KB, no SHMTOTAL limit
03:59:28 DR: DRAUTO is 0 (Off)
03:59:28 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
03:59:28 Event notification facility epoll enabled.
03:59:28 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial Number
AAA#B000000
03:59:28 Assert Warning: chunk failed sanity check
03:59:28 IBM Informix Dynamic Server Version 11.10.UC2
03:59:28 Who: Session(1, root@oas1, 0, 0x44d88018)
Thread(7, main_loop(), 44d59018, 1)
File: rspartn.c Line: 9104
03:59:28 Results: Chunk 1 is being taken OFFLINE.
03:59:28 Action: For all spaces other than temporary dbspaces, restore the
space
containing the chunk from the archive. If this chunk belongs to a
temporary dbspace and if it is not the only chunk in that dbspace,
then drop and re-create the chunk. Otherwise drop and re-create
the temporary dbspace.
03:59:28 stack trace for pid 2350 written to /u/informix/tmp/af.3ef4c70
03:59:28 See Also: /u/informix/tmp/af.3ef4c70
03:59:29 chunk failed sanity check
03:59:30 I/O error, Primary Chunk '/rootdbs/rootdbs' -- Offline (sanity)
03:59:30 IBM Informix Dynamic Server Stopped.
03:59:30 mt_shm_remove: WARNING: may not have removed all/correct segments
18:05:59 sane_chopen:pg_addr 0:0 != expected 1:2
page
45453800: 00000000 00000000 00000000 00000000 ........ ........
45453810 *
18:05:59
18:05:59 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial Number
AAA#B000000
18:05:59 Assert Warning: chunk failed sanity check
18:05:59 Who: Session(1, root@oas1, 0, 0x44d88018)
Thread(7, main_loop(), 44d59018, 1)
File: rspartn.c Line: 9104
18:05:59 Results: Chunk 1 is being taken OFFLINE.
18:05:59 Action: For all spaces other than temporary dbspaces, restore the
space
containing the chunk from the archive. If this chunk belongs to a
temporary dbspace and if it is not the only chunk in that dbspace,
then drop and re-create the chunk. Otherwise drop and re-create
the temporary dbspace.
18:05:59 Raw hex dump of stack located in /u/informix/tmp/af.3efc157.rawstk
18:05:59 Stack for thread: 7 main_loop()
base: 0x453ad000
len: 69632
pc: 0x088c50b1
tos: 0x453bc650
state: running
vp: 1
0x088c50b1 (oninit)afstack (0x4534dbf8, 0xbfe, 0x453bcb60, 0x2390, 0x453bd014,
0xad2e91)
0x088c65ac (oninit)afhandler(0x1, 0x453fefc8, 0x8dd8900, 0x453fee60, 0x401,
0x1)
0x088c697d (oninit)afwarn_interface(0x453fefc8, 0x8dd8900, 0x453fee60,
0x8bea987, 0x2390, 0x1)
0x085ebe72 (oninit)sane_chopen(0x44cd4950, 0x1002, 0x1b6, 0x4, 0x44cd4a84, 0x0)
0x085ec643 (oninit)chopen_util(0x44cd4950, 0x1, 0x453bd3f8, 0x811b188,
0x44cd4950, 0x440902d5)
0x085ecbda (oninit)chopen (0x44cd4950, 0x440902d5, 0x1, 0x0, 0x73756c66,
0x75735f68)
0x0811b188 (oninit)initpzero(0x0, 0x0, 0x453bd47c, 0x7d9, 0x7d9, 0xc16d73)
0x081394e7 (oninit)initseg (0x2, 0x0, 0x453bdee0, 0x8cb2dc0, 0x44090bc4, 0x0)
0x0813bd52 (oninit)main_loop(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
0x088a1a39 (oninit)startup (0x4, 0x453fe868, 0x45397cd8, 0x40868, 0x8a7d6da9,
0x0)
0x00000000 (*nosymtab*)0x(nil)
18:05:59 See Also: /u/informix/tmp/af.3efc157
---------------------------------
Begin System Alarm Program Output
---------------------------------
Assertion Failure Type: Warning
Host Name: oas1
Database Server Name: online
Time of failure: Thu Jan 15 18:06:00 EST 2009
AF file: /u/informix/tmp/af.3efc157
Shared memory file: None
System Blocking: OFF
-------------------------------
End System Alarm Program Output
-------------------------------
18:06:00 sh /u/informix/etc/evidence.sh 1 0 /u/informix/tmp/af.3efc157 1
0x44d59018 7 0x4534dbf8 1025 0 0 0 0
18:06:00
------------------ End of assertion failure 0 -----------------
I'm guessing that there is problem with the hostname in the sqlhosts file.
Either it is qualified with a domain and should not be or it doesn't have a
domain and must. Depends on your system setup.
Art
On Fri, Jan 16, 2009 at 10:45 AM, HARI NARAYANAN <harinarayanan.g@hcl.in>wrote:
> Hello,
>
> We are running IDS 11.10 on Red hat Linux Enterprise edition.
> and while running the oninit command we are some errors and the database is
> not initialized
>
> i am attaching the out put of online.log and the stack output
>
> I am not sure what is the issue. can someone help?
>
> Thanks
> Hari
>
> online.log
> ___________
>
> 03:48:05 IBM Informix Dynamic Server Started.
>
> Fri Jan 16 03:48:06 2009
>
> 03:48:06 Event alarms enabled. ALARMPROG =
> '/u/informix/etc/alarmprogram.sh'
> 03:48:07 Booting Language <c> from module <>
> 03:48:07 Loading Module <CNULL>
> 03:48:07 Booting Language <builtin> from module <>
> 03:48:07 Loading Module <BUILTINNULL>
> 03:48:12 Dynamically allocated new virtual shared memory segment (size
> 8192KB)
> 03:48:12 Memory sizes:resident:11904 KB, virtual:16384 KB, no SHMTOTAL
> limit
> 03:48:12 DR: DRAUTO is 0 (Off)
> 03:48:12 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
> 03:48:12 Event notification facility epoll enabled.
> 03:48:12 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
> Number
> AAA#B000000
> 03:48:12 listener-thread: err = -25572: oserr = 99: errstr = : Network
> driver
> cannot bind a name to the port.
> System error = 99.
> 03:48:12 sql_listener: ASF_LISTEN failed
>
> 03:48:12 Attempting to bring listener thread down.
>
> 03:48:12 Server stopped.
>
> 03:48:12 IBM Informix Dynamic Server Stopped.
>
> 03:48:12 mt_shm_remove: WARNING: may not have removed all/correct segments
> 03:59:21 IBM Informix Dynamic Server Started.
>
> Fri Jan 16 03:59:23 2009
>
> 03:59:23 Event alarms enabled. ALARMPROG =
> '/u/informix/etc/alarmprogram.sh'
> 03:59:23 Booting Language <c> from module <>
> 03:59:23 Loading Module <CNULL>
> 03:59:23 Booting Language <builtin> from module <>
> 03:59:23 Loading Module <BUILTINNULL>
> 03:59:28 Dynamically allocated new virtual shared memory segment (size
> 8192KB)
> 03:59:28 Memory sizes:resident:11904 KB, virtual:16384 KB, no SHMTOTAL
> limit
> 03:59:28 DR: DRAUTO is 0 (Off)
> 03:59:28 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled)
> 03:59:28 Event notification facility epoll enabled.
> 03:59:28 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
> Number
> AAA#B000000
> 03:59:28 Assert Warning: chunk failed sanity check
>
> 03:59:28 IBM Informix Dynamic Server Version 11.10.UC2
> 03:59:28 Who: Session(1, root@oas1, 0, 0x44d88018)
>
> Thread(7, main_loop(), 44d59018, 1)
>
> File: rspartn.c Line: 9104
> 03:59:28 Results: Chunk 1 is being taken OFFLINE.
> 03:59:28 Action: For all spaces other than temporary dbspaces, restore the
> space
>
> containing the chunk from the archive. If this chunk belongs to a
>
> temporary dbspace and if it is not the only chunk in that dbspace,
>
> then drop and re-create the chunk. Otherwise drop and re-create
>
> the temporary dbspace.
> 03:59:28 stack trace for pid 2350 written to /u/informix/tmp/af.3ef4c70
> 03:59:28 See Also: /u/informix/tmp/af.3ef4c70
> 03:59:29 chunk failed sanity check
>
> 03:59:30 I/O error, Primary Chunk '/rootdbs/rootdbs' -- Offline (sanity)
> 03:59:30 IBM Informix Dynamic Server Stopped.
>
> 03:59:30 mt_shm_remove: WARNING: may not have removed all/correct segments
>
> 18:05:59 sane_chopen:pg_addr 0:0 != expected 1:2
> page
> 45453800: 00000000 00000000 00000000 00000000 ........ ........
> 45453810 *
> 18:05:59
> 18:05:59 IBM Informix Dynamic Server Version 11.10.UC2 Software Serial
> Number
> AAA#B000000
>
> 18:05:59 Assert Warning: chunk failed sanity check
>
> 18:05:59 Who: Session(1, root@oas1, 0, 0x44d88018)
>
> Thread(7, main_loop(), 44d59018, 1)
>
> File: rspartn.c Line: 9104
> 18:05:59 Results: Chunk 1 is being taken OFFLINE.
> 18:05:59 Action: For all spaces other than temporary dbspaces, restore the
> space
>
> containing the chunk from the archive. If this chunk belongs to a
>
> temporary dbspace and if it is not the only chunk in that dbspace,
>
> then drop and re-create the chunk. Otherwise drop and re-create
>
> the temporary dbspace.
> 18:05:59 Raw hex dump of stack located in /u/informix/tmp/af.3efc157.rawstk
> 18:05:59 Stack for thread: 7 main_loop()
>
> base: 0x453ad000
> len: 69632
>
> pc: 0x088c50b1
> tos: 0x453bc650
> state: running
>
> vp: 1
>
> 0x088c50b1 (oninit)afstack (0x4534dbf8, 0xbfe, 0x453bcb60, 0x2390,
> 0x453bd014,
> 0xad2e91)
> 0x088c65ac (oninit)afhandler(0x1, 0x453fefc8, 0x8dd8900, 0x453fee60, 0x401,
> 0x1)
> 0x088c697d (oninit)afwarn_interface(0x453fefc8, 0x8dd8900, 0x453fee60,
> 0x8bea987, 0x2390, 0x1)
> 0x085ebe72 (oninit)sane_chopen(0x44cd4950, 0x1002, 0x1b6, 0x4, 0x44cd4a84,
> 0x0)
> 0x085ec643 (oninit)chopen_util(0x44cd4950, 0x1, 0x453bd3f8, 0x811b188,
> 0x44cd4950, 0x440902d5)
> 0x085ecbda (oninit)chopen (0x44cd4950, 0x440902d5, 0x1, 0x0, 0x73756c66,
> 0x75735f68)
> 0x0811b188 (oninit)initpzero(0x0, 0x0, 0x453bd47c, 0x7d9, 0x7d9, 0xc16d73)
> 0x081394e7 (oninit)initseg (0x2, 0x0, 0x453bdee0, 0x8cb2dc0, 0x44090bc4,
> 0x0)
> 0x0813bd52 (oninit)main_loop(0x0, 0x0, 0x0, 0x0, 0x0, 0x0)
> 0x088a1a39 (oninit)startup (0x4, 0x453fe868, 0x45397cd8, 0x40868,
> 0x8a7d6da9,
> 0x0)
> 0x00000000 (*nosymtab*)0x(nil)
>
> 18:05:59 See Also: /u/informix/tmp/af.3efc157
>
> ---------------------------------
> Begin System Alarm Program Output
> ---------------------------------
>
> Assertion Failure Type: Warning
> Host Name: oas1
> Database Server Name: online
> Time of failure: Thu Jan 15 18:06:00 EST 2009
> AF file: /u/informix/tmp/af.3efc157
> Shared memory file: None
> System Blocking: OFF
>
> -------------------------------
> End System Alarm Program Output
> -------------------------------
>
> 18:06:00 sh /u/informix/etc/evidence.sh 1 0 /u/informix/tmp/af.3efc157 1
> 0x44d59018 7 0x4534dbf8 1025 0 0 0 0
> 18:06:00
> ------------------ End of assertion failure 0 -----------------
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
Related threads
- HELP- database won't start !!
- Network driver cannot bind a name to the port.
- Solaris 8, IDSWE 7.31, WARNING: Network Down
- Error 25572 using ESQL/Cobol
- Identically named instances, different hosts