Smart Large Objects error -12097
Posted in 2000
Hello, I have a serious problem with an Informix database that I am using to store Word documents for worldwide distribution. I am using Smart Large Objects to store the documents and when I try and retrieve them (thousands of them that appear to have had no problem last week) I get the following error: -12097 Smart Large Objects: open: Bad smart-large-object address. Object might have been deleted. I opened a trouble ticket with Informix and spoke to an engineer. Here are the results. 1) Informix does not know why the error occurred. There is no patch or open bug report. It is not reproducible. 2) This error has occurred to seven or eight customers with no repeats. The last reported error was 3/19/00. 3) In all cases the solution provided to the customer was to restore the database. 4) In some cases where datablades were being used (we are not using them) the customer was asked to turn on 'Smart Large Object' logging, which we do not have turned on. The engineer does not believe that this is the root cause but could contribute to it not happening again. 5) Although he does not know what caused the problem he was open for speculation. We discussed connection failures during a transaction, engine crashes, rollbacks etc; However, none of the scenarios that we discussed could reasonably produce the current state of the database. Does anyone out there have any idea what the problem could possibly have been to cause such massive data loss ? Any help would be greatly appreciated. Thanks ... Lee