John
Solaris 8 and above has IPV6 tcpip libraries. I4gl 7.20 predates these
libraries so will not run using tcpip. If you are on the same server you
can configure and connect using shared memory, otherwise you must upgrade
i4gl.
MW
> -----Original Message-----
> From: owner-informix-list@iiug.org
> [mailto:owner-informix-list@iiug.org] On Behalf Of Spurgeon, John P
> Sent: Thursday, 14 April 2005 11:11 a.m.
> To: informix-list@iiug.org
> Subject: Anyone using i4gl 7.20 on Solaris 8, 9, or 10 (x86)?
>
> We're trying to upgrade from Solaris 7 (x86) to a more recent
> version of Solaris (x86). We're using i4gl 7.20.UD6, IDS
> 7.31.UD7X5, and the Sun Studio 10 C compiler. When we try to
> connect to a remote database - either at compile time or run
> time - we encounter errors similar to this
> one:
>
> Network driver cannot bind a name to the port.
> See error number -25572.
>
> Shared memory connections do work. It's only when we use
> ontlitcp in sqlhosts that we have a problem.
>
> Is anyone familiar with this issue? Is there a solution, such
> as upgrading our development environment, that will allow us
> to upgrade to a more recent version of Solaris (x86)?
>
> FYI, here's the description of error number -25572:
>
> -25572 Network driver cannot bind a name to the port.
>
> A system call has failed. The sqlexecd daemon or database
> server cannot access the network port that is specified by
> the servicename in the sqlhosts file. This situation might
> occur because the network port is already in use by another
> sqlexecd, database server, or other application. Use a
> different servicename on the command line (prior to Version
> 6.0) or in the sqlhosts file (beginning with Version 6.0).
> Contact your system administrator for assistance.
>
> John
>
> sending to informix-list
>
>
sending to informix-list